04 Duramax wont start! - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-05-2011, 05:12 PM   eBay Motors  #1 (permalink)
 
Join Date: Aug 2011
Location: Alabama
Posts: 6
04 Duramax wont start!

Been having problems with the truck not starting, it happens randomly doesn't matter if it's hot or cold. Took it to the dealer they said it wasn't showing any codes, and every time they tried to start it the truck started right up. Got them to replace the filters and change the oil just in case. Still doesn't start. I can spray starting fluid in and it starts up after a few sprays and trys but then does it again later. I've been told that the fuel pump in the tank is messed up. But that doesn't seem right to me. Any suggestions?
boltonn is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-05-2011, 05:16 PM   eBay Motors  #2 (permalink)
Senior Member
 
RyanZ71's Avatar
 
Join Date: May 2011
Location: Denver, Colorado
Posts: 924
Could be the fuel pump, only way to know is to have the fuel pressure checked.
__________________

2008 GMC 2500 D-Max Crew Cab Long Bed Z71 100% Stock
Real trucks don't need stacks
RyanZ71 is offline   Reply With Quote Quick reply to this message
Old 08-05-2011, 05:19 PM   eBay Motors  #3 (permalink)
Slave to the Interwebs
 
Johnasara's Avatar
 
Join Date: Jan 2008
Location: Roswell, NM
Posts: 9,587
You do not have a fuel pump in the tank. I would look at the filter head. it could have a hairline crack in it causing it to randomly suck air. When you have a no start issue try pumping the primer bulb until it gets hard. Then start it. You should not need any type of starting fluid.
__________________


06 2500 CREW CAB 4X4 LBZ LOONNGGGGG BED
EXHAUST,EFI LIVE,S&B COLD AIR INTAKE
AUTOMETER GAUGES, TRANSGO JR, BLOCKED, TIE ROD SLEEVES...

WORK RIG
2014 3500 CREW,DUALLY, LML, HARBOR 9' UTILITY BED Bone Freakin Stock
This is not only your forum you have to share it with over 100,000 others

Last edited by Johnasara; 08-07-2011 at 02:02 PM.
Johnasara is offline   Reply With Quote Quick reply to this message
Old 08-06-2011, 05:42 PM   eBay Motors  #4 (permalink)
Duramax Lifetime Supporter
Lifetime Supporting Member
 
Siewell Dmax's Avatar
 
Join Date: Sep 2009
Location: Sacramento, CA
Posts: 144
Do not use starting fluid on your truck or it will become parts for the rest of us. I second the filter head is probably the problem their are rebuilt o-ring kits from Merchant that you can probably solve that problem.
__________________
(FOR SALE) 2004 Silverado 2500 HD, LB7, Resonator capped, shiny mod's - billet door handles and buckets, Centerline Blackfoot forged wheels, and a drop in K&N filter. New Headgaskets, Injectors, Cups, Turbo and Nicktane Cat Filter mod. ****(AND IT IS FOR SALE)****
Siewell Dmax is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 01:39 PM   eBay Motors  #5 (permalink)
 
Join Date: Aug 2011
Location: Alabama
Posts: 6
Truck sat for a day got home sat morning fired right up Is there a pick-up pump in the tank, was told by a mechanic about that possibly being it. John are you talking about the fuel filter? Thanks for the input guys, as you can probably tell this is my first diesel. Don't really know alot about the engines.
boltonn is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 02:01 PM   eBay Motors  #6 (permalink)
Slave to the Interwebs
 
Johnasara's Avatar
 
Join Date: Jan 2008
Location: Roswell, NM
Posts: 9,587
Yes the fuel filter head. It is the part the filter screws onto. I hear they cause porblems in the earlier years. Merchant automotive carries a rebuild kit. There is no kind of lift pump in the tank the pump is settled in the lifter valley and it actually sickt the fuel through the filter. That is why it will not run when there is a gap in the system.
__________________


06 2500 CREW CAB 4X4 LBZ LOONNGGGGG BED
EXHAUST,EFI LIVE,S&B COLD AIR INTAKE
AUTOMETER GAUGES, TRANSGO JR, BLOCKED, TIE ROD SLEEVES...

WORK RIG
2014 3500 CREW,DUALLY, LML, HARBOR 9' UTILITY BED Bone Freakin Stock
This is not only your forum you have to share it with over 100,000 others
Johnasara is offline   Reply With Quote Quick reply to this message
Old 08-07-2011, 02:53 PM   eBay Motors  #7 (permalink)
Junior Member
 
Join Date: Jan 2009
Posts: 223
Been through this problem. A: There is no pickup pump in the tank. I know that because I put a Titan 43 gallon tank in my "03. Pickup and sending unit only. B: My problem was an easy fix. Bought the fuel filter head rebuild kit as mentioned above. Took the new stainless steel bleeder valve out of the kit and replaced the plastic POS that is original equipment. Have not had a problem starting in 2 years. Threw the rest of the kit on the shelf just in case. Haven't needed it.
__________________
2003 Extended cab, short bed
GM running boards, Titan 43, Air Lift Bags
Bilsteins all 4, Slider Hitch
Homemade flaps
Montana 29 RK,
Ebbtide 19' 150 horse Johnson, Lowrance Electronics
GPS, Downriggers,
15000 bucks per pound of Fish,
It's worth it!
Bob Trailerhauler is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 01:12 PM   eBay Motors  #8 (permalink)
DuramaxForum n00b
 
Join Date: Sep 2010
Posts: 12
Just DIED !!!

She fired up like normal...NO problem...stopped at the barn to feed
(Ideling maby 10 min) drove about 1/8 of mile to main road to head
to work. Before it shifted into 2nd..lost power & died. Just got to
shoulder in time. Crankes like crazy but will not fire...did the fuel filter bleed..
pumped filter back up...still nothing...
Whats this all about ? I DO HAVE A BAD INJECTOR but would this
cause total shut down & no re-start..?
HELP,
Julie
juloftx is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 02:19 PM   eBay Motors  #9 (permalink)
DuramaxForum Enthusiast
 
brokesmoke's Avatar
 
Join Date: Jul 2012
Location: Charleston, SC
Posts: 3,111
You need to bleed it, crank for 10 seconds, stop, pump again, crank for 10 seconds, pump again. sounds like air in your fuel system. Likely need your filter head rebuilt.

What year is the truck?

Sent from AutoGuide.com Free App
__________________
2005 LLY CCSB LT 4X4
Driven by Austin and Tuned by Kory w/ DSP5
20" XD Hoss/ 305/50/20 Nitto 420S/ Re-routed/ Blocked/ Shimmed/ TBSS Steering Wheel/ Red Head Steering Gearbox/ 5" Diamond Eye Straight Pipe/ Magnaflow DP/ K&N Intake/AFE Mouthpiece/ Factory Touchscreen Navigation Swap/ 2 MTX 10" Subs/ 6000K HIDS lows&fogs/ Recon LED tails/ Kool-Vue Tow Mirrors/ Moog Front End/ Rare Parts Extreme Tie Rods/ ADII 165 w/ CAT filter/ All Seasons Diesel Steering Brace/ 3" Drop Shackles/ Belltech Shocks/ Reflexxion hood/ Autometer Cobalts/ 200K+ Miles of Smiles

What's Next: Trans/Turbo Jan 2015

brokesmoke is offline   Reply With Quote Quick reply to this message
Old 09-26-2013, 02:56 PM   eBay Motors  #10 (permalink)
DuramaxForum n00b
 
Join Date: Sep 2010
Posts: 12
Just DIED !!!

This has been done, 3 to 4 times... Bleeding the system...NO air.
It is an 2004. (old style injectors-JUNK)
Filter head was rebuilt less than a year ago.

When it quit on me....it didn't spit, sputter, nothing.
It was like I reached up there & turned the key off.
Must have been still running as I still had PS & PB.
Julie
juloftx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 04:06 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1