Help.... Slowly loosing my mind.... - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-22-2012, 10:23 AM   eBay Motors  #1 (permalink)
 
Join Date: Nov 2012
Location: Camp Verde Arizona
Posts: 3
Help.... Slowly loosing my mind....

Ok, I bought a 2002 Duramax 2500 HD 4x4 because I had been running a V10 and really wanted to go back to a diesel. It has been a huge mistake so far.

I have been having problems with the truck rarely puffing white smoke (sometimes more that others, most times not at all). A rough idle tends to come and go with the smoke. At first I thought I had an injector failing until my most rescent development.

I was leaving a store the other day (one of those times the truck was missing and smoking). The "wait to start" stayed on much longer than usual and was acompanied by a healthy black cloud at start up. I then noticed my engine temp was reading 0* on my Edge however was reading normal on my dash.... Truck ran rough the whole way home and smoked like a train... Large loss of power.

The next day I hooked it to a scanner and discovered the following codes;

P0101 Mass air flow circuit out of range
P0116 Coolant temperature out of range
P0181 Fuel temperature out of range
P0341 CMP circuit out of range
P0380 Glow plug heater circuit problem

I began pulling and tugging at random wires under the hood then checked the vehicle again. It was like magic... The engine stopped smoking, started running smooth, "wait to start" light started working like normal and the temperature gauge started working on my Edge again.

Fast forward to day...

I was driving home and noticed a significant loss of power. When I got home I turned the truck off then went to cycle it back on it the light stayed on a long time again and the black cloud was back. The edge was working again until I started messing around with the harness above teh left valve cover then it stopped again.

Is this a harness problem, PCM, glow plug controller? Im about ready to drive this thing to Yuma and leave teh keys in the ignition....
__________________
2002 Silverado 2500HD Duramax LB7 4x4
K&N Filter
Highflow Muffler
Edge Attitude
165,000
19.5 Wheels with 245 Tires
travistodd1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-22-2012, 06:16 PM   eBay Motors  #2 (permalink)
DuramaxForum Veteran
 
Earnhardtfan's Avatar
 
Join Date: Mar 2011
Location: Huntersville, NC
Posts: 1,663
The Edge Attitude has been known to mess up the trucks. Try removing it and see how it runs.
__________________
Justin 2001 LB7 Silverado 2500HD LT CCSB 4x4.
EFI Live by Idaho Rob, 356K+ and rolling, Undercover Bed Cover, Vortex spray in bed liner, Westin steps, Bilstein Shocks, Road Master Active Suspension, M/A Pump Rub Kit, MBRP 5" Exhaust, Edge Insight CTS, K&N drop in filter, AirDog II 100 w/ CAT 751, Nicktane w/ CAT, Running on LMM Blacked out Wheels & Michelin LTX M/S2 tires.
ADRENALINE TRUCK PERFORMANCE
APPALACHIAN COAL ROLLERS
Merchant Automotive
Earnhardtfan is offline   Reply With Quote Quick reply to this message
Old 11-22-2012, 06:21 PM   eBay Motors  #3 (permalink)
 
Join Date: Nov 2012
Location: Camp Verde Arizona
Posts: 3
I have already tried but no luck. Seems to not matter of its hooked up or not.
__________________
2002 Silverado 2500HD Duramax LB7 4x4
K&N Filter
Highflow Muffler
Edge Attitude
165,000
19.5 Wheels with 245 Tires
travistodd1 is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 11:36 AM   eBay Motors  #4 (permalink)
 
Join Date: Nov 2012
Location: Camp Verde Arizona
Posts: 3
Ok, update here. Even though the Edge was unhooked and the check engine light was off (truck still running like hell). I decided to check to see if tehre were any codes. Guess what.... lots of them.

I cleared everything out and suddenly everything was great again. I am pleased with the fact that the fix turned out to be so simple however disapointed in Edge.

I do still have one problem, when I first start the truck after it has already warmed up it will puff white smoke for a few seconds then it goes away. No problems that I have noticed when driving or on cold starts. It runs smooth and quiet and has normal power. I do get a rich fuel smell at times (again not constant). I do not smell anything in the oil. I have read some posts about injectors and some have mentioned that a glow plug may cause a similar problem. Anyone have any ideas?

Also, thanks Earndhart fan... for the tip.
__________________
2002 Silverado 2500HD Duramax LB7 4x4
K&N Filter
Highflow Muffler
Edge Attitude
165,000
19.5 Wheels with 245 Tires
travistodd1 is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 01:25 PM   eBay Motors  #5 (permalink)
DuramaxForum Veteran
 
Earnhardtfan's Avatar
 
Join Date: Mar 2011
Location: Huntersville, NC
Posts: 1,663
Good to hear. Definitely look into EFI live, you won't be disappointed. The puff of smoke is not good. Need to see what your balance rates are. Also, some additive could help with the smoking issue. You injectors might be on the way out. I have tried to mod my truck for fuel economy and reliability as you can see in my sig.
__________________
Justin 2001 LB7 Silverado 2500HD LT CCSB 4x4.
EFI Live by Idaho Rob, 356K+ and rolling, Undercover Bed Cover, Vortex spray in bed liner, Westin steps, Bilstein Shocks, Road Master Active Suspension, M/A Pump Rub Kit, MBRP 5" Exhaust, Edge Insight CTS, K&N drop in filter, AirDog II 100 w/ CAT 751, Nicktane w/ CAT, Running on LMM Blacked out Wheels & Michelin LTX M/S2 tires.
ADRENALINE TRUCK PERFORMANCE
APPALACHIAN COAL ROLLERS
Merchant Automotive
Earnhardtfan is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 01:27 PM   eBay Motors  #6 (permalink)
Banned
 
Join Date: Feb 2011
Location: Graham NC
Posts: 2,001
The puff sounds like injector time! Efi live is the way to go for tuning!


Sent from my iPhone using AutoGuide.com App
ferdkila is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 03:49 PM   eBay Motors  #7 (permalink)
DF Sponsors
 
Brent@LDS's Avatar
 
Join Date: Aug 2009
Location: Wisconsin
Posts: 1,299
x2^^sounds like it could be your injectors. Id start the easy way by getting your balance rates and possibly your retrun rates checked.
__________________
Looking for LB7 Injectors?
Check these prices out!....

......... Lincoln Diesel Specialties .........
Phone: 920-765-1615


Click here For,
LB7 Injector Install Instructions
Brent@LDS is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 03:54 PM   eBay Motors  #8 (permalink)
DuramaxForum Enthusiast
 
Thebiggids's Avatar
 
Join Date: Jun 2011
Location: Bellingham, Wa
Posts: 4,345
If its not constantly smoking at idle and only does it on cold starts start with your glow plugs. After all, you did have a glowplug code to start...if not! Injectors :-) time for some 30% overs and efi
__________________
Gideon
01 LB7 EC/SB Ally 4x4 shop ornament
DD: 1990 4runner completely stock 4x4 3.slow


Big Thanks To Adrenaline Truck Performance, Alligator Diesel PerformanceSocal Diesel and Lincoln Diesel Specialties
Thebiggids is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 04:23 PM   eBay Motors  #9 (permalink)
Banned
 
Join Date: Feb 2011
Location: Graham NC
Posts: 2,001
Quote:
Originally Posted by Thebiggids View Post
If its not constantly smoking at idle and only does it on cold starts start with your glow plugs. After all, you did have a glowplug code to start...if not! Injectors :-) time for some 30% overs and efi
Why 30% overs? Efi live on a stock lb7 fuel system is enough to bend rods and lift heads


Sent from my iPhone using AutoGuide.com App
ferdkila is offline   Reply With Quote Quick reply to this message
Old 11-25-2012, 04:27 PM   eBay Motors  #10 (permalink)
DuramaxForum Enthusiast
 
Thebiggids's Avatar
 
Join Date: Jun 2011
Location: Bellingham, Wa
Posts: 4,345
Quote:
Originally Posted by ferdkila View Post
Why 30% overs? Efi live on a stock lb7 fuel system is enough to bend rods and lift heads


Sent from my iPhone using AutoGuide.com App
Why not? Lower pw...lower egts...lower cylinder pressure.
__________________
Gideon
01 LB7 EC/SB Ally 4x4 shop ornament
DD: 1990 4runner completely stock 4x4 3.slow


Big Thanks To Adrenaline Truck Performance, Alligator Diesel PerformanceSocal Diesel and Lincoln Diesel Specialties
Thebiggids is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:26 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1