Oil pressure issue - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-21-2008, 05:07 AM   eBay Motors  #1 (permalink)
Junior Member
 
mjjjweber's Avatar
 
Join Date: Jan 2008
Posts: 3
Oil pressure issue

I had an issue with my oil pressure this morning, Here are the specifics.
2004 Silverado, 2500HD (78,000 Miles), 4X4, Crew Cab, Duramax (LB7), Allison.

This is long winded so bear with me.

It was chilly this morning around 19F. I started the truck and the oil pressure was normal for a cold weather start (80). But a couple of miles down the road I noticed it had went into the red, and down to Zero as I let off the gas, but would briefly reach 20 if I accelerated.

I never once got a check engine light or low pressure chime . I pulled over to make sure I had oil (it was full), and didn't blow a filter (it didn't). I turned around went home and shut it down. When I started it back up everything was normal. I did not get faulty readings from any other gauges.

Any ideas guys? I suspect a gauge. I'm taking it to the dealer today.
mjjjweber is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-21-2008, 08:46 AM   eBay Motors  #2 (permalink)
Yep!
 
deeretracks's Avatar
 
Join Date: Jan 2008
Location: Riverton,Kansas
Posts: 4,901
Im hate to ask but did you let it worm up first? If not it could be that the oil was to coldand thick and it just could not flow proper..Just my thought.
__________________
Craig

01 Dmax CC, SB, 2wd
"All tyranny needs to gain a foothold is for people of good conscience to remain silent". - Thomas Jefferson
Quote:
Originally Posted by Duraskank View Post
So basically this is the only time I'm allowed to call you a giant douchebag pickle smoocher without getting an infraction.


2012 Duramax Forum Best Troll Award Winner for Promoting Jmaz to Admin

deeretracks is offline   Reply With Quote Quick reply to this message
Old 01-22-2008, 05:20 PM   eBay Motors  #3 (permalink)
Junior Member
 
mjjjweber's Avatar
 
Join Date: Jan 2008
Posts: 3
Ya, it was wormed up; actually it was a few miles down the road before it happened.

I took it to the dealer and they said the gauge cluster was bad; there is actually a service bulletin out on this very problem.

Thanks for the reply.
mjjjweber is offline   Reply With Quote Quick reply to this message
Old 01-22-2008, 10:38 PM   eBay Motors  #4 (permalink)
Senior Member
 
Maverick684's Avatar
 
Join Date: Dec 2006
Location: Lubbock, TX
Posts: 852
Yeah mine has been acting a little funky lately. When I start it, it goes to 70 until I start driving it even after being warmed up. We have had some cold mornings for our area like in the teens every morning. BTW my speedo gave my the finger about a month ago. Time for a new cluster.
__________________
John
05' Dmax LLY CC SB, 6in.Fabtech, 20x12 Fuel Krank's, 35in Trail Grapplers and some other stuff
2012 Jeep Grand Cherokee SRT8
2003 Cummins SC LB
Maverick684 is offline   Reply With Quote Quick reply to this message
Old 01-23-2008, 11:00 AM   eBay Motors  #5 (permalink)
Member
 
Supper's Avatar
 
Join Date: Aug 2007
Location: SE Wyoming
Posts: 65
Quote:
Originally Posted by mjjjweber View Post
I took it to the dealer and they said the gauge cluster was bad; there is actually a service bulletin out on this very problem.
Any more info on this service bulletin? I also have some oil pressure gauge issues even after warming the truck up. Especially when we get down in the -20F range.
__________________
2003 GM 2500HD Auto CrewCab Short Bed 130,000 miles. No longer bone stock. 5" turbo-back straight pipe & PPE Standard Xcelerator, transmission and suspension on its way once I can afford them
Supper is offline   Reply With Quote Quick reply to this message
Old 01-23-2008, 12:26 PM   eBay Motors  #6 (permalink)
Senior Member
 
Diesel-N-Dust's Avatar
 
Join Date: Dec 2005
Posts: 239
Yep.It is the guage cluster. Mine did the same thing.
Diesel-N-Dust is offline   Reply With Quote Quick reply to this message
Old 03-27-2008, 10:02 AM   eBay Motors  #7 (permalink)
Junior Member
 
BowtieBrian's Avatar
 
Join Date: Mar 2008
Location: Whereever the rig is parked
Posts: 29
Hey all, I jsut started having the same issue with my oil guage (the needle now pegs out when I go down the road), but I am well over the 70,000 miles GM states in the recall ... anyone have any ideas on the cost to have it fixed?
BowtieBrian is offline   Reply With Quote Quick reply to this message
Old 03-28-2008, 06:06 AM   eBay Motors  #8 (permalink)
Junior Member
 
wgr73's Avatar
 
Join Date: Mar 2008
Posts: 63
Mines doing this too. After I had a car alarm put in yesterday it started doing this...before this it was fine! I think I read in another thread that if you turn off the truck, put it in park and pump the brakes twice it will go away?! Maybe someone can tell me if im right....I sure hope so, I need to get rid of this problem.
wgr73 is offline   Reply With Quote Quick reply to this message
Old 03-28-2008, 08:14 AM   eBay Motors  #9 (permalink)
Member
 
zvacman's Avatar
 
Join Date: Mar 2008
Posts: 30
Last July 5th mine dumped an oil pressure sending unit, but I got the low oil pressure chime.

Z
zvacman is offline   Reply With Quote Quick reply to this message
Old 04-05-2008, 01:39 PM   eBay Motors  #10 (permalink)
Junior Member
 
Join Date: Mar 2008
Posts: 9
Question

Quote:
Originally Posted by zvacman View Post
Last July 5th mine dumped an oil pressure sending unit, but I got the low oil pressure chime.

Z
ya me too! my oil pressure gauge flickers all over the place when it gets low the DIC says low oil pressure.. on a long trip it gets pretty annoying..i changed the oil pressure sensor and it didn't fix it $104 how do i fix it????...cluster was changed a year ago.. let me know thanks
__________________
2003 Dmax GMC ext-cab shortbox carbon metallic..PPE Stage 3..Boost valve..Kennedy air intake..nitto 285's..Alpine deck..amp..JL audio subs..A-pillar boost gauge:rockin
03 Dmaxer is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 08:21 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2