Instrument cluster or perhaps not - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-14-2010, 08:58 PM   eBay Motors  #1 (permalink)
 
Join Date: Apr 2010
Posts: 4
Instrument cluster or perhaps not

2004 GMC Duramax, 145,000 miles. Instrument cluster replaced about 95,000 miles ago. Problem then was speedo quit working. Problem now is entire dash does not come alive till I drive 30 seconnds or more, including auto door locks, seat belt light and all gauges. Almost like a bad ground or like the vehicle was started using the autostart (Ultimat-Start) and then it did not allow the full use function to come alive. But I had the autostart replaced and the problem left for a while, but now is back again. Not sure where to look. Any ideas? Thanks.
kpawluk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-15-2010, 02:38 AM   eBay Motors  #2 (permalink)
DuramaxForum n00b
 
Join Date: Jan 2010
Posts: 15
my gauges on my truck do not come on either. i noticed that they do come on when my alternator actually kicks in and does its job. they have always come on for me every time the alt does its job so i have worried about it. mine has been doing it for a couple years now. but could also be something else wrong with yours. could be possible ground or could be just the same thing as miine.
__________________
03 GMC crewcab shortbed, afe stage 2 intake, 5" exhaust straight piped, PPE boost valve, turbo mouth piece mod, PPE excelerator hot+2.
Matzkesdmax is offline   Reply With Quote Quick reply to this message
Old 04-15-2010, 05:34 PM   eBay Motors  #3 (permalink)
 
Join Date: Apr 2010
Posts: 4
Thanks for the reply. On my truck, not only the gauges do not work, the ABS light, seat belt light and door auto lock feature all do not work. Then they come on all at the same time: the dash lights, the gauges, the door locks. Is this also the case for you?
kpawluk is offline   Reply With Quote Quick reply to this message
Old 04-15-2010, 08:13 PM   eBay Motors  #4 (permalink)
 
Join Date: Apr 2010
Posts: 4
Matzkesdmax

How do you know when the alternator kicks in if the gauges are not operating at the time?

Last edited by kpawluk; 04-15-2010 at 08:45 PM. Reason: grammar
kpawluk is offline   Reply With Quote Quick reply to this message
Old 04-20-2010, 02:45 AM   eBay Motors  #5 (permalink)
DuramaxForum n00b
 
Join Date: Jan 2010
Posts: 15
yes the lights in the cluster and the locks do not work until the alt kicks in, i put a meter on it awhile ago to see if it wasnt getting any power and it had power just like 10 volts or something like that then wheen the alt kicked on it was pushing about 14 volts to it. but it has always came on for me just some times it takes awhile for it to come on then some days it comes on right away.
__________________
03 GMC crewcab shortbed, afe stage 2 intake, 5" exhaust straight piped, PPE boost valve, turbo mouth piece mod, PPE excelerator hot+2.
Matzkesdmax is offline   Reply With Quote Quick reply to this message
Old 04-27-2010, 01:32 AM   eBay Motors  #6 (permalink)
Senior Member
 
topherstrux's Avatar
 
Join Date: Apr 2009
Location: Friendswood, Tx.
Posts: 296
Mine has been doing the same thing for a couple of months now?! Anybody?
__________________
2002 GMC cc/dually Regency package
TTS Xtreme tuner stacked with Duramaximizer with N2O baby!
built tranny with ATS TC
Built IHI turbo from Turbochargers.com
Bassani 4 inch exhaust with 6 in. tip
De badged!
Soon to come Water injection to cool things off a bit and 6000K HIDs, and ported MP

12.89 @ 108 655/1187 rwhp/tq on gas at 42 lbs/boost
topherstrux is offline   Reply With Quote Quick reply to this message
Old 04-28-2010, 09:42 AM   eBay Motors  #7 (permalink)
DuramaxForum n00b
 
Join Date: Feb 2010
Posts: 10
Smile

mine too speedo long gone erratic then stuck past 120 mpg wife goes[ omg slow down ]speedo probaly needs stepping motor $60 ebay rest intermittant. anyone post diy speedo rebuild.
chjackso662 is offline   Reply With Quote Quick reply to this message
Old 04-28-2010, 11:11 AM   eBay Motors  #8 (permalink)
DuramaxForum n00b
 
Join Date: Feb 2010
Posts: 10
member infinityfabworks posted a diy on changeing stepper motors
$9.50 + 2.70 shipping ebay think all of mine defective or going that way, same part # all motors same. Two versions new lifetime warranty on motor part or install old part same problem.Service + two way shipping for service+ 60 and up
chjackso662 is offline   Reply With Quote Quick reply to this message
Old 04-28-2010, 02:33 PM   eBay Motors  #9 (permalink)
Junior Member
 
daschae's Avatar
 
Join Date: Aug 2009
Posts: 90
If its multiple componets, check the relay that powers those up, sounds like its worn or sticking. Key comes on, tells PDC (power distribution center) to send out power to components through their relays. Sounds like a bad relay, or possible a shitty wiring job for the auto-start..
__________________
2004 CCSB AFE, Banks Exhaust exhaust, 6in Lift on 35's

2003 CCSB Edge Attitude, Banks Kit, Lowered on 20's
daschae is offline   Reply With Quote Quick reply to this message
Old 04-28-2010, 02:59 PM   eBay Motors  #10 (permalink)
 
Join Date: Apr 2010
Posts: 4
Your answer sounds logical. I have totaly removed the autostart to try and narrow this down. Any thoughts on how to narrow things down further?

Key comes on. Interior lights come on, vehicle starts, no guages or dash indicator lights, radio works, heater works, wipers work, horn too I think. I drive a minute more or less, and then doors lock, fuel level light on, then goes off as gauge lights up, all gauges come alive and all dash indicator lights light up. (This all happens simultaneously.)

Thanks.
kpawluk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 03:24 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2