04 LLY Idles fine,runs rough till warm - Chevy and GMC Duramax Diesel Forum
04.5-05 LLY Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-06-2013, 09:31 AM   eBay Motors  #1 (permalink)
Life Time Supporter
Lifetime Supporting Member
 
Join Date: Aug 2009
Location: Wichita Ks
Posts: 6
04 LLY Idles fine,runs rough till warm

Ok guys i have a 04 LLY with 5" exhaust.other than that,its stock with 150,000 miles. it starts right up and idles fine,put it in gear and take off and it starts surging and has no power.some times it may blow a little white smoke,in one instance it was blowing a lot of black smoke and clattering like the old Fords. never get a CEL during any of this. once its up to operating temp it runs flawless ! it started after i filled up so i naturally thought i had bad fuel. changed the filter,added a whole bottle of DK and a 16oz bottle of 2stroke with no change. my buddy has a cheap scanner that will tell me the DTC.s and fuel pressure but thats about it. No codes and the fuel pressure at idle is around 5500 and when driving it will go up to 19-21K. the new filter was from auto zone(house brand) since they were they only one left open late,but it is a 2 micron filter. I looked at the wiring at the alternater bracket a while back and someone had reaired it in the past and insulated it pretty good. I would think that if that was the problem it wouldn't clear up when the engine warms up?any thoughts ?
Thanks
Tom
West1 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-06-2013, 02:01 PM   eBay Motors  #2 (permalink)
Senior Member
 
Bransjeep's Avatar
 
Join Date: Jun 2011
Location: Reno
Posts: 533
You need to ditch that filter for a GM/Racor Filter. And clean your MAF with the MAF cleaner spray. Then ice pick all your injector connectors. Check the harness that is ziptied to the alternator bracket. Insulate it with heater hose. If nothing changes id bet its injector(s). It was for me when i had the same issues


Sent from my iPhone using AutoGuide.com Free App
__________________
2004.5 Chevy CCSB LT2. Black, 6" tuff country ez ride. 35-12.50r16 Toyo MT. AMP Fourty one-2 wheels painted black. Bilstein 5100's. AMP research elec. steps. 4" MBRP Turbo Back w/5" tip. pcv re-route, modded air box, EFI Live! DSP5 powered by Edge insight CTS...EGR blocked. Viper remote start and alarm. Custom built bumper by CountryBoy2500, with 3000k HID's and Hella 500's. 5000k HID's in lows. Raptor lined rocker panels. Tinted to match and tow mirrors. Energy Suspension Poly bushings. 9 speaker J&L audio setup

coming soon..NBS cab lights
Bransjeep is offline   Reply With Quote Quick reply to this message
Old 01-07-2013, 10:00 AM   eBay Motors  #3 (permalink)
DuramaxForum Fanatic
 
Join Date: Sep 2010
Location: Maritimes, Canada
Posts: 5,442
Quote:
Originally Posted by Bransjeep View Post
You need to ditch that filter for a GM/Racor Filter. And clean your MAF with the MAF cleaner spray. Then ice pick all your injector connectors. Check the harness that is ziptied to the alternator bracket. Insulate it with heater hose. If nothing changes id bet its injector(s). It was for me when i had the same issues


Sent from my iPhone using AutoGuide.com Free App

X2

Follow the list above ^^^^^^ and you will find your issue.
__________________
2005 Silverado EC/SB, LLY, 4WD, EFI DSP5 V2 (Idaho Rob at ATP), Edge CTS w/ EGT probe, LML Exhaust Manifold, PPE shimmed FPRV, Banks LBZ air cleaner, Profab intake, LBZ Turbo Mouthpiece, Kennedy twin lift pumps w/ megafilter, Corsa 304 SS Exhaust, Mike L tranny cooler, EXAXT Steering System, Redhead Power Steering Box w/ Amsoil PS fluid, Green Torsion Keys, Allison Deep Pan w/ Suncoast Filterlock and Transynd ATF, Bilstein 5100's (Norcal), Cognito UCA's, 17" NBS alloy rims, 265/70R17 Michelin LTX M/S2's, Pioneer AVH-P3200BT, CubbyCam Backup Camera, Pop & Lock Power Tailgate Lock, Extang Solid Fold Tonneau Cover, Tekonsha P3 Brake controller, Alphatherm AT-38OD Washer Fluid Heater
MTL_Dmax is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:48 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2