ECU-TCM PRNDL switch issue not like any other! PLEASE HELP! - Chevy and GMC Duramax Diesel Forum
04.5-05 LLY Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-25-2013, 08:25 PM   eBay Motors  #1 (permalink)
 
tnelson013's Avatar
 
Join Date: Jan 2013
Posts: 8
ECU-TCM PRNDL switch issue not like any other! PLEASE HELP!

Hey guys,

ive searched all over the forrums and have seen a couple people with this issue but i cant seem to fix my problem....

Put cab lights on my truck and had a wire short. My ABS, parking brake light, and a service 4wd alert came on and my PRNDL light went out. tripped a code U0101 TCM lost communication. So i got on here and started reading. Today I picked up a new ecm-tmc thinkin for sure that was my problem. put it in the truck and nothing. had my batteries checked and 1 was bad. Bought a new battery put it in and nothing.
heres whats different about my issue compared to the others: my truck will not start. i turn the key over and i have zero cranking power and i cannot clear the U0101 code (with edge CTS).

the only thing i can think of that i havent replaced is the NSBU switch on the driver side of the tranny. Would this be my next step or am i missing something simple? Could the company have written in the wrong vin on the new ecu-tcm?None of my fuses are visably blown. again, i cannot even start my truck unlikw the other forrums i have read with people having the same issue.

i refuse to take my truck to a dealership. ive had nothing but bad experiences with them. Any help would be greatly appreciated.
tnelson013 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-25-2013, 09:21 PM   eBay Motors  #2 (permalink)
 
tnelson013's Avatar
 
Join Date: Jan 2013
Posts: 8
i found anither thread with same issue of truck not starting but there was not a solution. any ideas on whst i should do?
__________________
2004.5 LLY black crew cab debadged
EFI Live, Edge CS, 5" turbo back MBRP exhaust, 8" Pypes Monster tip, S&B cold air intake, EGR blocker plate, Turbo resonator plug, Race valve, Duramax Tuner ECM/TCM, Pcv reroute,Tie rod sleeves
tnelson013 is offline   Reply With Quote Quick reply to this message
Old 01-25-2013, 10:40 PM   eBay Motors  #3 (permalink)
Senior Member
 
Join Date: Jun 2012
Location: ND
Posts: 336
Sure sounds like your burnt out your TCM. I'll almost bet on it.
__________________
2005 Chevy LLY
EFI LIVE by Kory Willis
Stage V PPE trans, ML converter and some other stuff.
whiteoutlly is offline   Reply With Quote Quick reply to this message
Old 01-26-2013, 05:21 AM   eBay Motors  #4 (permalink)
 
tnelson013's Avatar
 
Join Date: Jan 2013
Posts: 8
ive replaced the tcm and before i put the new one in i unhooked the power source for my cab lighta. im about 98% sure thats what caused the short in the first place. i wouldnt think it was my prndl switch because my prndl lights in the instrument panel are still lit and my truck should still start if that was out. and i think that switch being bad would trip a P code and not a U code.
is the new tcm bad? What should i do next?
__________________
2004.5 LLY black crew cab debadged
EFI Live, Edge CS, 5" turbo back MBRP exhaust, 8" Pypes Monster tip, S&B cold air intake, EGR blocker plate, Turbo resonator plug, Race valve, Duramax Tuner ECM/TCM, Pcv reroute,Tie rod sleeves
tnelson013 is offline   Reply With Quote Quick reply to this message
Old 01-26-2013, 08:46 PM   eBay Motors  #5 (permalink)
Senior Member
 
Join Date: Jan 2009
Location: Beautiful California
Posts: 301
Wiggle the key and see if it does anything. Also, cycle the tilt column up and down. There are several circuits on the ignition switch and one is power for the TCM. You could have a back switch or bad connection. Mine did. I kept getting TCM comm errors.

Just a suggestion.

Edit: Forgot something. The TCM is powered via IGN 1. Can you check the voltage? I believe the fuse is post ignition switch so if it's low, it maybe indicate a faulty switch. Since the switch switches several circuits you can lose one (like TCM power) and not others.
__________________
2005 Chevy Silverado 3500LT SRW D/A CC/LB LLY 4x4 (loaded)
LBZ MP, TxCAI, PS Cooler, stack seal, Edge Insight CTS + EGT + EOT, E837 HD Radiator + Aux Radiator w/fan, Earl's trans cooler, mass/IAT shield, LML manifold, SD rotors
NuWa Hitchhiker II LS 29.5LKTG 5th Wheel

Last edited by terryk; 01-26-2013 at 09:23 PM.
terryk is offline   Reply With Quote Quick reply to this message
Old 01-26-2013, 11:31 PM   eBay Motors  #6 (permalink)
Senior Member
 
baconstruction's Avatar
 
Join Date: Jun 2011
Location: madison wi
Posts: 336
if you dont get a gear selection on the dash the truck wont start most time because it does not know what gear it is in. However if you turn the key forward you should be able to clear the code.

Does your lights and radio come on?
__________________
05 lly cc, afe turbo inlet, blocker plate, efi dsp5 by nick (duramaxtuner.com)
baconstruction is offline   Reply With Quote Quick reply to this message
Old 01-27-2013, 01:21 AM   eBay Motors  #7 (permalink)
JUST TROLLING AROUND
Lifetime Supporting Member
 
vinnie gillotti's Avatar
 
Join Date: Feb 2010
Location: NH
Posts: 2,023
check all fuses teh check your wire harness behind alt for caffing and shorts.
__________________
05 lly 2500hd ccsb http://s1135.photobucket.com/albums/m635/vinnie_1965/
vinnie gillotti is offline   Reply With Quote Quick reply to this message
Old 01-27-2013, 01:06 PM   eBay Motors  #8 (permalink)
 
tnelson013's Avatar
 
Join Date: Jan 2013
Posts: 8
its not the ignition or a rubbed wire. i hooked the new ecm up with the bad battery. had tounhook everything when iput the new battery in so the computer had the power to operate correcy. i got my truck running and everything is workin correctly. re routed my wires for the cab lights i put on and got them tucked away. thanks for all the advice
__________________
2004.5 LLY black crew cab debadged
EFI Live, Edge CS, 5" turbo back MBRP exhaust, 8" Pypes Monster tip, S&B cold air intake, EGR blocker plate, Turbo resonator plug, Race valve, Duramax Tuner ECM/TCM, Pcv reroute,Tie rod sleeves
tnelson013 is offline   Reply With Quote Quick reply to this message
Old 01-27-2013, 06:21 PM   eBay Motors  #9 (permalink)
Senior Member
 
Join Date: Jan 2009
Location: Beautiful California
Posts: 301
What exactly was wrong?
__________________
2005 Chevy Silverado 3500LT SRW D/A CC/LB LLY 4x4 (loaded)
LBZ MP, TxCAI, PS Cooler, stack seal, Edge Insight CTS + EGT + EOT, E837 HD Radiator + Aux Radiator w/fan, Earl's trans cooler, mass/IAT shield, LML manifold, SD rotors
NuWa Hitchhiker II LS 29.5LKTG 5th Wheel
terryk is offline   Reply With Quote Quick reply to this message
Old 01-28-2013, 04:31 AM   eBay Motors  #10 (permalink)
 
tnelson013's Avatar
 
Join Date: Jan 2013
Posts: 8
i thought my cab lights sjorted my ecu-tcm so i bought a new one. come to find out i had a bad battery that surged the internal grounding unit on the ecu and fried it. when i put the new one in there wasnt enough power in the battery to reboot the computer so i thought i had another problem. aftet i put the new batteries in i had to disconnect the ecu-tcm and reconnect for it to register.
my problem all along was a bad battery that fried my computer. it just happened to go out after i put my cab lights on. at first i was pretty lit about it but now with the new ecu i can change my driving pattern. went from 18-20mpg to 25mpg this morning on my way to work
__________________
2004.5 LLY black crew cab debadged
EFI Live, Edge CS, 5" turbo back MBRP exhaust, 8" Pypes Monster tip, S&B cold air intake, EGR blocker plate, Turbo resonator plug, Race valve, Duramax Tuner ECM/TCM, Pcv reroute,Tie rod sleeves
tnelson013 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 07:28 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2