P0106 MAP Sensor & Limp - Chevy and GMC Duramax Diesel Forum

06-07 LBZ & LLY Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 22 (permalink) Old 12-01-2009, 12:48 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 21
Send a message via Yahoo to antdolan
P0106 MAP Sensor & Limp

I have gotten P0106 & U0100 codes recently. I removed the MAP & cleaned with some MAF cleaner & it worked great for a few days but codes came back & back into limp mode. Does this mean my MAP sensor needs to be replaced? If so, where would I buy one? Any other ideas of what to try?
I removed my Edge and that didn't seem to help.
Thanks! Tony

2006 GMC Sierra 2500 LBZ
Edge Juice w/ Attitude & hot unlock
TransGo Jr - Volant air intake
MagnaFlow 5" turbo back exhaust
Diamon Eye downpipe - Kennedy boost stick
Blocker plate & finger stick - Firestone airbags
Viair compressor - Train horn -3 gal air tank
34' Thor ToyHauler
antdolan is offline  
Sponsored Links
Advertisement
 
post #2 of 22 (permalink) Old 12-01-2009, 02:02 PM
DF Sponsors
 
IdahoRob's Avatar
 
Join Date: Oct 2005
Posts: 2,321
P0106 is MAP sensor performance issue, not a MAF. The MAF is near the air cleaner, two different sensors.

2007 LBZ tow rig/Daily driver, stock engine 11.70 @ 115mph on #2, 677 HP, MPI Twins
23.5 MPG Diesel Power Challenge 2008
2002 LB7 Max'd Out 9.71@141+MPH on #2 fuel only, MPI Twins


EFI Live, Suncoast Dealer, Dmax Hotrod Parts
Adrenaline Truck Performance 208.484.3670
IdahoRob is offline  
post #3 of 22 (permalink) Old 12-01-2009, 02:06 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 21
Send a message via Yahoo to antdolan
The MAP is giving me problems, not the MAF. I cleaned the MAP with MAF cleaner.

2006 GMC Sierra 2500 LBZ
Edge Juice w/ Attitude & hot unlock
TransGo Jr - Volant air intake
MagnaFlow 5" turbo back exhaust
Diamon Eye downpipe - Kennedy boost stick
Blocker plate & finger stick - Firestone airbags
Viair compressor - Train horn -3 gal air tank
34' Thor ToyHauler
antdolan is offline  
post #4 of 22 (permalink) Old 12-01-2009, 04:29 PM
Administrator
 
jc1843's Avatar
 
Join Date: Jun 2008
Location: So. Cal
Posts: 15,068
Send a message via AIM to jc1843
GM had many problems with the MAP sensor on the 06 vehicles -- one was water into the sensor and freezing. To help the problem, they relocated the sensor. I believe there was a TSB (GM -- Tech Service Bulletin) to do a modification.

I do not have the TSB.

Chevy 04.5 LLY, 2X, shell, XDR, MikeL Heavy duty up-grade, 6spd, TransGo, deep pan, de-badged, 65 Gallon replacement Aero tank, LBZ-mp, Kennedy pump, shimmed, Pre-fuel filter, tow mirrors, BU cam, gauges, GPS, Sirius, bags, custom grille, fender vents, HD trans cooler- Curt front hitch, footwell lights, load lights, Studs, head gaskets.--- Jerry
jc1843 is offline  
post #5 of 22 (permalink) Old 12-22-2009, 06:43 AM
Junior Member
 
chrisk1500's Avatar
 
Join Date: Dec 2009
Posts: 49
Mine is/was doing the same thing.

The GM fix is to attach a 1 1/2" piece of 3/8" brake line to the MAP sensor. The end of the tubing gets cut at a 45* angle. This stops the sensor from freezing up.

Here is a pic I got from another forum of the fix....need to get mine done ASAP...

EDIT - when attaching the tube to the sensor, use epoxy and put a flare on the end of the tubing to prevent it from falling into the intake....that would be bad...
Attached Images
File Type: jpg 2219335.jpg (8.6 KB, 40 views)
chrisk1500 is offline  
post #6 of 22 (permalink) Old 12-22-2009, 07:56 AM
DF Sponsors
 
IdahoRob's Avatar
 
Join Date: Oct 2005
Posts: 2,321
Wow, I would be very hesitant to put that in my intake for fear of it coming of and going through the engine. The MAP have been working fine for 99% of the trucks (if not more), I'd take my chances with the old style.

2007 LBZ tow rig/Daily driver, stock engine 11.70 @ 115mph on #2, 677 HP, MPI Twins
23.5 MPG Diesel Power Challenge 2008
2002 LB7 Max'd Out 9.71@141+MPH on #2 fuel only, MPI Twins


EFI Live, Suncoast Dealer, Dmax Hotrod Parts
Adrenaline Truck Performance 208.484.3670
IdahoRob is offline  
post #7 of 22 (permalink) Old 12-22-2009, 09:34 AM
Junior Member
 
chrisk1500's Avatar
 
Join Date: Dec 2009
Posts: 49
I disagree with your 99% figure. If it were such a small percentage, I doubt GM would have issued the bulletin they did regarding the MAP sensor fix. Up here in colder climates, the MAP freezing is a definite issue with these trucks...

I agree with the fear of the tube going through the engine, but if it is flared properly and epoxied to the MAP, the odds of it falling in are pretty slim. Better chance of being rear-ended when my truck goes immediately into limp mode due to a frozen MAP....

07.5 LMM DMAX, 2500 HD, LT, PCV re-route, resonator delete, Edge EVO/RACE - level 4, colibert gooseneck hitch, Tekonsha PrimusIQ Controller, Access Tonneau Cover, Bushwhacker Pocket flares, Scorpion color match bedliner and rockers, levelled, 285 General AT2's, AFE 4" exhaust, PPE tierod sleeves --> coming soon: lift pump, Trans Go Jr
14.1 @ 96.2 MPH
chrisk1500 is offline  
post #8 of 22 (permalink) Old 12-22-2009, 09:42 AM
DuramaxForum Enthusiast
 
DuramaxSMOKE11's Avatar
 
Join Date: Nov 2008
Location: Altamont, New York
Posts: 2,379
Send a message via AIM to DuramaxSMOKE11
Quote:
Originally Posted by IdahoRob View Post
Wow, I would be very hesitant to put that in my intake for fear of it coming of and going through the engine. The MAP have been working fine for 99% of the trucks (if not more), I'd take my chances with the old style.
i am going to have to argree with rob thats alittle iffie

Mike
2005 Chevy 2500HD Duramax LLY
BANKS ram air intake, MBRP 4" exhaust, CAT DELETE and NO MUFFLER, EGR Deleted, Fisher SS ExtremeV plow, Auto Meter Gauges, Boost, Pyro, Fuel Pressure, turbo resenator blocked off, PCV Reroute. SoCal Stage 1 heads, ARP Studs, BD Manifold, diamond eye down pipe, AFE mouth piece, AFE intercooler pipes, KMC Rokstars 20" wheels with Nitto Terra Grappler AT
EFI LIVE TUNED BY NICK
Big thanks to chad at Alligator performancewww.alligatorperformance.com
DuramaxSMOKE11 is offline  
post #9 of 22 (permalink) Old 12-22-2009, 09:57 AM
DF Sponsors
 
IdahoRob's Avatar
 
Join Date: Oct 2005
Posts: 2,321
Quote:
Originally Posted by chrisk1500 View Post
I disagree with your 99% figure. If it were such a small percentage, I doubt GM would have issued the bulletin they did regarding the MAP sensor fix. Up here in colder climates, the MAP freezing is a definite issue with these trucks...

I agree with the fear of the tube going through the engine, but if it is flared properly and epoxied to the MAP, the odds of it falling in are pretty slim. Better chance of being rear-ended when my truck goes immediately into limp mode due to a frozen MAP....
Your opinion is welcome here. Welcome to the site also.

In all the years working on these trucks and working with 100's upon 100's of customers, I've never heard of this problem. Been wrong before though.

What is freezing? Running water meth? I know where and what it is but have a hard time figuring out how that much moisture could collect in something the is pointing down in the intake manifold, and how it stays frozen in a warm engine.

On GM knowing what is best, I'll hold back my comments

2007 LBZ tow rig/Daily driver, stock engine 11.70 @ 115mph on #2, 677 HP, MPI Twins
23.5 MPG Diesel Power Challenge 2008
2002 LB7 Max'd Out 9.71@141+MPH on #2 fuel only, MPI Twins


EFI Live, Suncoast Dealer, Dmax Hotrod Parts
Adrenaline Truck Performance 208.484.3670

Last edited by IdahoRob; 12-22-2009 at 10:02 AM.
IdahoRob is offline  
post #10 of 22 (permalink) Old 12-22-2009, 10:31 AM
Junior Member
 
chrisk1500's Avatar
 
Join Date: Dec 2009
Posts: 49
I live in the frozen north (Saskatchewan, Canada).

Take yesterday for example. It was -20* C (not too cold) and I drove into the city to pick up some parts for the house. I got to the Home Depot and shut the truck off while I went inside for about an hour. When I came back outside, I turned on the key to let the glows do their thing and then I started the truck. Immediately, the check engine light came on the truck was in 'reduced power mode'. I put the handheld scanner I have in the truck on and came out with a P0106. I cleared the code and it came back immediately.

I drove home in limp mode and got on the internet ASAP. I found that GM has an update (the one I posted about) for the MAP sensor due to it freezing up. I then went outside and pulled the MAP out of the tube. Sure as shit, there was a glop of icy oily goo blocking the hole in the MAP.

I warmed the MAP up, sprayed MAF sensor cleaner in it, and then put it back on the truck. The light didn't come back on and the truck came out of limp mode.

Needless to say, GM's fix looks pretty Mickey Mouse to me, but if it keeps me from getting stranded in the middle of nowhere, I guess I will give it a shot.....

I have not been around the DMAX for very long, but I am certainly no stranger to diesel engines nor am I a stranger to GM vehicles. In fact, I get wholesale pricing at the local dealership parts department because I am in there so often for parts...not the kind of thing to be proud of....LOL!

07.5 LMM DMAX, 2500 HD, LT, PCV re-route, resonator delete, Edge EVO/RACE - level 4, colibert gooseneck hitch, Tekonsha PrimusIQ Controller, Access Tonneau Cover, Bushwhacker Pocket flares, Scorpion color match bedliner and rockers, levelled, 285 General AT2's, AFE 4" exhaust, PPE tierod sleeves --> coming soon: lift pump, Trans Go Jr
14.1 @ 96.2 MPH
chrisk1500 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome