Service 4 Wheel Drive Message - Chevy and GMC Duramax Diesel Forum
2001 - 2007.5 (GMT800) Non Powertrain Discussion of 01 to 07.5 Topics Not related to the Powertrain, interior, suspensions, body,wheels, tires, ect.

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-20-2009, 01:13 PM   eBay Motors  #1 (permalink)
 
Join Date: Oct 2009
Posts: 4
Service 4 Wheel Drive Message

When driving my truck to day I noticed that the service 4wd message was on my DIC. I shut the truck off and restarted the truck. Upon restarting the truck I noticed that while starting it all the led lights on the 4wd push buttons came on never noticed that before but honestly never looked at the buttons while starting the truck.The lights then go out and the led on the 2wd stays lit.

I attempted to push the 4hi button and it appears as if the truck is not going into 4wd. After pushing the 4hi the 2wd light stays on. I do not feel or hear the truck going into 4wd.

Did a search and it appears as if it could be the switch, encoder motor, or actuator on the axle. Are there any tests that I can do to narrow it down. Went to autozone and it showed no codes on their scanner.

Are there any fluid monitors in the 4wd system where there could be low or dirty t-case fluid or axle fluid?

Any help would be greatly appreciated!!!!!!!!

The truck is a 2004 2500 HD with 173,XXX miles...
gixxersixr is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-20-2009, 01:18 PM   eBay Motors  #2 (permalink)
Senior Member
 
03lb7dmax's Avatar
 
Join Date: May 2009
Location: Ohio
Posts: 414
mine also did that. it was the encoder motor! the part was like 90 bucks and pretty easy to change. im not sure if there are any test to narrow down the prob.
__________________
2003 chevy cc,sb 4x4
Engine: LB7 6.6 duramax diesel
Transmission: allison 1000
Mods: transparts stage IV, S/C 1056 converter (built by me), EFI live w/ DSP2, LBZ fuel pressure regulator, 5" flo pro exhaust 6" dual wall tip, airdog 150, PPE billet pickup tube, K&n cold air intake, LB7 mouth piece mod, tripple piller gauge mount w/ fuel pressure,egt and boost, GM touch screen navigation, extang soft bed cover, tow mirrors, debadged
Wheels & Tires: 20"x10" eagle wheels and 33"x12.5"x20" nitto mud grapplers
03lb7dmax is offline   Reply With Quote Quick reply to this message
Old 12-20-2009, 01:38 PM   eBay Motors  #3 (permalink)
Senior Member
 
DieselpoweredGMC's Avatar
 
Join Date: Dec 2009
Location: GA
Posts: 447
Transfer cases need servicing just like trannies
DieselpoweredGMC is offline   Reply With Quote Quick reply to this message
Old 01-11-2010, 07:04 AM   eBay Motors  #4 (permalink)
Junior Member
 
brj833's Avatar
 
Join Date: Sep 2008
Location: norwalk, ct
Posts: 184
Just curious if u ever figured out what was wrong cause mine is doing the same thing
__________________
2003 2500 hd crew cab
-ppe boost increse valve -MBRP 4 in. turbo back into dual 5 in. mitre cut stacks -ppe standard programmer-HID conversion-20% tints -ready lift leveling kit-18" KMC badlands wrapped in 325/60/r18 nitto terra grapplers-S&B intake-tie rod sleeves thanks to idaho rob- 3" body lift- autometer cobalt boost and pyrometer gauges
brj833 is offline   Reply With Quote Quick reply to this message
Old 01-12-2010, 04:55 PM   eBay Motors  #5 (permalink)
 
Join Date: Oct 2009
Posts: 4
I did figure out what it was. It was the dash switch that has the three push buttons on it to select 2hi 4hi 4low. Easy fix for now.....
gixxersixr is offline   Reply With Quote Quick reply to this message
Old 01-12-2010, 08:15 PM   eBay Motors  #6 (permalink)
Junior Member
 
brj833's Avatar
 
Join Date: Sep 2008
Location: norwalk, ct
Posts: 184
how did u determine that was the issue. did u do something in particular or just change the switch with the hopes that was the problem? thanks
__________________
2003 2500 hd crew cab
-ppe boost increse valve -MBRP 4 in. turbo back into dual 5 in. mitre cut stacks -ppe standard programmer-HID conversion-20% tints -ready lift leveling kit-18" KMC badlands wrapped in 325/60/r18 nitto terra grapplers-S&B intake-tie rod sleeves thanks to idaho rob- 3" body lift- autometer cobalt boost and pyrometer gauges
brj833 is offline   Reply With Quote Quick reply to this message
Old 01-25-2010, 08:01 PM   eBay Motors  #7 (permalink)
Yup, it's a dikfir.
 
Join Date: Jan 2009
Location: Chandler, AZ
Posts: 21
I am having the same issue & pretty sure it's my push buttons. What exactly did you replace? Thanks
__________________
2006 GMC Sierra 2500 LBZ
Edge Juice w/ Attitude & hot unlock
TransGo Jr - Volant air intake
MagnaFlow 5" turbo back exhaust
Diamon Eye downpipe - Kennedy boost stick
Blocker plate & finger stick - Firestone airbags
Viair compressor - Train horn -3 gal air tank
34' Thor ToyHauler
antdolan is offline   Reply With Quote Quick reply to this message
Old 01-26-2010, 12:31 PM   eBay Motors  #8 (permalink)
 
Join Date: Jan 2010
Posts: 3
I have '03 gmc 2500 4wd dmax. svc 4wd light keeps coming on, check engine lt comes on and off. trsnfr case switch 2wd/4wd/4low sometimes switches to neutral, 4wd or 4 low and still actually in 2wd. sometimes when it is shut off for a while, it will clear up. has anyone figured out what is really going wrong and what to do?
roydchristopher is offline   Reply With Quote Quick reply to this message
Old 01-26-2010, 01:03 PM   eBay Motors  #9 (permalink)
Junior Member
 
96fast's Avatar
 
Join Date: Nov 2009
Location: Highland, IL
Posts: 129
my old truck was a 2000 half ton truck and it did that same thing w/ the service 4wd light and mine was the switch in the dash. popped front trim panel around the gauges, removed 2 screws(i think) and unplug and replace. very easy to do. my part cost me aroud 60 bucks if i remember right, i know it wasnt a lot.
__________________
2007 2500 Classic CCSB LBZ
265 Dick Cepek FC II
EFI W/DSP5 and egr blocker..thanks to Dustin & Rob @
www.atptrucks.com
Truxedo Bed Cover
Plugged Resonator
Banks CAI
MBRP XP 4'' (missing kitty)
Exhaust & CAI thanks to Nate @
www.performancetruckproducts.com/

2012 Puma 31KBH
96fast is offline   Reply With Quote Quick reply to this message
Old 01-26-2010, 01:15 PM   eBay Motors  #10 (permalink)
Duramax Lifetime Supporter
Lifetime Supporting Member
 
scottdomine's Avatar
 
Join Date: Aug 2009
Location: Phoenix
Posts: 1,420
These switches go bad all the time. Put two in my gasser, never one in the DMax though (yet)
__________________
2002 Silverado 2500HD LB7 FE9 Ext Cab 4x4 LT, Goodyear Wrangler MT/R 285/75R16, Resonator plugged, B&W Turnover ball, LB7 Intake Horn Mod, PPE Airbox mod, Rancho 9000XL shocks, PPE Running Level 3! 4" MBRP Turbo Back,Pillar Mounted Autometer Cobalt Boost and Pyro gauges, PPE Boost Increase Valve

scottdomine is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 11:34 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2