Egr trouble code on 2012 lml - Chevy and GMC Duramax Diesel Forum

2011+ LML Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 17 (permalink) Old 01-14-2012, 12:09 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Location: Castlewood Virginia
Posts: 75
Egr trouble code on 2012 lml

Last night I had a check engine light come on so I pushed the Onstar button they told me if was linked to the egr on the truck..... I was wondern if any of you all had had this code pop up and what was done about it.... Is it safe to drive the truck till Monday rolls around where I can get it to the dealer..

Tyler,24
2012 victory red Chevy 2500hd d/a ex/sb...EFILive by PPEI.....cognito a arms with fox shocks all the way around and steering braces..rare parts tie rod ends..18x9 black xd addicts ...33/12.5/18 toyo open country mt...Ranch hand grill guard ...B&W turn over ball...Armor-thane spray in bed liner...AFE stage 2 intake....Led bulbs here and there....5 inch flo-pro down pipe back exhaust 8 inch black tip....mbrp down pipe.... Egr delete...Auto meter NV boost and pyro gauges ....air dog II 165...built trans with suncoast stuff
Alot more to come

Last edited by Red012; 01-14-2012 at 12:12 PM.
Red012 is offline  
Sponsored Links
Advertisement
 
post #2 of 17 (permalink) Old 01-14-2012, 01:04 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Location: Castlewood Virginia
Posts: 75
The code is P140C

Tyler,24
2012 victory red Chevy 2500hd d/a ex/sb...EFILive by PPEI.....cognito a arms with fox shocks all the way around and steering braces..rare parts tie rod ends..18x9 black xd addicts ...33/12.5/18 toyo open country mt...Ranch hand grill guard ...B&W turn over ball...Armor-thane spray in bed liner...AFE stage 2 intake....Led bulbs here and there....5 inch flo-pro down pipe back exhaust 8 inch black tip....mbrp down pipe.... Egr delete...Auto meter NV boost and pyro gauges ....air dog II 165...built trans with suncoast stuff
Alot more to come
Red012 is offline  
post #3 of 17 (permalink) Old 01-14-2012, 11:14 PM Thread Starter
Junior Member
 
Join Date: Jan 2012
Location: Castlewood Virginia
Posts: 75
Anyone

Tyler,24
2012 victory red Chevy 2500hd d/a ex/sb...EFILive by PPEI.....cognito a arms with fox shocks all the way around and steering braces..rare parts tie rod ends..18x9 black xd addicts ...33/12.5/18 toyo open country mt...Ranch hand grill guard ...B&W turn over ball...Armor-thane spray in bed liner...AFE stage 2 intake....Led bulbs here and there....5 inch flo-pro down pipe back exhaust 8 inch black tip....mbrp down pipe.... Egr delete...Auto meter NV boost and pyro gauges ....air dog II 165...built trans with suncoast stuff
Alot more to come
Red012 is offline  
post #4 of 17 (permalink) Old 01-15-2012, 05:04 AM
Senior Member
 
Join Date: Oct 2010
Location: New orleans
Posts: 419
Na. Haven't and don't remember hearing anybody. Good luck

2011 GMC 3500HD SLT 4x4 DRW CC STORM GRAY/CASHMERE
HS minimax 5' mbrp
2009 CAN AM OUTLANDER 800R (too much to list)
willsdiesel is offline  
post #5 of 17 (permalink) Old 01-15-2012, 05:19 AM
Danno001 is offline  
post #6 of 17 (permalink) Old 04-14-2012, 08:45 PM
Junior Member
 
Join Date: Jan 2012
Location: Magnolia, TX
Posts: 126
any update on this? Did you get the truck fixed?

My truck got stuck a week ago and about 30 miles after getting pulled out the CEL came on, same p140c code. I was about 800 miles from home so i just reset it. It keeps coming back on and at seemingly quicker rates each time. I stopped at a dealership in Hays Kansas on the way back and they said that to diagnose anything would cost a minimum of 90 bucks because they claim o2 sensor is only covered on 36k mile warranty and i have 53k miles. Shouldnt the o2 sensor be covered in the 100k powertrain warranty, or at the very least, the emissions warranty?

How many O2 sensors are on this thing? I assume the sensor behind the cat and before the dpf is the O2 sensor? I checked it and all the wires look fine to me. Could have some water in that connection there but it looks like it needs a special tool to take it apart. Are there any other O2 sensors besides this one?

In any case, im back home now and plan to take the truck back to where i bought it for the DEF recal and see if they can check this while its in, but any input from you guys would be greatly appreciated.

btw when it got stuck, it wasnt burried or anything, the truck just slid into a ditch because the dirt road turned to soup in the rain.


Edit, found another thread that says diesels dont use o2 sensors and that this code could be because of poor egr flow. Is this true? If so, what would cause this? (i idle the truck A LOT but am always able to drive it on the highway for regens)


2015 Sierra 3500 Denali SRW long bed
2011 Sierra 2500 SLE - sold

Last edited by TX2011; 04-14-2012 at 08:48 PM.
TX2011 is offline  
post #7 of 17 (permalink) Old 04-16-2012, 06:29 AM
Junior Member
 
Join Date: Jan 2012
Location: Magnolia, TX
Posts: 126
Anyone?


2015 Sierra 3500 Denali SRW long bed
2011 Sierra 2500 SLE - sold
TX2011 is offline  
post #8 of 17 (permalink) Old 12-12-2012, 11:36 AM
AWM
Senior Member
 
AWM's Avatar
 
Join Date: May 2012
Location: Texas
Posts: 428
Please excuse the thread resurrection but I am now throwing the P140C code. I can only find 3 threads that mention this code and none have an outcome or solution. I installed a S&B intake with an oiled filter on Saturday and on Tuesday, approx. 500 miles later, my CEL came on. Brought it to the dealership today and they showed me a P140C code explanation showing one of the causes as "aftermarket air filter". They hung there hat on this and said no further diagnostics could be completed until the stock box and filter were reinstalled. I purchased some MAF cleaner and plan to clean the MAF check the box connections and clear the code. Any other thoughts or advice?

LML
DELETED/REMOVED/RE-ROUTED
S&B/FASS/FLOPRO
CUSTOM TUNING BY KORY WILLIS
SYNTHETIC MOTORSPORTS
AWM is offline  
post #9 of 17 (permalink) Old 12-12-2012, 01:35 PM
GMC..Professional Grade
 
KensAuto's Avatar
 
Join Date: Apr 2012
Location: Casa Grande, Az
Posts: 3,949
Quote:
Originally Posted by AWM View Post
Please excuse the thread resurrection but I am now throwing the P140C code. I can only find 3 threads that mention this code and none have an outcome or solution. I installed a S&B intake with an oiled filter on Saturday and on Tuesday, approx. 500 miles later, my CEL came on. Brought it to the dealership today and they showed me a P140C code explanation showing one of the causes as "aftermarket air filter". They hung there hat on this and said no further diagnostics could be completed until the stock box and filter were reinstalled. I purchased some MAF cleaner and plan to clean the MAF check the box connections and clear the code. Any other thoughts or advice?
Try cleaning and check tube connections...anything that would throw the MAF off. if that doesn't work, install oem filter. The computor knows exactly what the maf should read under every condition possible, so if it opens the egr a certain amount, the maf should drop to a specific value....it's dropping to much, hence the P0140c, too much egr flow, which means the MAF is reading low (dirty, oily, intake leak, etc.) other things can cause that code, but since it did it immediately after air cleaner replacement you gotta start there

2012 GMC 2500 SLT 4x4
---Arizona Diesel Club---
Member #19
KensAuto is offline  
post #10 of 17 (permalink) Old 12-12-2012, 03:58 PM
AWM
Senior Member
 
AWM's Avatar
 
Join Date: May 2012
Location: Texas
Posts: 428
Thanks Ken. I did as indicated in my post and what Ken suggested then cleared the code. Drove it over 100 miles without an issue. Hope it is not reoccurring as indicated in other's posts.

LML
DELETED/REMOVED/RE-ROUTED
S&B/FASS/FLOPRO
CUSTOM TUNING BY KORY WILLIS
SYNTHETIC MOTORSPORTS
AWM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome