2011 Electrical Problem - Chevy and GMC Duramax Diesel Forum

2011+ LML Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 01-17-2013, 05:45 AM Thread Starter
 
Join Date: Aug 2011
Posts: 9
2011 Electrical Problem

Has anyone heard of any problems with these trucks regarding the electrical.

Here's my problem: Driving truck and gauges started going down to zero/radio shut off/heater quit working/DIC went through alot of problems (check tire pressure/air bags/4wheel drive/etc.) It would do this in approx. 15 minute intervals. I tried to drive it the next day to the dealer and it wouldn't start, so I had it towed. Dealer has been problem solving for a week and can't find the problem, but the truck is mysteriously running fine now, so I am getting it back.

Does anyone have any advice on this. The truck has 25k on it and this is a sudden problem.

Thanks in advance.
PA_DEEREMAN is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 01-17-2013, 06:03 AM
AWM
Senior Member
 
AWM's Avatar
 
Join Date: May 2012
Location: Texas
Posts: 428
Can’t say I have heard of this.... Keep us updated.

LML
DELETED/REMOVED/RE-ROUTED
S&B/FASS/FLOPRO
CUSTOM TUNING BY KORY WILLIS
SYNTHETIC MOTORSPORTS
AWM is offline  
post #3 of 18 (permalink) Old 01-17-2013, 01:49 PM
Guest
 
Join Date: Oct 2012
Location: OkieHomie
Posts: 4,211
never heard of such but am very interested to hear what happened.
Cayenne is offline  
post #4 of 18 (permalink) Old 01-17-2013, 01:58 PM
Senior Member
 
Grasshopper101's Avatar
 
Join Date: Aug 2011
Location: Clarksville TN
Posts: 917
It sounds like a weak alternator that is just keeping the battery barely working.

2011 GMC 2500 HD. First ever diesel and loving it.
PPEI tunes by Kory
Flo-Pro 4" exhaust with muffler
EGR blocker plates
DPF/DEF deleted
Air Dog Lift pump.
Edge CTS
Grasshopper101 is offline  
post #5 of 18 (permalink) Old 01-17-2013, 02:26 PM
GMC..Professional Grade
 
KensAuto's Avatar
 
Join Date: Apr 2012
Location: Casa Grande, Az
Posts: 3,949
Could be anything to do with main power feeds. Battery, batt connections, alternator or lead to alternator, main power leads to underhood fuse block (especially if someone has added something and tied into a main lead somewhere), ground connections, well you get the idea, it really could be anything on these complicated vehicles.

2012 GMC 2500 SLT 4x4
---Arizona Diesel Club---
Member #19
KensAuto is offline  
post #6 of 18 (permalink) Old 01-17-2013, 03:19 PM
Senior Member
 
Grasshopper101's Avatar
 
Join Date: Aug 2011
Location: Clarksville TN
Posts: 917
Agree. I had a vehicle years ago that did weird things like that and it was eventually tracked to the alternator but a bad connection would do the same thing.

2011 GMC 2500 HD. First ever diesel and loving it.
PPEI tunes by Kory
Flo-Pro 4" exhaust with muffler
EGR blocker plates
DPF/DEF deleted
Air Dog Lift pump.
Edge CTS
Grasshopper101 is offline  
post #7 of 18 (permalink) Old 01-17-2013, 08:50 PM
DuramaxForum Veteran
 
DENALI HD3500's Avatar
 
Join Date: Feb 2011
Posts: 1,294
Quote:
Originally Posted by KensAuto View Post
Could be anything to do with main power feeds. Battery, batt connections, alternator or lead to alternator, main power leads to underhood fuse block (especially if someone has added something and tied into a main lead somewhere), ground connections, well you get the idea, it really could be anything on these complicated vehicles.
I agree. I would lean more towards a bad (green) ground, or corroded PCM wire.

2015 SLT CCSB Summit White on Jet Black sunroof/rear slider/driver alert/ cooled/heated leather/nav/ telescope/tilt steer... Z71 package .

Previous:2002 LB7 ECSB
2005 LLY CCSB
2007.5 LMM CCSB
2010 CTD CCSB
2011 LML CCSB
DENALI HD3500 is offline  
post #8 of 18 (permalink) Old 01-17-2013, 08:56 PM
Senior Member
 
FireRescue's Avatar
 
Join Date: Mar 2011
Location: Zanesville, Ohio
Posts: 786
Which trucks had the wiring harness that rubbed and caused problems? Anyway, have batteries checked seperately, have the alternator checked, maybe belts and pulleys. But I would bet it's a wiring issue / connection issue somewhere.

Bryan
2011 Chevrolet Silverado 2500HD WT, Victory Red, 4x4, ECLB, Duramax(LML)/Allison, Heavy Duty Towing Package
Insalled: Amp Research, Amsoil, ATS, Autometer, B&W, Back Rack, Bushwacker, Code Alarm, Cognito, DRP, FASS, Goodyear, H&S, Hypertech, Mayhem, MBRP, Plasti Dip, Precision, Ranch Hand, Rearview Saftey, Rhino Linings, Rigid Industries, Rough Country, S&B, Snow Performance, Titan, Warn, Weather Guard

Need the Guts to Install: Frost Fighter.
FireRescue is offline  
post #9 of 18 (permalink) Old 01-17-2013, 09:26 PM
Junior Member
 
Join Date: Nov 2012
Location: Durango, CO
Posts: 127
This may have changed between 06-11 but I had electrical issues with my stereo, mirror display and airbag light. At first I thought it was just a fuse because my airbag fuse was blown. Replaced it and it was fine for a week or so... Then it happened again, after I released my e-brake. I found a wiring harness on the DS floor board that is behind the e-brake arm, so after pushing it down many times it rubbed the wire coating off and grounded, causing my issues and blown fuses. Repaired the wire and moved harness and haven't had the problem since.

Jeremiah
2006 LBZ W/ EFI DSP 5 by RGR Racing, DP 3794 Stg 2 Turbo, AFE intake and 4" EX. Down pipe, EGR blocked, Autometer boost & pyro gauges. All Amsoil. 235k Miles
D2DAMAX is offline  
post #10 of 18 (permalink) Old 01-18-2013, 12:49 AM
Junior Member
 
Charliechevy's Avatar
 
Join Date: Jul 2012
Location: Alaska
Posts: 177
Quote:
Originally Posted by Grasshopper101 View Post
It sounds like a weak alternator that is just keeping the battery barely working.
Agreed. I had this happen to me on a couple occasions in a gas motor, can be a real PITA if the dealers are clueless.

2015 Chevy 2500 HD Duramax, Crew Cab Z71 LT, Stock for now, Morimoto Retro Kit soon.
Charliechevy is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome