Diesel Exhaust Fluid issue hopefully resolved - Page 7 - Chevy and GMC Duramax Diesel Forum
2011+ LML Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-12-2012, 01:28 PM   eBay Motors  #61 (permalink)
DuramaxForum n00b
 
Join Date: Mar 2012
Location: SE Florida
Posts: 23
I don't care about the regens - it's the problems related to the regen cycles and the sensors, DEF injectors, etc. that are making everyone crazy.
Aside from fixing the system so that it' more reliable using improved software or better sensors, it would be nice to see an additional status screen in the DIC that provides info on regen status and the total number of regen's since last reset. I think the only way to tell if a regen is occurring today is to somehow notice that mileage is worse than usual. That's not very accurate.
__________________
2011 GMC 2500HD
sierra2500HD is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-13-2012, 11:01 AM   eBay Motors  #62 (permalink)
DuramaxForum Enthusiast
 
GMCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 2,112
Congratulations, Jigga99!

Michelle, GM Customer Service
GMCustomerService is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 06:08 PM   eBay Motors  #63 (permalink)
DuramaxForum n00b
 
Join Date: Sep 2012
Posts: 13
hi im new to this site...i bought my 2011 LML in august 2012 with 28500 kms, the week after i bought it i had the def quality poor light come on - dealer said to add fresh fluid cause truck sat for a while, it worked...light went off after adding new fluid after driving 25 miles or so...then engine light came on with a service def system message...brought it to an awesome dealer in michigan when i was camping...they changed a nox sensor...now is there more than one? the invoice says they changed front nox sensor? the truck has been def light free since then, which has been about 2500 kms, but now i just got a poor quality def message again...just wondering if there is another nox sensor at rear, if this could be my problem? dont know if this is related but truck just went through regen that took about 3 days to complete, it actually gave me a message to drive until message disappears (which i did) and then the next day the def quality poor message came on? any info will help..thanks!
gr8dane79 is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 06:22 PM   eBay Motors  #64 (permalink)
GMC..Professional Grade
Lifetime Supporting Member
 
KensAuto's Avatar
 
Join Date: Apr 2012
Location: Casa Grande, Az
Posts: 3,616
pretty sure most guys with NOX sensor problems had the rear one changed, the one at the filter
__________________
2012 GMC 2500 SLT 4x4
H&S minimaxx, MBRP downpipe back SS duals, Insight CTS w/backup cam, Fass HD150, PPE rear diff cover, Amsoil front-rear w/bypass, Cognito 4-6 NTBD w/idler/pitman braces, a-arms, Recon smoked cab lights
Titan 57 gal saddle tank, linex color matched bedliner , Trekstep bed steps x2, RBP rail steps, Nitto Mud Grapplers, B&W Gooseneck

---Arizona Diesel Club---
Member #19
it's not just a hobbie, it's an Adventure
KensAuto is offline   Reply With Quote Quick reply to this message
Old 11-14-2012, 12:05 PM   eBay Motors  #65 (permalink)
DuramaxForum Enthusiast
 
GMCustomerService's Avatar
 
Join Date: Nov 2010
Posts: 2,112
@WileECoyote, I’m curious if you’ve been able to get the truck out to “stretch her legs” yet.

Michelle, GM Customer Service
GMCustomerService is offline   Reply With Quote Quick reply to this message
Old 11-14-2012, 01:10 PM   eBay Motors  #66 (permalink)
DuramaxForum n00b
 
Join Date: Sep 2012
Posts: 13
ok KensAuto...thanks, so there is 2 Nox sensors then ? so i should bring it back to dealer to see if they will change rear sensor as well?

thanks
gr8dane79 is offline   Reply With Quote Quick reply to this message
Old 11-14-2012, 02:41 PM   eBay Motors  #67 (permalink)
GMC..Professional Grade
Lifetime Supporting Member
 
KensAuto's Avatar
 
Join Date: Apr 2012
Location: Casa Grande, Az
Posts: 3,616
yeah, there is 2. The front one tells the pcm how much the engine is producing and the rear one measures the drop after the urea is sprayed in the scr/dpf, so if the rear one fails, or is not accurately measuring the drop in NOX, the pcm thinks there is a problem with the def system
__________________
2012 GMC 2500 SLT 4x4
H&S minimaxx, MBRP downpipe back SS duals, Insight CTS w/backup cam, Fass HD150, PPE rear diff cover, Amsoil front-rear w/bypass, Cognito 4-6 NTBD w/idler/pitman braces, a-arms, Recon smoked cab lights
Titan 57 gal saddle tank, linex color matched bedliner , Trekstep bed steps x2, RBP rail steps, Nitto Mud Grapplers, B&W Gooseneck

---Arizona Diesel Club---
Member #19
it's not just a hobbie, it's an Adventure
KensAuto is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 10:46 AM   eBay Motors  #68 (permalink)
DuramaxForum n00b
 
Join Date: Mar 2012
Location: SE Florida
Posts: 23
Quote:
Originally Posted by KensAuto View Post
yeah, there is 2. The front one tells the pcm how much the engine is producing and the rear one measures the drop after the urea is sprayed in the scr/dpf, so if the rear one fails, or is not accurately measuring the drop in NOX, the pcm thinks there is a problem with the def system

Nice - a clear explanation of what the NOx sensors are doing. Thanks.
__________________
2011 GMC 2500HD
sierra2500HD is offline   Reply With Quote Quick reply to this message
Old 11-20-2012, 08:15 PM   eBay Motors  #69 (permalink)
 
Join Date: Nov 2012
Location: Virginia
Posts: 3
I've had the same "diesel exhaust quality poor" light for the last two weeks. I took it to the dealer (4 separate times) and they ran it through the computer and regen. They were not able to clear the message. They told me it was due to the Cold Air Intake I installed when the truck had 600 miles on it. It now has 19,500. They put a stock filter back on it, $653.00 cost to me, and the light came back on after 20 miles. I mentioned the NOx sensor but they didn't think it was the problem. Other than the NOx sensor, has anyone had this problem with the CAIs? I'm 700 miles from home and the original air cleaner system, and I don't feel like limping home...

Last edited by VADMAX; 11-21-2012 at 05:07 AM.
VADMAX is offline   Reply With Quote Quick reply to this message
Old 11-24-2012, 11:49 AM   eBay Motors  #70 (permalink)
Junior Member
 
Join Date: Nov 2012
Posts: 149
same boat guys.Low quality lights and cel's all day long.I clear the cel with my scan tool and go.Im sick of bring my truck back to the dealer to have them clear it.I have a rejection sticker on my truck from trying to get a inspection sticker.I brought it to the dealer with the rejection and they still can't fix my problem.Maybe i don't use the truck like im spose to.
__________________
2011 3500 drw 6.6 "stock"
1987 s10 427 sbc "stroker" 10.0 in 1/4 mile
built not bought
2012 chevy cruize
s10aromeo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 10:54 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2