I'm stranded.My truck just died and will not restart! - Chevy and GMC Duramax Diesel Forum

911 Problems Forum Truck won't start or drive? Post here!

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 10-04-2009, 02:36 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 27
I'm stranded.My truck just died and will not restart!

I have a 2003 chevy 3500 1 ton with a 6.6 duramax. I was driving down the road the MIL lamp came on and off a few times then my speedometer just jumped from 30 MPH to 100 mph then from 60MPH it jumped to 100 MPh. After that it just died and will not restart. It acts as if its not getting any fuel and the only code i recieved was P0380. Can someone please help? I'm stranded out of town and dont know what the problem is. thanks for any info
Van44 is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 10-04-2009, 02:46 PM
Administrator
 
ob_1jr's Avatar
 
Join Date: Aug 2005
Location: Syracuse, UT
Posts: 8,484
Send a message via Yahoo to ob_1jr
to the forum!!

Do you have any mods on your truck? have you tried to prime your fuel filter? What does your fuel gauge read? When was the last time you changed your fuel filter? I would first try to prime, then if that dont work, drain the filter, and lastly change it. It is kinda weird that the cluster did that, but they are known for going bad. Also that could be a sign one of your batteries are messed up.

2016 GMC Sierra 2500HD Denali
Extang Blackmax Tonneau
Weathertech floor mats and mud flaps
X-pel clear bra

SOLD 2004 GMC Sierra LB7
ob_1jr is offline  
post #3 of 15 (permalink) Old 10-04-2009, 02:47 PM
DuramaxForum Veteran
 
Chevyguy08's Avatar
 
Join Date: Sep 2008
Location: South Dakota
Posts: 1,984
your P0380 code is a Glow Plug Circ Error Circ A, what tuner are you running if you are running one? check the primer to see if it feels hard or spungy

08 LMM is alive and well again with a few add ons

2011 3500 Denali
2011 2500HD LTZ
2011 1500 LTZ
Chevyguy08 is offline  
post #4 of 15 (permalink) Old 10-04-2009, 02:55 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 27
I have no mods. I'ts just a plane jane 3500 1 ton with the 6.6 Duramax. Also i noticed when i turn the key on i dont hear the fuel pump in the tank running (like u would a gasoline engine) so i tried tapping on it while someone else started it but no luck. still no start. Shouldn't i hear the pump pressurising the fuel from the tank.
Van44 is offline  
post #5 of 15 (permalink) Old 10-04-2009, 02:57 PM
DuramaxForum Enthusiast
 
delong_1's Avatar
 
Join Date: Mar 2008
Location: Arvada, CO
Posts: 3,950
there is no pump in the tank, the injection pump pulls the fuel.

built motor, big turbos, built trans, etc all by me, parts from Elite Diesel

1016 hp

7.1 1/8 @ 100

11.27 @ 105
delong_1 is offline  
post #6 of 15 (permalink) Old 10-04-2009, 03:02 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 27
i have a dump bed on my truck and i raised it up to look at the tank and there is a pump mounted on top of the fuel tank just like a normal gasoline engine fuel tank would have
Van44 is offline  
post #7 of 15 (permalink) Old 10-04-2009, 03:07 PM
Senior Member
 
Join Date: Aug 2008
Location: surrey bc
Posts: 559
Quote:
Originally Posted by Van44 View Post
i have a dump bed on my truck and i raised it up to look at the tank and there is a pump mounted on top of the fuel tank just like a normal gasoline engine fuel tank would have
maybe thats just the sending unit

2006 gmc slt,full bore exhaust maniflod,leather,dee zee nerf bars,Diamondback hd tonneu cover,cloud rider mud flaps ,trans go jr with bd valve body, cognito level installed uca , ppe tie rod sleeves,atx teflon,pro comp shocks edge evoloution A/T.295/70/17 nitto terra grapplers::die NOW WHERE ARE THE CANADIAN TRANNY BUILDERS
marbles72 is offline  
post #8 of 15 (permalink) Old 10-04-2009, 03:07 PM
DuramaxForum Enthusiast
 
delong_1's Avatar
 
Join Date: Mar 2008
Location: Arvada, CO
Posts: 3,950
im not calling you a liar but are you sure its not just the feed and return lines plus a couple wires for the fuel gauge?

built motor, big turbos, built trans, etc all by me, parts from Elite Diesel

1016 hp

7.1 1/8 @ 100

11.27 @ 105
delong_1 is offline  
post #9 of 15 (permalink) Old 10-04-2009, 03:16 PM Thread Starter
Junior Member
 
Join Date: Oct 2009
Posts: 27
Quote:
Originally Posted by delong_1 View Post
im not calling you a liar but are you sure its not just the feed and return lines plus a couple wires for the fuel gauge?
I'm not a mechanic but it sounds like u know what you are talking about so yes thats probally what it is. I just thought that it pressurised fuel to the pump.

Ok so i need to start by checking the prime on my filter first right? Maybe it somehow lost its prime and if so i need to fill it up with fuel and it should run right?
Van44 is offline  
post #10 of 15 (permalink) Old 10-04-2009, 03:20 PM
Banned
 
Join Date: Jan 2009
Location: Sin City
Posts: 4,544
sounds elec. to me, not fuel related. check the bail connectors and connectors to ecm.


make sure the fuses are all good, under the hood especially.
MMLMM is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome