Duramax won't run, fuel or fuel pump problem? - Chevy and GMC Duramax Diesel Forum
911 Problems Forum Truck won't start or drive? Post here!

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-15-2011, 08:15 AM   eBay Motors  #1 (permalink)
DuramaxForum n00b
 
Join Date: Jun 2011
Posts: 14
Duramax won't run, fuel or fuel pump problem?

Jumped in my truck yesterday (2005 Duramax 6.6 with 160k) and it cranked fine, won't run. Replaced fuel filter and primed many, many times. It would run about 3 seconds until, it seems, ran out of fuel. When I pump the primer with the bleed screw closed, a small amount of fuel comes out of the under the primer housing. Is that normal? The button does get firm.

When I open the bleed screw, it seems a small amount of air bubbles continue to come out. I had my friend continue pumping the primer button while I cranked it. The engine ran as long as he pumped the primer. As soon as he stopped, the engine stopped. Is it possible the primer housing has a leak and it is aerating or do you think the injector pump is gone? Other suggestions? My truck is out of town in Modesto CA. Anyone reasonable there if I have to have it towed in? Thanks!!
DaveDelta is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-15-2011, 08:17 AM   eBay Motors  #2 (permalink)
Senior Member
 
TJO116's Avatar
 
Join Date: Aug 2010
Location: Middletown, NJ
Posts: 327
no fuel should come out of anywhere with the bleeder screw closed. thats your problem. you'll probably need to rebuild the housing.
__________________
2005 Silverado 2500HD Ext. Cab Long Bed

Mostly Stock
TJO116 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:24 AM   eBay Motors  #3 (permalink)
DuramaxForum n00b
 
Join Date: Jun 2011
Posts: 14
Thanks TJ. I don't remember it ever letting a little fuel out under the housing when I pumped it in the past. If I pump it about 3 times a small amount does come out under the housing on top of the housing. The button does get firm. It seems like it does not maintain a prime. So it's possible it's sucking in air from the primer housing and that makes it not run?
DaveDelta is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:37 AM   eBay Motors  #4 (permalink)
Senior Member
 
Drolly82's Avatar
 
Join Date: Mar 2009
Location: Nor Cal
Posts: 548
Just an idea had it happen to me twice where the truck was parked on an incline and wouldn't start but would crank fine.

The last time i actually un-hooked the batteries for 5-10 min, an i also primed the pump and it worked. I had tried to prime it 3 times before that with fuel leaking all over the ground an it still wouldn't start.

Make sure if you changed the fuel filter by chance that it is seated properly on the housing. You have the water seperater on the bottom of the fuel filter, and that you got the old seal off the housing if it wasn't still on the old fuel filter when you took it off.

Just hinting a few ideas that might save you some cash.
__________________
05 lly 4x4, 17" American Racing Rims , 35x12.5x17 Toyo MT, 4" Trailmaster Lift, Rear Air Bags, Autometer (Boost, Pyro, an Tranny), 4" Mbrp Exhaust (now straight through) Axle Dump Thanks to Alligator Performance Giveaway. LBZ Mouthpiece, Resonator Plugged, Pcv Re-route, Homemade Egr Blocker Plate, Homemade Front Bumper, Homemade Rear Mud Flaps, Debadged, Red Interior Accents

Nor Cal Diesel Forum- DURAMAX-82
http://www.alligatorperformance.com/

Last edited by Drolly82; 06-15-2011 at 08:40 AM.
Drolly82 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:41 AM   eBay Motors  #5 (permalink)
Senior Member
 
TJO116's Avatar
 
Join Date: Aug 2010
Location: Middletown, NJ
Posts: 327
From what I've read on here, even a tiny bit of a leak can really cause problems as far as that stuff goes. Complete Duramax Filter Head Rebuild Kit
this might fix your problem, and its fairly cheap. but if you wait a little while I'm sure others will chime in with a second opinion for ya.
__________________
2005 Silverado 2500HD Ext. Cab Long Bed

Mostly Stock
TJO116 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:45 AM   eBay Motors  #6 (permalink)
Senior Member
 
Drolly82's Avatar
 
Join Date: Mar 2009
Location: Nor Cal
Posts: 548
Not sayin tjo116 is wrong by an means, just a few thangs to look at, case you were in a hurry an maybe missed somethin.
__________________
05 lly 4x4, 17" American Racing Rims , 35x12.5x17 Toyo MT, 4" Trailmaster Lift, Rear Air Bags, Autometer (Boost, Pyro, an Tranny), 4" Mbrp Exhaust (now straight through) Axle Dump Thanks to Alligator Performance Giveaway. LBZ Mouthpiece, Resonator Plugged, Pcv Re-route, Homemade Egr Blocker Plate, Homemade Front Bumper, Homemade Rear Mud Flaps, Debadged, Red Interior Accents

Nor Cal Diesel Forum- DURAMAX-82
http://www.alligatorperformance.com/
Drolly82 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:55 AM   eBay Motors  #7 (permalink)
Senior Member
 
TJO116's Avatar
 
Join Date: Aug 2010
Location: Middletown, NJ
Posts: 327
Quote:
Originally Posted by Drolly82 View Post
Not sayin tjo116 is wrong by an means, just a few thangs to look at, case you were in a hurry an maybe missed somethin.
No worries man. Second opinions are great, especially since I've never had this problem personally...and I'm not a mechanic. We're all just tryin to help a brotha out.
__________________
2005 Silverado 2500HD Ext. Cab Long Bed

Mostly Stock
TJO116 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 08:57 AM   eBay Motors  #8 (permalink)
Senior Member
 
Drolly82's Avatar
 
Join Date: Mar 2009
Location: Nor Cal
Posts: 548
Sure thing man
__________________
05 lly 4x4, 17" American Racing Rims , 35x12.5x17 Toyo MT, 4" Trailmaster Lift, Rear Air Bags, Autometer (Boost, Pyro, an Tranny), 4" Mbrp Exhaust (now straight through) Axle Dump Thanks to Alligator Performance Giveaway. LBZ Mouthpiece, Resonator Plugged, Pcv Re-route, Homemade Egr Blocker Plate, Homemade Front Bumper, Homemade Rear Mud Flaps, Debadged, Red Interior Accents

Nor Cal Diesel Forum- DURAMAX-82
http://www.alligatorperformance.com/
Drolly82 is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 09:30 AM   eBay Motors  #9 (permalink)
DuramaxForum n00b
 
Join Date: Jun 2011
Posts: 14
Thanks guys. Off to check out the primer rebuild thread(s) and try to get o-rings at NAPA today. Problem was prior to replacing the fuel filter, that was just a starting point because it needed replacing. I have changed it before and was careful the o-rings were on the filter correctly and the drain plug assembly. Hopefully it's the primer assembly cuz I don't have the $ to replace the fuel pump.
DaveDelta is offline   Reply With Quote Quick reply to this message
Old 06-15-2011, 09:33 AM   eBay Motors  #10 (permalink)
Senior Member
 
TJO116's Avatar
 
Join Date: Aug 2010
Location: Middletown, NJ
Posts: 327
I doubt its the fuel pump. Dont hear about those going bad too often.
__________________
2005 Silverado 2500HD Ext. Cab Long Bed

Mostly Stock
TJO116 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 01:50 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2