Stuck on Defrost?? - Chevy and GMC Duramax Diesel Forum
Gauges, Electronics and Wiring. A place to discuss electronic / wiring issues and what gauges, audio, video, nav systems, lights, ect. are right for you.

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-09-2009, 10:39 PM   eBay Motors  #1 (permalink)
Junior Member
 
Join Date: Dec 2009
Location: Minot,ND
Posts: 76
Stuck on Defrost??

I just replaced my batteries and since i did that my heater is stuck on defrost i turn the climate control to anything else and nothing happens just stays on front window defrost? Any help would be nice and appreciated.
__________________
05 LLY 4 INCH MBRP STRAIGHT PIPED W/ 6 INCH TIP TURBO BACK, AFE TURBO INLET TUBE, K&N AIR INTAKE, BULLY DOG POWER PUP, BLOCKED RESONATOR, EGR BLOCKER PLATE, 386 RWHP
JLOP83 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-11-2009, 09:03 PM   eBay Motors  #2 (permalink)
DuramaxForum n00b
 
Join Date: Aug 2009
Location: Southeast, WI
Posts: 24
Try pulling the fuse for a few minutes then popping it back in.
copmagnet is offline   Reply With Quote Quick reply to this message
Old 12-12-2009, 09:18 AM   eBay Motors  #3 (permalink)
Junior Member
 
Join Date: Dec 2009
Location: Minot,ND
Posts: 76
Id assume while the truck is not running then correct?? Or do you pull it out, then start my truck, then shut it off and replace fuse back??
__________________
05 LLY 4 INCH MBRP STRAIGHT PIPED W/ 6 INCH TIP TURBO BACK, AFE TURBO INLET TUBE, K&N AIR INTAKE, BULLY DOG POWER PUP, BLOCKED RESONATOR, EGR BLOCKER PLATE, 386 RWHP
JLOP83 is offline   Reply With Quote Quick reply to this message
Old 12-12-2009, 09:32 AM   eBay Motors  #4 (permalink)
Junior Member
 
Join Date: Feb 2009
Location: Medicine Hat, Alberta
Posts: 102
What truck do you have. I'm pretty sure mine starts out on defrost and then goes to the others after engine warm up. Can't remember for sure though because I always use command start. Might be what yours is doing.
__________________
Jason

2007 Classic Silverado LS 2500HD Z71 4WD
Amsoil in the engine
Jackrabbit tonneau cover with pop and lock
Billet Grille insert
Innovative Creations side bars
chrome rocker panels
Titan remote starter
pulls 28' fifth wheel RV that I nicknamed, "the flag"
www.performancetruckproducts.com
millwright01 is offline   Reply With Quote Quick reply to this message
Old 12-12-2009, 10:05 AM   eBay Motors  #5 (permalink)
Senior Member
 
diesel_tech1's Avatar
 
Join Date: Jan 2009
Location: Rio Rancho, NM
Posts: 407
sounds like your blend door motor went out.
__________________
NAME: Tyrone
2001 GMC SLT 2500 HD Crew Cab short box 4X4 LB7
4" straight exhaust 285/75/r16 180,000 miles
Auto Meter Carbon Fiber Ultra Lite Pyro, Boost Gauges
PPE Boost valve.
Turbo MP Mod PPE HOT+2
30% over injectors
diesel_tech1 is offline   Reply With Quote Quick reply to this message
Old 12-13-2009, 08:54 PM   eBay Motors  #6 (permalink)
Junior Member
 
Join Date: Dec 2009
Location: Minot,ND
Posts: 76
Ya gents i appreciate the advice and as stupid as it was i finally got a day above -5 degrees and warmed up enough to loosen something up and everything works fine cant wait for the -21 tonight but i tell you what this D-MAX starts everytime.
__________________
05 LLY 4 INCH MBRP STRAIGHT PIPED W/ 6 INCH TIP TURBO BACK, AFE TURBO INLET TUBE, K&N AIR INTAKE, BULLY DOG POWER PUP, BLOCKED RESONATOR, EGR BLOCKER PLATE, 386 RWHP
JLOP83 is offline   Reply With Quote Quick reply to this message
Old 12-14-2009, 04:23 PM   eBay Motors  #7 (permalink)
DuramaxForum n00b
 
Join Date: Aug 2009
Location: Southeast, WI
Posts: 24
Quote:
Originally Posted by JLOP83 View Post
Ya gents i appreciate the advice and as stupid as it was i finally got a day above -5 degrees and warmed up enough to loosen something up and everything works fine cant wait for the -21 tonight but i tell you what this D-MAX starts everytime.
I hope for ur sake that it wont be a problem in the future, but sometimes this is just a sign of a motor going out.
copmagnet is offline   Reply With Quote Quick reply to this message
Old 12-14-2009, 07:10 PM   eBay Motors  #8 (permalink)
DuramaxForum n00b
 
Join Date: Jul 2009
Location: Bastrop, Louisiana
Posts: 10
I have this happen every time I disconnect the battery. I found that you have to turn the switch on after reconnecting batteries with everything in off position and on vent. Let in set with key switch on and not running, turn switch off and back on and listen to blend door movement before cranking. This seems to work everytime for me.
__________________
2-2004' Chev. 2500Hd. LLY one white that my son drives and one black that I drive. Triple-dog on son's truck, K&N air filter, and 5" exhaust and all stock on mine except for radio (Bose quit on me) and K&N air filter.
weakone is offline   Reply With Quote Quick reply to this message
Old 07-03-2010, 05:36 AM   eBay Motors  #9 (permalink)
DuramaxForum n00b
 
Join Date: May 2009
Posts: 23
Quote:
Originally Posted by weakone View Post
I have this happen every time I disconnect the battery. I found that you have to turn the switch on after reconnecting batteries with everything in off position and on vent. Let in set with key switch on and not running, turn switch off and back on and listen to blend door movement before cranking. This seems to work everytime for me.

This worked for me this morning, i did the same thing and actually removed the key from ignition while in off position.

THANKS GUYS
__________________
2004 chev 3500, all stock
rackmaster2 is offline   Reply With Quote Quick reply to this message
Old 11-03-2012, 02:00 PM   eBay Motors  #10 (permalink)
DuramaxForum n00b
 
Join Date: Jun 2012
Posts: 16
Hey guys, sorry to revive an old thread but we might as well keep all the info in the same place.

A week ago one of my idler pulleys separated at the bearings and completely came apart/fell off. So I disconnected both batteries at the negative terminals, replaced both idler pulleys and belt - and when I started my truck back up, air only blows through the defrost and some at my feet. The truck does allow me to enable recirculation, and a/c works, fan speed controls work - it just blows through the damn defrost. I have tried removing the fuse, starting the truck, replacing the fuse, any combination of key off/key on/ac off/ac on, disconnecting both batteries again and no cigar. On DieselPlace they said some trucks in this situation go through a cycle of defrost, floorboard, dash vents but my truck does not, even after disconnecting the batteries again. It is always on dash. It would be a hell of a coincidence if it was a hardware failure... Any help is appreciated, thanks!
__________________
2004.5 LLY Crew Cab Short Bed 2wd
TheDoubleDeuce is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 05:49 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Search Engine Friendly URLs by vBSEO 3.6.1