Xx fuel system problems - Chevy and GMC Duramax Diesel Forum
Performance Upgrades Discuss what Intakes,Exhaust,Fuel System,Programmers,Tuners,&Trans. are right for you.

DuramaxForum.com is the premier Chevy and GMC Duramax Diesel Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-17-2012, 03:17 PM   eBay Motors  #1 (permalink)
Duramax Forum Supporter
Supporting Member
 
Texas Wallbanger's Avatar
 
Join Date: Feb 2012
Location: TEXAS
Posts: 941
Xx fuel system problems

I have the XX FUEL SYSTEM installed on my truck and right after I put it on I started having to prime the system almost every time AFTER I had been pulling hard. This is the only time it does it! Anytime I have more than 20 k behind me it has to be primed. I will pull let the Turbo cool, shut it off, then it will start up and run for about five seconds then shut down? We are at a loss for answers other than the 2 micron filter is just not letting enough fuel pass by or causing some kind pressure build up then sucking back. THIS ONLY HAPPENS UNDER LOAD AND REALLY JUST AFTER 20K . ANY IDEAS?

I posted some pictures of BOTH oil/fuel systems. I'm a bit nuts about this problem so again any ideas are welcome.
Attached Images
File Type: jpg IMG_20120304_101111.jpg (41.5 KB, 50 views)
File Type: jpg IMG_20120304_101119.jpg (53.0 KB, 50 views)
__________________
J.B.3
2009 3500 LMM DRW LTZ
Downpipe <> "Clean" Exhaust <> AFE Intake Stage 2 <> PPE Deep Tranny Pan <> Fleetrite ATF <> TransGo Jr. <> PCV Reroute <> Resonator Plug <> <> Amsoil By-Pass <> Synthetic Fluid Everywhere <>. Auxiliary Fuel Filters 2 cat filters 1R-0749 & 175-2949 <> Rear Air Bags <> LED fogs & rear work lights <>6000 lumens Drive lights<> Pillar gauges <> Debadged <> full front bumper replacement <> <> stock Fuel Filter replaced w/ 1r-0750 or 0749 <> EFI LIVE from ATP by Rob <> Michelin Green X<> Kennedy Lift Pump <>Custom Flatbed<>Edge CTS gauges <> FLYING DOWN TEXAS ROADS ALL DAY LONG!

Last edited by Texas Wallbanger; 03-17-2012 at 03:19 PM.
Texas Wallbanger is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-17-2012, 03:28 PM   eBay Motors  #2 (permalink)
Duramax Forum Supporter
Supporting Member
 
blaineGMC's Avatar
 
Join Date: Mar 2010
Location: Arcadia, Florida
Posts: 2,518
You likely need a fuel filter head rebuild kit. Does your truck do the same thing when your parked on a hill with the front of the truck towards the top of the hill?
__________________
Blaine

04 LLY Suncoast/Precision ML by me. Tuned by Rob.

AFE, MBRP, Mag-Hytec, Merchant Automotive, SSBC, Bilstein

For EFI Live go to:
blaineGMC is offline   Reply With Quote Quick reply to this message
Old 03-17-2012, 09:40 PM   eBay Motors  #3 (permalink)
Duramax Forum Supporter
Supporting Member
 
Texas Wallbanger's Avatar
 
Join Date: Feb 2012
Location: TEXAS
Posts: 941
I live in Texas man .....never really had a chance to text that. But i will look for a hill to test this on.
__________________
J.B.3
2009 3500 LMM DRW LTZ
Downpipe <> "Clean" Exhaust <> AFE Intake Stage 2 <> PPE Deep Tranny Pan <> Fleetrite ATF <> TransGo Jr. <> PCV Reroute <> Resonator Plug <> <> Amsoil By-Pass <> Synthetic Fluid Everywhere <>. Auxiliary Fuel Filters 2 cat filters 1R-0749 & 175-2949 <> Rear Air Bags <> LED fogs & rear work lights <>6000 lumens Drive lights<> Pillar gauges <> Debadged <> full front bumper replacement <> <> stock Fuel Filter replaced w/ 1r-0750 or 0749 <> EFI LIVE from ATP by Rob <> Michelin Green X<> Kennedy Lift Pump <>Custom Flatbed<>Edge CTS gauges <> FLYING DOWN TEXAS ROADS ALL DAY LONG!
Texas Wallbanger is offline   Reply With Quote Quick reply to this message
Old 03-18-2012, 12:19 AM   eBay Motors  #4 (permalink)
Junior Member
 
rittenhouse_21's Avatar
 
Join Date: Jun 2011
Posts: 140
do you have a lift pump? that might cause the issue the cp3 prolly cant keep up with what is being demanded.
__________________
01 dmax
rittenhouse_21 is offline   Reply With Quote Quick reply to this message
Old 04-19-2012, 02:55 PM   eBay Motors  #5 (permalink)
 
Join Date: Jul 2009
Posts: 4
Texas Wallbanger,

Try calling XX-Fuel Technical support in between 8Am and 5PM Pacific Time so they can help troubleshoot your issue.

Your description sounds a lot like you are sucking into the fuel supply side of the system. Re-check all your XX-Fuel fittings and connections. Check the filters for correct tightness and as "BlaineGMC" suggested, you should also check your OE filter and head assembly. Your needing to prime has nothing to do with the filters (unless loose) and everything to do with finding where the air is being sucked into your system.

Last edited by n0useforaname; 04-20-2012 at 09:35 AM.
ashtiani is offline   Reply With Quote Quick reply to this message
Old 04-20-2012, 09:26 AM   eBay Motors  #6 (permalink)
 
Join Date: Jul 2009
Posts: 4
Texas Wallbanger,

Just a follow up to my last post:

Try opening up the compression fittings on the fuel line. In particular, I would like you pinch the ferrule in between your thumb and forefinger and try and wiggle the ferrule. If you get any movement whatsoever, that means the compression fitting was not tightened sufficiently upon installation. Please refer back to our installation instructions and go through them again to insure a trouble free installation.

Last edited by n0useforaname; 04-20-2012 at 09:34 AM.
ashtiani is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply


Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -7. The time now is 06:39 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

Search Engine Friendly URLs by vBSEO 3.3.2