2003 LB7 Limp Mode Range Shift Inhibited, first timer needs help - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-11-2020, 01:28 PM Thread Starter
DuramaxForum n00b
 
Join Date: Oct 2017
Posts: 12
2003 LB7 Limp Mode Range Shift Inhibited, first timer needs help

Hello Guys, have my truck for 2 years and put around 18k miles in that timeframe the with only issue was fuel filter blockage. Two days ago a few blocks away from my house after a 2 hr drive, the truck at the stoplight had no power. Kind of thought it was in my mind and just brushed it off. The next day, had to pick up a friend from the airport 20 miles away. On the freeway truck ran normal till I hit the first stoplight. After that the truck would not shift gears and received the " range shift inhibited" error on the dash cluster with no check engine light. Limped mode all the way to pick up friend and pull off to the side to check things over. Transmission oil and everything else looked fine so call my mechanic buddy and told me to unplug batteries. It's been a one day since plugging the battery back and truck does run fine after 30 miles. At this point little hesitant to drive too far or tow/haul anything till I've sorted or find the culprit. Anyone ever just unplug battery and issue resolved itself? Search the forum and the culprit can be something simply to transmission rebuild. Any help would be great to help diagnose the issue.
America964 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-11-2020, 07:40 PM
Junior Member
 
Join Date: Oct 2018
Location: Calgary Alberta
Posts: 152
I'd check the NSBU switch and wiring on the side of the tranny. They are known to get crud in them and cause all sorts of issues. It's only a $60 part.

Sent from my google machine

"Stinky Pig"
2003 Sierra 2500 Crew 4x4ĖCharcoal Grey Metallic
325k kms and counting
LLY Head swap
LBZ full intake w/MP
Flo-Pro Downpipe
4" Straight pipe
EGR delete
PCV Re-route
EFI Live (E. Stock/30HP/60HP Tow/high idle/No start)
Edge CTS2 with EGT
AxysAssault is offline  
post #3 of 6 (permalink) Old 01-12-2020, 10:33 AM Thread Starter
DuramaxForum n00b
 
Join Date: Oct 2017
Posts: 12
Thinking will keep driving locally for a bit to test and will setup a full transmission service with the NSBS and harness. Saw another thread that it could be the ignition switch Hope unplugging the battery works
America964 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 01-13-2020, 10:09 PM Thread Starter
DuramaxForum n00b
 
Join Date: Oct 2017
Posts: 12
Limp mode is back. The battery disconnect lasted 1/2 a day or few hour drive time. During limp mode this time reverse did not engage. Disconnected battery again and drove fine. No check engine light. Going to borrow a code reader tomorrow and see if any codes
America964 is offline  
post #5 of 6 (permalink) Old 01-29-2020, 07:11 PM Thread Starter
DuramaxForum n00b
 
Join Date: Oct 2017
Posts: 12
Replaced the NSBU switch and the harness plus the ignition starter switch along with both transmission filters and oil but still in limp mode. Absolutely no codes, any suggestions to what to do next?
America964 is offline  
post #6 of 6 (permalink) Old 01-31-2020, 06:53 AM
 
Join Date: Aug 2018
Posts: 5
I went through the same thing with my truck. I'd get range shift inhibited and stuck in 3rd. Changed nsbu and ignition switch and no change. I have a code reader so I just cleared codes and it would work for a little while. Took to transmission shop and they wanted to tear apart and rebuild. Luckily I waited. Replaced valve body myself based on suggestions and still limped. Turned out to be a bad shift solenoid that would only fail when it got hot enough. Shift solenoids were reused during valve body swap. Just a suggestion to look into. Took about a month of range shift inhibits to finally track down.
wixster7 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome