DashCommand PIDs for balance rates, etc -- LB7 - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 10-04-2017, 10:10 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Location: Amarillo, TX
Posts: 59
DashCommand PIDs for balance rates, etc -- LB7

Downloaded DashCommand for iOS and have a WIFI ELM OBDII adapter. Bought the "Extended PID pack for 2002 GM vehicles". App connects and shows speed, hp, torque, MAF, etc, etc. But I can't get it to verify the "extended" PIDs for balance rates, fuel rail pressure, etc. which is I what I got it for. Anybody have any experience with this app or this problem? It might be important to mention that the truck had an Edge Juice w/ Attitude installed before I bought it. Could the Edge be intercepting the signals for certain things like the balance rates, etc and not sending them to the OBDII?

2002 White Chevy Silverado 2500HD Crew Cab 4X4 LS
Head studs
Fass lift pump
Banks Cold Air Intake
Edge Insight Pro CS2 monitor
Titan 52 gallon diesel tank with Beans sump
SirMatthewT is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 10-04-2017, 10:32 AM
Duramax Lifetime Supporter
 
Join Date: Feb 2012
Location: Walton, WV
Posts: 9,317
Shouldn't you be able to read balance rates on the Edge?

2001 2500HD 4WD EXTENDED CAB LS,
S&B CAI, 4" STAINLESS STEEL EXHAUST, EFI LIVE FROM ATP TRUCKS, EDGE CTS, PPE BOOST VALVE, BANKS INTERCOOLER PIPE, AIR DOG II 165, REBUILT TRANNY WITH SUNCOAST KIT, TRANSGO SHIFTKIT AND BILLIT TORQUE CONVERTER, NEW UPGRADED TAILSHAFT, PUMP RUB FIX ON TRANSFER WITH NEW ALUMINUM TAIL SHAFT, NEW TOW MIRRORS, NEW GAGE HEAVY DUTY FRONT AND REAR BUMPERS, BEANS SUMP, FUMOTO VALVE, RARE PARTS TIE RODS WITH COGNITO PISK, MAD JACK FUEL FILTER ACCESS DOOR, STAINLESS STEEL SPEED BLEEDERS.
2011 GMC 3500HD DUALLY Welding Bed, 4WD CREW CAB, 4" downpipe back exhaust, def delete, egr delete, with new LB7 up pipe, pcv reroute, Fass 150, EFI live with DSP 5, HSP CAI. Air Lift Air bags. PPEI transmission tune.
mray is offline  
post #3 of 15 (permalink) Old 10-04-2017, 10:43 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Location: Amarillo, TX
Posts: 59
I don't have a CS or CS2. I have the old Attitude with the monotone gray display. Pretty sure balance rates aren't supported. This one:


2002 White Chevy Silverado 2500HD Crew Cab 4X4 LS
Head studs
Fass lift pump
Banks Cold Air Intake
Edge Insight Pro CS2 monitor
Titan 52 gallon diesel tank with Beans sump
SirMatthewT is offline  
Sponsored Links
Advertisement
 
post #4 of 15 (permalink) Old 10-04-2017, 12:56 PM
Senior Member
 
Join Date: Apr 2017
Posts: 298
I doubt the edge is intercepting messages.

The enhanced PIDs for balance rates are 0x162F through 0x1636. The entire message should look like "22 16 2F 01" sent to the ELM327 device. I've had issues with some ELM devices not always responding because the trailing "01" is not added, telling the ELM device there is only one message expected in return so return it as soon as it's received. The other possibility is the application not telling the ELM device to set the correct header for J1850 devices, which should be "6C 10 F1" (I've had this problem with Torque lite). The default header is usually "68 6A F1", where the first byte (2 digits) is the priority mask, second the destination, and the last telling OBD the sender is from an off-board device (your ELM327 device).

Hope this helps somewhat. I'm in the process of releasing my ELM327 reader application (for PC) that reads enhanced PIDs. If I get legal clearance I'll announce it.

2005 LLY 3500 CCLB 215,000 miles
Shibby6600 is offline  
post #5 of 15 (permalink) Old 09-07-2019, 12:26 PM
Duramax Forum Supporter
 
flynn78us's Avatar
 
Join Date: Apr 2018
Posts: 28
Did you get it to work I have the same edge and can’t get the balance rates either and no help from the folks at dash command
flynn78us is offline  
post #6 of 15 (permalink) Old 09-09-2019, 09:33 AM Thread Starter
Junior Member
 
Join Date: Aug 2017
Location: Amarillo, TX
Posts: 59
No I never got it to read all of the PIDs. I suspect it's my ELM's fault but I haven't tried another or messed with it in awhile. I currently have larger issues with an engine swap and if I ever get that completed I've bought an Edge Insight Pro CS2 to read the "deeper" PIDs like balance rates, etc.

2002 White Chevy Silverado 2500HD Crew Cab 4X4 LS
Head studs
Fass lift pump
Banks Cold Air Intake
Edge Insight Pro CS2 monitor
Titan 52 gallon diesel tank with Beans sump
SirMatthewT is offline  
post #7 of 15 (permalink) Old 09-12-2019, 05:17 PM
Duramax Forum Supporter
 
flynn78us's Avatar
 
Join Date: Apr 2018
Posts: 28
I changed obd2 readers and got mine working. Hopefully you can get your squared away

2005 3500 ECLB 4x4 Auto
flynn78us is offline  
post #8 of 15 (permalink) Old 09-16-2019, 02:40 PM
Junior Member
 
Join Date: Sep 2017
Location: NorCal
Posts: 34
Quote:
Originally Posted by flynn78us View Post
I changed obd2 readers and got mine working. Hopefully you can get your squared away
I had found a guide somewhere to add the pids to torque. Worked.

Only issue I found, was when the app was configured to display the balance rates, it would lock my ECU up. To elaborate, The ECU in my vehicle would not go to sleep and resulted in a dead battery. This only occurs if the device and torque app are left connected. In my case, it was connected to a android device in the center console, which stayed on.

There was another app posted on one of these forums called "link". Someone wrote it, and I cannot find it anymore, but it worked flawlessly and already had the pids.

2004 Chevy 2500HD(LB7) LS Crew Cab

2015 Tow Mirrors, Lightweight Tailgate Mod (ebay replacement lol), Move Bumpers, Tuff Stuff 17,500# Winch, Amber LED Bulbs in DRL Turn/Park, 16x8 American Racing Wheels w/4.5" backspacing, 315/75r16 Mud tires, Kryptonite Tierods, Cognito Tubular Upper Control Arms & Pitman/Idler Bracing kit, Bilstein 5100 Shocks, NorCal Firewall mod, Edge Juice w/Attitude, 5" MBRP exhaust, K&N CAI with non K&N "filter", 3" Inter-cooler tubing, PPI Wastegate delay thingy, Longhorn Fab dash opening , 54" Curved Quad Row LED light bar(Violates ohms law even with 832w at less than 40amps!)
bumbalard is offline  
post #9 of 15 (permalink) Old 11-19-2019, 06:50 AM
DuramaxForum n00b
 
Join Date: Nov 2019
Posts: 13
Quote:
Originally Posted by flynn78us View Post
I changed obd2 readers and got mine working. Hopefully you can get your squared away
What obd2 reader did you buy? I have the GoPoint BT1 recommended by Dashcommand and it doesn't read injector balance.
chuckd83 is offline  
post #10 of 15 (permalink) Old 11-19-2019, 04:58 PM
Duramax Forum Supporter
 
flynn78us's Avatar
 
Join Date: Apr 2018
Posts: 28
Panlong OBD scanner for iOS from amazon. My gopoint didn’t work either so I tried this one and it worked. Only 15.99 hopefully the link below will work

Panlong OBD2 Scanner for iOS iPhone iPad & Android, OBDII WiFi Car Diagnostic Code Reader, Read/Clear Trouble Codes Turn Off Check Engine Light https://www.amazon.com/dp/B07BHLQLN5..._mgi1Db19DFSXG

2005 3500 ECLB 4x4 Auto
flynn78us is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome