Cold Air intake - Chevy and GMC Duramax Diesel Forum
01-04.5 LB7 Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-26-2019, 06:11 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2019
Posts: 14
Cold Air intake

So I installed a specter cold air intake last night. Ran great going to work about 18 miles but just before I got home I started losing throttle response. No check engine light and all gauges read normal. Sitting in driveway I can rev it up no problem but going down the road it's just not acting right. My neighbor said that it's possible the truck has to re learn with the new intake. Any one else have this issue. 2004 LB7

Sent from my SM-N950U using Tapatalk
jpeters9605 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-26-2019, 06:22 PM
Duramax Lifetime Supporter
 
Join Date: Feb 2012
Location: Walton, WV
Posts: 9,211
If it was a bigger intake the MAF sensor may have to be rescaled with a tune adjustment.

2001 2500HD 4WD EXTENDED CAB LS,
S&B CAI, 4" STAINLESS STEEL EXHAUST, EFI LIVE FROM ATP TRUCKS, EDGE CTS, PPE BOOST VALVE, BANKS INTERCOOLER PIPE, AIR DOG II 165, REBUILT TRANNY WITH SUNCOAST KIT, TRANSGO SHIFTKIT AND BILLIT TORQUE CONVERTER, NEW UPGRADED TAILSHAFT, PUMP RUB FIX ON TRANSFER WITH NEW ALUMINUM TAIL SHAFT, NEW TOW MIRRORS, NEW GAGE HEAVY DUTY FRONT AND REAR BUMPERS, BEANS SUMP, FUMOTO VALVE, RARE PARTS TIE RODS WITH COGNITO PISK, MAD JACK FUEL FILTER ACCESS DOOR, STAINLESS STEEL SPEED BLEEDERS.
2011 GMC 3500HD DUALLY Welding Bed, 4WD CREW CAB, 4" downpipe back exhaust, def delete, egr delete, with new LB7 up pipe, pcv reroute, Fass 150, EFI live with DSP 5, HSP CAI. Air Lift Air bags. PPEI transmission tune.
mray is offline  
post #3 of 7 (permalink) Old 01-26-2019, 06:25 PM
DuramaxForum Veteran
 
novaman64's Avatar
 
Join Date: May 2013
Location: Placerville, CA
Posts: 1,950
Garage
Send a message via Skype™ to novaman64
Quote:
Originally Posted by jpeters9605 View Post
So I installed a specter cold air intake last night. Ran great going to work about 18 miles but just before I got home I started losing throttle response. No check engine light and all gauges read normal. Sitting in driveway I can rev it up no problem but going down the road it's just not acting right. My neighbor said that it's possible the truck has to re learn with the new intake. Any one else have this issue. 2004 LB7

Sent from my SM-N950U using Tapatalk
Check your MAF. Sometimes new filters are over oiled, and will get filter oil on the MAF.

-Jimmy (aka DmaxStoreJimmy)
08' Silverado 3500HD CCLB LMM 4x4 - Build Thread
02' Silverado 2500HD CCLB LB7 4x4 - RIP 12/15/2016

#1 member 3500 LB SRW Club

WWW.DMAXSTORE.COM
DURAMAX ONLY STORE 1-877-4MY-DMAX
novaman64 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 01-28-2019, 02:57 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2019
Posts: 14
Thanks for the input. It's not an oiled filter. I will check on the intake size difference.

Sent from my SM-N950U using Tapatalk
jpeters9605 is offline  
post #5 of 7 (permalink) Old 01-29-2019, 01:40 PM
J83
DuramaxForum Enthusiast
 
J83's Avatar
 
Join Date: Apr 2014
Location: Alaska
Posts: 4,527
Quote:
Originally Posted by jpeters9605 View Post
Thanks for the input. It's not an oiled filter. I will check on the intake size difference.

Sent from my SM-N950U using Tapatalk
You may still want to take the MAF sensor out and clean it, it just takes a little MAF /MAP cleaning spray to do the job. It doesent take much to cause those sensors to read wrong and no filter is perfect. Its something you should do from time to time anyway so nothing to be lost by trying it.

2015 Chevy Silverado 2500 HD 6.6L LML
J83 is offline  
post #6 of 7 (permalink) Old 01-29-2019, 03:02 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2019
Posts: 14
I will do that. Thank you

Sent from my SM-N950U using Tapatalk
jpeters9605 is offline  
post #7 of 7 (permalink) Old 02-02-2019, 05:04 PM Thread Starter
DuramaxForum n00b
 
Join Date: Jan 2019
Posts: 14
Changed out the fuel filter. Don't think it had been changed in quite some time by the former owner. Also cleaned the MAF, and did a master reset by disconnecting the batteries and touching the positive and negative cables together for 30 sec. Runs amazing now.

Sent from my SM-N950U using Tapatalk
jpeters9605 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
S&B vs Banks Ram Air Cold Air Intake (CAI) 507Sledz 01-04.5 LB7 Duramax Powertrain 3 04-06-2015 10:17 AM
It was a cold cold cold drive in to work mracoker 2001 - 2007 (GMT800) Non Powertrain 14 12-15-2013 07:01 PM
Cold air intake Back to Factory Air box robinson20xmopar 04.5-05 LLY Performance Parts Discussion 3 07-07-2013 04:24 PM
best intake manifold and cold air intake Dmaxpower Aftermarket Mods. 2 05-27-2010 10:16 PM
Stock Intake to cold air intake Murrow Exterior 8 10-22-2008 06:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome