Loud noise, no power, lots of smoke - Chevy and GMC Duramax Diesel Forum
06-07 LBZ & LLY Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-16-2019, 09:01 PM Thread Starter
DuramaxForum n00b
 
Join Date: Mar 2014
Posts: 12
Loud noise, no power, lots of smoke

Hi I have a 07í deleted, EFI live. Within the last 2 weeks a loud noise has developed that you can hear really well in the cab, it sounds like the AC/heater is on full blast (except a little louder) and it gets louder with the more throttle you give it. When you pop the hood and rev the motor you can hear the blowing noise, it sounds like its coming from the rear of the turbo/ down pipe area, so I took a inspection mirror and flashlight and ran it up and down the firewall looking for a crack in the down pipe. Nothing. It just dumps coal now while accelerating from a stop or going up a hill, I hate being that guy so I keep the tranny in manual mode and try to keep the RPMís up so Iím not smoking everyone out, I have noticed a loss of power too. I recently (3 weeks ago) installed the EGR pipe delete (before I had just had the blocker plate so it could pass a visual smog check) but it ran fine for about a week before all this came up, so Iím not sure maybe itís related or a coincidence? Anyways I tested for boost leaks with leak soap, cold/hot/intake. Nothing. I normally have my monitor set to watch other stuff, but today I set it to boost and I can only build 10lbs under hard acceleration. It has 186,xxx miles. Thank you for any help or suggestions!
Attached Images
File Type: jpg 3BDB1355-23FB-4995-8D21-3810C44B1FCC.jpg (89.6 KB, 26 views)

03' LB7 dually welding truck, Kryptonite UCA's, S&B Intake, Airdog II, Mishimoto intercooler /pipes, ProFab intake horn and downpipe, EFI Live, 5" straight piped
BigInch is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-17-2019, 08:09 AM
Duramax Lifetime Supporter
 
407driver's Avatar
 
Join Date: Oct 2016
Location: Maurice, LA
Posts: 4,004
crack in the bellows of the Up Pipe maybe? Not uncommon if you did not change it to an earlier type without the EGR take off.

2008 Silverado 2500HD CCSB LTZ Diesel
FASS 95 Lift Pump (with Baldwin filters), Edge Insight CTS Monitor on a Windshield Mount, Nicktane Fuel Filter Adapter w/ CAT 306-9199 UHE tertiary fuel filter, Bilstein 5100 Stock Height, Bushwacker Bed Rail Caps, AMP Research Bedstep, Fumoto oil drain valve, Dorman PS Oil cooler, Pioneer AVIC 7200NEX GPS/Stereo, Air Lift LoadLifter 5000 Air Bags.
407driver is offline  
post #3 of 3 (permalink) Old 10-17-2019, 09:59 AM
HWI
Senior Member
 
HWI's Avatar
 
Join Date: Oct 2013
Location: Florida
Posts: 436
If I had to guess I would think you have a boost leak at the y-bridge, not too uncommon when running EGR delete pipes on the stock y-bridge, especially if it's an ebay special pipe.

06 LBZ CCSB
With some stuff.
HWI is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome