LBZ Shaking and TC not locking up on Highway while towing - Chevy and GMC Duramax Diesel Forum
06-07 LBZ & LLY Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 03-28-2019, 07:24 AM Thread Starter
Senior Member
 
Rumpeltiltskin's Avatar
 
Join Date: Jul 2012
Location: Roggen, CO
Posts: 428
LBZ Shaking and TC not locking up on Highway while towing

Truck is in Signature.

I was pulling my large 5th wheel camper (Approx 20,000 lbs gross weight truck and camper) to and from Kansas this week. Approx 500 miles round trip. Between 65 and 70 mph going up hill it would begin to shake if I was in 5th or 6th gear. If i hammered the throttle or "manually" shifted and made it downshift to 4th gear it would stop and pull like normal. I got the p0087 low rail pressure code a couple times and only once I got a p0700(I think) trans mil light and also a (forgot the number 2653??) turbo boost actuator A code at the same time. After all of this happened the torque converter wouldn't lock up anymore which in turn caused the trans fluid to get hot. I pulled over when the trans temp got to 230 degrees and let everything cool down while idling for about an hour. I shut it off to reset the computer(s) That fixed the torque converter problem but the shaking continued if I didn't shift down or drive slower or faster than 65-70 mph range. I monitored desired fuel rail psi against actual fuel rail psi on the CTS and it was right on the money which leads me to believe it isn't a fuel problem, however it is probably time to change the filters on the air dog anyway.

Transfer case just replaced with Kodiak truck unit. I also updated to the nickel slip yoke and new u joint and lubed the splines back at the carrier bearing as suggested by Kodiak truck. All other u joints on rear driveshaft were replaced less than 5000 miles ago. I rotated the tires right before we left but i did not re balance them.

I think I will replace the fuel filters and re balance all 4 tires and try again but I think it may be internal transmission issues since it only does it in 5th and 6th gear. Maybe a shift solenoid? Maybe torque converter? Trans Computer? Any guidance will be appreciated.

2007 Chevy 2500HD CLASSIC LBZ crew cab long bed LT 4X4 EFI Live by ATP...stock, heavy tow with brake, light tow with brake, street/economy, FUN 120HP ...MBRP 4" downpipe back with muffler, Edge CTS for gauges and edge expandable EGT probe, ppe frprv shim kit, egr race plate ADII 165, Transgo Jr. ,ATP tie rod sleeves, Cognito pitman and idler arm braces, Kodiak Truck transfer case, , 165k miles(and counting), 265/75/16 tires pyo wheels, B&W hitch with companion, prodigy P3, husky liners front and back, Lund running boards,
Rumpeltiltskin is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 03-29-2019, 07:33 AM Thread Starter
Senior Member
 
Rumpeltiltskin's Avatar
 
Join Date: Jul 2012
Location: Roggen, CO
Posts: 428
Changed both air dog fuel filters, they only had 11000 miles on them but they were changed a year and a half ago. Drives fine unloaded. Anybody have any ideas?

2007 Chevy 2500HD CLASSIC LBZ crew cab long bed LT 4X4 EFI Live by ATP...stock, heavy tow with brake, light tow with brake, street/economy, FUN 120HP ...MBRP 4" downpipe back with muffler, Edge CTS for gauges and edge expandable EGT probe, ppe frprv shim kit, egr race plate ADII 165, Transgo Jr. ,ATP tie rod sleeves, Cognito pitman and idler arm braces, Kodiak Truck transfer case, , 165k miles(and counting), 265/75/16 tires pyo wheels, B&W hitch with companion, prodigy P3, husky liners front and back, Lund running boards,
Rumpeltiltskin is offline  
post #3 of 4 (permalink) Old 08-13-2019, 04:02 PM Thread Starter
Senior Member
 
Rumpeltiltskin's Avatar
 
Join Date: Jul 2012
Location: Roggen, CO
Posts: 428
Just pulled camper as well as a small 16ft bumper pull with a polaris ranger and a 4 wheeler behind the camper. Up and down the mountains and there was no shaking or torque converter problems this time. HOWEVER I'm still getting the P0087 low fuel rail psi code. It will only set the code if I am in 5th or 6th gear. I monitored desired vs actual again and in 5th gear if it demanded 23k it would only go to about 19 or 20k. If I caught it in time and forced it to shift down into 4th it would get plenty of fuel and not set the code. Both air dog filters were changed less than 1000 miles ago but the factory filter hasn't been changed in about 50k miles. IN THEORY with the air dog filters the factory filter shouldn't ever get anything in it. I know some guys even delete the whole factory unit all together. I think I will try to change the factory fuel filter next but if that doesn't fix it what could it be??? Cp3 getting weak???

2007 Chevy 2500HD CLASSIC LBZ crew cab long bed LT 4X4 EFI Live by ATP...stock, heavy tow with brake, light tow with brake, street/economy, FUN 120HP ...MBRP 4" downpipe back with muffler, Edge CTS for gauges and edge expandable EGT probe, ppe frprv shim kit, egr race plate ADII 165, Transgo Jr. ,ATP tie rod sleeves, Cognito pitman and idler arm braces, Kodiak Truck transfer case, , 165k miles(and counting), 265/75/16 tires pyo wheels, B&W hitch with companion, prodigy P3, husky liners front and back, Lund running boards,
Rumpeltiltskin is offline  
Sponsored Links
Advertisement
 
post #4 of 4 (permalink) Old 08-13-2019, 05:22 PM
HWI
Senior Member
 
HWI's Avatar
 
Join Date: Oct 2013
Location: Florida
Posts: 338
Put a gauge post lift pump and see what pressure your AD is putting out when your actual rail pressure is not meeting desired.

06 LBZ CCSB
MBRP 3" down pipe/4" straight pipe, PPE Xcelerator, FASS 150, Beans sump, deleted, pump rub fix
Zone 6" lift, Kryptonite tie rods
HWI is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Steering shaking while stationary Troponin 11-16 LML Duramax Powertrain 2 12-29-2014 11:06 PM
TC question... Locking up at idle Dmaxster Transmission Shop 4 02-10-2014 04:28 PM
Locking or Non Locking Rear Diff? lynxer 07.5-10 LMM Duramax Powertrain 4 12-13-2011 06:40 AM
tc slow to finish locking up chinaman Transmission Shop 2 01-16-2011 09:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome