2008 LMM transmission solenoid and 4x4 issues - Chevy and GMC Duramax Diesel Forum
07.5-10 LMM Duramax Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-08-2020, 12:29 PM Thread Starter
 
Join Date: Jan 2020
Posts: 6
2008 LMM transmission solenoid and 4x4 issues

I currently have codes:
P0751 shift solenoid A performance or stuck off
P0756 shift solenoid B performance or stuck off
P0761 shift solenoid C performance or stuck off
P0894 transmission component slipping

Service 4 wheel drive also displayed on dash. Any ideas as to what this could be? Hoping it's not a failing transmission.
John LaClair is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-08-2020, 01:29 PM
DuramaxForum n00b
 
Join Date: Nov 2019
Posts: 21
Do you have a wiring diagram? I wonder if those are wired from the same source and there is a problem in the wiring/fuse.

2006 Chevrolet Silverado 2500HD LT
chuckd83 is offline  
post #3 of 9 (permalink) Old 01-08-2020, 02:21 PM Thread Starter
 
Join Date: Jan 2020
Posts: 6
Quote:
Originally Posted by chuckd83 View Post
Do you have a wiring diagram? I wonder if those are wired from the same source and there is a problem in the wiring/fuse.
I don't have a wiring diagram, but after messing with the fuse block and moving around some relays, the run/crank relay wasn't making a connection so the truck won't even crank. Pulled out the fuse block and found a couple of broken wires, not to mention the fuse block is corroded internally and coming apart. Going to replace that and hope that it fixes my problems.
Attached Images
File Type: jpg 20200108_161048_1578518413255.jpg (44.3 KB, 40 views)
File Type: jpg 20200108_161041_1578518440500.jpg (33.1 KB, 40 views)
File Type: jpg 20200108_161034_1578518456053.jpg (43.2 KB, 40 views)
John LaClair is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 01-08-2020, 06:51 PM
DuramaxForum Veteran
 
Join Date: Aug 2009
Location: Berryton, KS
Posts: 1,445
Wiring diagrams can be obtained from GMUPFITTER.COM in the body builder section. Electrical is in it's own manual, by year/model.

Ron Nielson
2008 Silverado LT, CCLB, Edge Insight CTS
2009 Arctic Fox 29-5T, Silver Fox Edition, Onan 3600 LPG generator
Ron Nielson is online now  
post #5 of 9 (permalink) Old 01-09-2020, 04:02 PM
DuramaxForum n00b
 
Join Date: Nov 2019
Posts: 21
The wiring diagram from the above link is here:
https://www.gmupfitter.com/files/med...hassisCabs.pdf

Fuse 22, TRANS IGN 1, 15A powers:
Transmission Control Module (TCM),
1-2 Shift Solenoid (1-2 SS) Valve,
2-3 Shift Solenoid (2-3 SS) Valve,
3-2 Shift Solenoid (3-2 SS) Valve (M30/M70),
Torque Converter Clutch (TCC) Solenoid Valve (M30/M70),
Torque Converter Clutch Pulse Width Modulation (TCC PWM) Solenoid Valve

2006 Chevrolet Silverado 2500HD LT
chuckd83 is offline  
post #6 of 9 (permalink) Old 01-09-2020, 04:08 PM
DuramaxForum n00b
 
Join Date: Nov 2019
Posts: 21
Sorry, that's gas.

Fuse 15, TRANS IGN 1 Fuse:
Transmission Control Module (TCM),
Front Axle Actuator (NQF/NQG)

2006 Chevrolet Silverado 2500HD LT
chuckd83 is offline  
post #7 of 9 (permalink) Old 01-18-2020, 10:59 PM
DuramaxForum n00b
 
Join Date: Nov 2015
Posts: 14
Is this only happening when cold?


Sent from my iPhone using Tapatalk
Nicksquid is offline  
post #8 of 9 (permalink) Old 01-20-2020, 04:30 AM Thread Starter
 
Join Date: Jan 2020
Posts: 6
Definitely seems like it could be. The first time I wasn't paying attention to the temperature, but the last two times it has been below 20 degrees when it had these codes pop up. Let it warm up, clear the codes, and I don't have any more issues out of it until it gets cold again.

Quote:
Originally Posted by Nicksquid View Post
Is this only happening when cold?


Sent from my iPhone using Tapatalk
John LaClair is offline  
post #9 of 9 (permalink) Old 01-20-2020, 06:19 PM
Junior Member
 
aautio1004's Avatar
 
Join Date: Apr 2009
Location: Birchwood, Wisconsin
Posts: 60
sorry to hope into your post here, but i’ve got the same issue on my truck, same codes minus the service 4 wheel drive message...but it’s definitely only when it’s cold out on mine. transmission won’t go into gear until i clear the codes out, and then it’s all good again until the next time it’s really cold out. then the process repeats itself.


just wondering, do you happen to have any sort of manual locker switch for your transmission at all? i’ve got one on mine and i’m just trying to eliminate that as the source of the problem.

07 LBZ Allison Auto 4x4 crew cab long box LT2 Edge Juice w/ Attitude SOLD
01 Ram 2500 Cummins QC SB 5 inch exhaust HX40 turbo Smarty/Edge Comp Hot stack SOLD
85 Chev 1500 dropped to the ground..6.2L til it blew...now runs with a 454
14 Chevy Cruze 2.0 diesel
08 CCSB LLM-trying to figure out what allís been done to it......
aautio1004 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome