07+ trailer brake not showing up in DIC - Chevy and GMC Duramax Diesel Forum
2007.5 + (GMT 900) Non Powertrain--New Body Style-- Discussion 07.5 - 2010 Topics Not related to the Powertrain, interior, suspensions, body, wheels, tires, ect.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-03-2019, 04:22 PM Thread Starter
Junior Member
 
henrys072500hd's Avatar
 
Join Date: Mar 2011
Location: Carleton Place, ON
Posts: 32
07+ trailer brake not showing up in DIC

Factory installed controller, nothing comes up on the dash when I hook up the trailer nor when I push the brake controller buttons etc. No power to trailer brakes.
henrys072500hd is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-03-2019, 07:49 PM
DuramaxForum Veteran
 
Join Date: Aug 2009
Location: Berryton, KS
Posts: 1,233
Has this ever worked in your truck? Did you check the fuses? Have you checked for codes? Do you have an ABS light in your dash? High mount 3rd brake light work? Cruise Control work? When you connect a trailer does the DIC say TRAILER CONNECTED? There are lots of problems with this system and knowing some of these answers may help solve the problem. One relatively simple remedy is to replace the trailer brake system relay located on the rear frame above the axle. Another is to replace the trailer brake pressure sensor on the master cylinder.

Ron Nielson
2008 Silverado LT, CCLB, Edge Insight CTS
2009 Arctic Fox 29-5T, Silver Fox Edition, Onan 3600 LPG generator
Ron Nielson is offline  
post #3 of 5 (permalink) Old 08-06-2019, 03:50 PM Thread Starter
Junior Member
 
henrys072500hd's Avatar
 
Join Date: Mar 2011
Location: Carleton Place, ON
Posts: 32
Yes brakes have worked in the past, years ago I even had the relay changed after I got a message to service brakes. I did put a used dash from a newer truck in a couple of years ago and have not used the truck to pull a trailer until now.

So far all fuses are OK. No ABS light on. 3rd brake works. Cruise works. No trailer connected message. No service trailer brakes message either. I pulled the plug off the back of the brake controller and with the key on checked for power but no pin showed power at the connector. I will search for a wiring diagram.
henrys072500hd is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 08-06-2019, 04:22 PM
DuramaxForum Veteran
 
Join Date: Aug 2009
Location: Berryton, KS
Posts: 1,233
Quote:
Originally Posted by henrys072500hd View Post
No trailer connected message.
The truck doesn't even recognize that you have a trailer connected. Solve that problem and you may have brakes.



Quote:
Originally Posted by henrys072500hd View Post
I will search for a wiring diagram.
GMUPFITTERS.COM has electric manuals in the bodybuilders section of the website. Use the search function to find the information you want.

Ron Nielson
2008 Silverado LT, CCLB, Edge Insight CTS
2009 Arctic Fox 29-5T, Silver Fox Edition, Onan 3600 LPG generator
Ron Nielson is offline  
post #5 of 5 (permalink) Old 08-07-2019, 10:12 AM Thread Starter
Junior Member
 
henrys072500hd's Avatar
 
Join Date: Mar 2011
Location: Carleton Place, ON
Posts: 32
Thank you very much for all your help Ron. Since we have sold our 5th wheel travel trailer and won't be getting another I will just leave the brake system as is. Hope someone else will benefit from your help on here.
henrys072500hd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome