Illumination Problems with front emblem - Chevy and GMC Duramax Diesel Forum
2017-19 GM T-K2 Platform Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission, Etc.

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 11-19-2019, 03:40 PM Thread Starter
 
Join Date: Nov 2019
Posts: 1
Illumination Problems with front emblem

Ive got a 2018 Chevy High Country, and the front lighted emblem recently has stopped illuminating. Is there a fuse for the emblem I should look for? Or has the emblem just burnt out? The dealership installed it when the truck was bought new.
Zach Dodd is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome