Emissions issues L5P - Chevy and GMC Duramax Diesel Forum
L5P TSB (service bulletins, recalls, updates) Postings of Tech Service info for any New L5P engine issues.

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-03-2018, 09:34 AM Thread Starter
 
Join Date: May 2018
Location: Garden Grove Ca
Posts: 8
Emissions issues L5P

Yesterday while driving around town after getting up to Big Bear Lake. My check engine light came on with Service Emissions System on the DIC. And it also said 175 miles till 65 MPH max. Has anyone had this. My truck just rolled over to 5500 miles. I called my service tech and said to add DEF fluid and drive around. And still on. Has anyone had this issues????
TurboL5PZ71 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-03-2018, 01:48 PM
DuramaxForum Fanatic
 
redwngr's Avatar
 
Join Date: Feb 2011
Location: SW Ont
Posts: 5,609
If it's because of 'low def' the message would be 'Exhaust Fluid Low', not 'service emissions'.

2018 GMC 2500 L5P CCSB 4x4 Denali - Mineral Metallic; previous '11 LML, '10 LMM and 04.5 LLY
redwngr is offline  
post #3 of 9 (permalink) Old 06-03-2018, 02:42 PM Thread Starter
 
Join Date: May 2018
Location: Garden Grove Ca
Posts: 8
Yea I figured as much. I’ve read on some items that it could be the DEF filter causing that issue. Just seeing if this has happened to other people and see their fix
TurboL5PZ71 is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-04-2018, 03:48 AM
DuramaxForum n00b
 
Join Date: Sep 2017
Posts: 10
Quote:
Originally Posted by TurboL5PZ71 View Post
Yesterday while driving around town after getting up to Big Bear Lake. My check engine light came on with Service Emissions System on the DIC. And it also said 175 miles till 65 MPH max. Has anyone had this. My truck just rolled over to 5500 miles. I called my service tech and said to add DEF fluid and drive around. And still on. Has anyone had this issues????
I have had the same issue at 10K km. Brought it to my local dealer and they replaced my ECM, which wasn't the issue as it went into limp mode again right away. So I went to a different dealer and they replaced the Nox 2 sensor. Been 6 months since, no issues. Also it seemed my truck was in regen alot, since the sensor the regens are almost un-noticable. My truck works awesome, very happy with it
bullfrog1972 is offline  
post #5 of 9 (permalink) Old 06-11-2018, 07:53 PM Thread Starter
 
Join Date: May 2018
Location: Garden Grove Ca
Posts: 8
So guys I took my truck to get checked out at my local dealership and of course as soon as I get there my check engine light goes off. The DTC was stored as p206b. It seems like some aeration occurred who he’d caused the code to be thrown. There was no power loss. Just message giving me 175miles till 65mph limit. Everything checked out at the dealership. Hopefully the last time this happens
TurboL5PZ71 is offline  
post #6 of 9 (permalink) Old 06-11-2018, 08:12 PM
DuramaxForum Enthusiast
 
Join Date: Oct 2008
Location: Aliso Viejo, Ca
Posts: 2,309
HIGHLY..... doubtful.
AlisoBob is offline  
post #7 of 9 (permalink) Old 06-12-2018, 02:47 PM Thread Starter
 
Join Date: May 2018
Location: Garden Grove Ca
Posts: 8
What makes you say that Bob
TurboL5PZ71 is offline  
post #8 of 9 (permalink) Old 06-13-2018, 08:47 AM
Junior Member
 
Join Date: May 2016
Posts: 57
Had the same issues on my truck, same code in fact. Lost my truck for just over 3 weeks before the issues were sorted out. Even had it back before it went back into limp mode, and it didn't actually reset the miles to limp mode. Just a heads up on that. You maybe driving along and your truck may go into limp mode.
BeardedBBQ is offline  
post #9 of 9 (permalink) Old 02-10-2019, 05:45 PM
Junior Member
 
Luis_Flelite's Avatar
 
Join Date: Dec 2017
Posts: 34
Same happened to mine now but earlier in week my check engine light came on when it was trying to clean the dpf filter but the light turned off now it says I have 145miles intil 65mph max i also pull a gooseneck trailer with mine and I have about 80k on the clock
Luis_Flelite is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome