Crank, No Start - Need Help Diagnosing - Chevy and GMC Duramax Diesel Forum
Maintenance Discuss scheduled maintenace, capacities, filter part numbers, etc.

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 08-15-2019, 06:53 AM Thread Starter
Junior Member
 
SOCOPowerMan's Avatar
 
Join Date: May 2017
Location: Mooresville, NC
Posts: 61
Garage
Unhappy Crank, No Start - Need Help Diagnosing

Hello, I've got a 2002 LB7. I've one through and replaced a lot of the fuel system and now I've got a crank/no start situation.

I have added a lift pump and replaced the filter head. Everything was running at that point. But I still had low rail pressure.

I replaced my CP3. And that's where things stopped working. I am pretty sure I got it all back together correctly. I have a new FPR on the CP3. I know I put the gear on correctly because it's tapered and only goes on one way. I know the mounting plate is on correctly and the four mounting bolts are all pulled tight. So the gear should be in the correct place.

I've got all of the fuel lines hooked up. When I run the lift pump I can see fuel coming all the way out of the last return banjo bolt. So I shouldn't have a bunch of air in the system.

I don't see any plugs that I forgot to plug up on the wiring harness.

But it just cranks and cranks and cranks. Never seems to fire off and want to start. It's almost like I'm not getting fuel, but I know there is fuel in the system. I have at least a 1/2 tank of fuel currently.

Any ideas on where to start?

2003 Chevrolet 3500 DRW, LB& with forged rods and crank. Tuned. Lots of little odds and ends.

I know a whole lot about nothing. And I know nothing about even more.
SOCOPowerMan is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 08-15-2019, 07:03 AM
Duramax Lifetime Supporter
 
M.A.M.'s Avatar
 
Join Date: Apr 2014
Location: Millersburg, OH
Posts: 8,343
Garage
Do you have anyway to hook it to a scanner and see if youíre building rail pressure?


Sent from my iPhone using Tapatalk

9/26/17 80k miles with no issues...

--2015 GMC 3500 SRW/CCLB--

Engine rebuilt @ 170,000 miles due to hole in cylinder #7
First start on 5/13/16

8/29/17 REBUILD 2.0 @ 295k miles


255k miles on 4/1/17, and goin' strong...

S&B Intake, 3" MBRP downpipe, Flo-Pro 5" downpipe back exhaust/no muffler, PPEI tuned no longer, MOONSHINE tuned by Tony @ RidgeRunner, Airdog lift pump...

Monitoring via CTS2

Engine
Fingers Oval Bowl pistons @ 17.5:1 .040 over
Carrillo rods
chromoly pushrods
SoCal Girdle
ATI Super-Damper
ARP main and head studs
Keyed crank and cam
SDP CP3 coversion w/ Sportsman pump

Suspension
305/55/20 MT Baja ATZ P3s on stock 20's...
Kryptonite tie rods/centerlink

BUILD THREAD
M.A.M. is offline  
post #3 of 13 (permalink) Old 08-15-2019, 07:18 AM Thread Starter
Junior Member
 
SOCOPowerMan's Avatar
 
Join Date: May 2017
Location: Mooresville, NC
Posts: 61
Garage
I use DashCommand but I don't think it measures Rail Pressure.

2003 Chevrolet 3500 DRW, LB& with forged rods and crank. Tuned. Lots of little odds and ends.

I know a whole lot about nothing. And I know nothing about even more.
SOCOPowerMan is offline  
Sponsored Links
Advertisement
 
post #4 of 13 (permalink) Old 08-15-2019, 09:03 AM
Duramax Lifetime Supporter
 
M.A.M.'s Avatar
 
Join Date: Apr 2014
Location: Millersburg, OH
Posts: 8,343
Garage
First step is to confirm if your building rail or not, that will dictate what the next step in diagnosing is.


Sent from my iPhone using Tapatalk

9/26/17 80k miles with no issues...

--2015 GMC 3500 SRW/CCLB--

Engine rebuilt @ 170,000 miles due to hole in cylinder #7
First start on 5/13/16

8/29/17 REBUILD 2.0 @ 295k miles


255k miles on 4/1/17, and goin' strong...

S&B Intake, 3" MBRP downpipe, Flo-Pro 5" downpipe back exhaust/no muffler, PPEI tuned no longer, MOONSHINE tuned by Tony @ RidgeRunner, Airdog lift pump...

Monitoring via CTS2

Engine
Fingers Oval Bowl pistons @ 17.5:1 .040 over
Carrillo rods
chromoly pushrods
SoCal Girdle
ATI Super-Damper
ARP main and head studs
Keyed crank and cam
SDP CP3 coversion w/ Sportsman pump

Suspension
305/55/20 MT Baja ATZ P3s on stock 20's...
Kryptonite tie rods/centerlink

BUILD THREAD
M.A.M. is offline  
post #5 of 13 (permalink) Old 08-15-2019, 10:07 AM Thread Starter
Junior Member
 
SOCOPowerMan's Avatar
 
Join Date: May 2017
Location: Mooresville, NC
Posts: 61
Garage
Quote:
Originally Posted by M.A.M. View Post
First step is to confirm if your building rail or not, that will dictate what the next step in diagnosing is.


Sent from my iPhone using Tapatalk
How do I go about doing that? I have an OBDII scanner, so if you can point to some software to use I can do that.

2003 Chevrolet 3500 DRW, LB& with forged rods and crank. Tuned. Lots of little odds and ends.

I know a whole lot about nothing. And I know nothing about even more.
SOCOPowerMan is offline  
post #6 of 13 (permalink) Old 08-15-2019, 10:15 AM
Duramax Lifetime Supporter
 
M.A.M.'s Avatar
 
Join Date: Apr 2014
Location: Millersburg, OH
Posts: 8,343
Garage
Crank, No Start - Need Help Diagnosing

I know an edge CTS2 monitor can pull it up. A snap on scanner, or any equivalent should be able to. I donít know of any software to use that is compatible with your scanner, might have to try a few and see if anything works.


You need to look at desired versus actual fuel rail pressure.


Sent from my iPhone using Tapatalk

9/26/17 80k miles with no issues...

--2015 GMC 3500 SRW/CCLB--

Engine rebuilt @ 170,000 miles due to hole in cylinder #7
First start on 5/13/16

8/29/17 REBUILD 2.0 @ 295k miles


255k miles on 4/1/17, and goin' strong...

S&B Intake, 3" MBRP downpipe, Flo-Pro 5" downpipe back exhaust/no muffler, PPEI tuned no longer, MOONSHINE tuned by Tony @ RidgeRunner, Airdog lift pump...

Monitoring via CTS2

Engine
Fingers Oval Bowl pistons @ 17.5:1 .040 over
Carrillo rods
chromoly pushrods
SoCal Girdle
ATI Super-Damper
ARP main and head studs
Keyed crank and cam
SDP CP3 coversion w/ Sportsman pump

Suspension
305/55/20 MT Baja ATZ P3s on stock 20's...
Kryptonite tie rods/centerlink

BUILD THREAD
M.A.M. is offline  
post #7 of 13 (permalink) Old 08-15-2019, 10:50 AM Thread Starter
Junior Member
 
SOCOPowerMan's Avatar
 
Join Date: May 2017
Location: Mooresville, NC
Posts: 61
Garage
Quote:
Originally Posted by M.A.M. View Post
I know an edge CTS2 monitor can pull it up. A snap on scanner, or any equivalent should be able to. I donít know of any software to use that is compatible with your scanner, might have to try a few and see if anything works.


You need to look at desired versus actual fuel rail pressure.


Sent from my iPhone using Tapatalk
Thanks. I'll see what I can figure out with that. Will it be able to tell me even if I have a crank/no start situation?

2003 Chevrolet 3500 DRW, LB& with forged rods and crank. Tuned. Lots of little odds and ends.

I know a whole lot about nothing. And I know nothing about even more.
SOCOPowerMan is offline  
post #8 of 13 (permalink) Old 08-15-2019, 10:52 AM
Duramax Lifetime Supporter
 
M.A.M.'s Avatar
 
Join Date: Apr 2014
Location: Millersburg, OH
Posts: 8,343
Garage
Quote:
Originally Posted by SOCOPowerMan View Post
Thanks. I'll see what I can figure out with that. Will it be able to tell me even if I have a crank/no start situation?


If youíre not building any rail pressure, thatís obviously why itís not starting. You then need to figure out if youíre getting fuel up to the injection pump, or if you are, why itís not building pressure.


Sent from my iPhone using Tapatalk

9/26/17 80k miles with no issues...

--2015 GMC 3500 SRW/CCLB--

Engine rebuilt @ 170,000 miles due to hole in cylinder #7
First start on 5/13/16

8/29/17 REBUILD 2.0 @ 295k miles


255k miles on 4/1/17, and goin' strong...

S&B Intake, 3" MBRP downpipe, Flo-Pro 5" downpipe back exhaust/no muffler, PPEI tuned no longer, MOONSHINE tuned by Tony @ RidgeRunner, Airdog lift pump...

Monitoring via CTS2

Engine
Fingers Oval Bowl pistons @ 17.5:1 .040 over
Carrillo rods
chromoly pushrods
SoCal Girdle
ATI Super-Damper
ARP main and head studs
Keyed crank and cam
SDP CP3 coversion w/ Sportsman pump

Suspension
305/55/20 MT Baja ATZ P3s on stock 20's...
Kryptonite tie rods/centerlink

BUILD THREAD
M.A.M. is offline  
post #9 of 13 (permalink) Old 08-15-2019, 01:43 PM Thread Starter
Junior Member
 
SOCOPowerMan's Avatar
 
Join Date: May 2017
Location: Mooresville, NC
Posts: 61
Garage
Quote:
Originally Posted by M.A.M. View Post
If youíre not building any rail pressure, thatís obviously why itís not starting. You then need to figure out if youíre getting fuel up to the injection pump, or if you are, why itís not building pressure.


Sent from my iPhone using Tapatalk
I know I'm getting fuel to the pump. I've taken the supply line off the pump and turned on my lift pump. It comes out as a nice, steady (and heavy) flow. So it's after the filter that i'm having issues.

2003 Chevrolet 3500 DRW, LB& with forged rods and crank. Tuned. Lots of little odds and ends.

I know a whole lot about nothing. And I know nothing about even more.
SOCOPowerMan is offline  
post #10 of 13 (permalink) Old 08-15-2019, 02:06 PM
Duramax Lifetime Supporter
 
M.A.M.'s Avatar
 
Join Date: Apr 2014
Location: Millersburg, OH
Posts: 8,343
Garage
Crank, No Start - Need Help Diagnosing

Verify itís building rail pressure. If thereís no way to check it with a computer, crack a fuel line on the rail or on an injector to see if youíre getting pressurized fuel there.


Sent from my iPhone using Tapatalk

9/26/17 80k miles with no issues...

--2015 GMC 3500 SRW/CCLB--

Engine rebuilt @ 170,000 miles due to hole in cylinder #7
First start on 5/13/16

8/29/17 REBUILD 2.0 @ 295k miles


255k miles on 4/1/17, and goin' strong...

S&B Intake, 3" MBRP downpipe, Flo-Pro 5" downpipe back exhaust/no muffler, PPEI tuned no longer, MOONSHINE tuned by Tony @ RidgeRunner, Airdog lift pump...

Monitoring via CTS2

Engine
Fingers Oval Bowl pistons @ 17.5:1 .040 over
Carrillo rods
chromoly pushrods
SoCal Girdle
ATI Super-Damper
ARP main and head studs
Keyed crank and cam
SDP CP3 coversion w/ Sportsman pump

Suspension
305/55/20 MT Baja ATZ P3s on stock 20's...
Kryptonite tie rods/centerlink

BUILD THREAD
M.A.M. is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Chevy and GMC Duramax Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome