Chevy and GMC Duramax Diesel Forum - View Profile: nastynotchback1

nastynotchback1 nastynotchback1 is online now

Senior Member

  Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. nastynotchback1
    07-08-2013 09:26 AM - permalink
    nastynotchback1
    What about fuel filter?Did you try taking the tune out and pulling without it?
  2. JJSLLY
    07-07-2013 10:30 AM - permalink
    JJSLLY
    I hope I can find some help here once again! I'm outside of Durango CO on a family trip towing my fifth wheel and have no HP between idle and 2000rpms in fact I had to back down a small hill to get a run at it, not fun. I have noticed this after I installed a efi live tune from Idaho Rob but all other areas the truck runs great. I have the banks cold air intake with the bigger mouth piece, bigger exhaust, egr block off plate and the Edge CTS monitor. I'm hoping someone can tell me where to start looking? From what I read it sounds like my MAP sensor may not be scaled correctly because you can give it wot and it doesn't smoke. I plan to call Rob tomorrow morning and talk with him also. Thank you, Jason

  About Me

  • About nastynotchback1
    Location
    SC
  • Signature
    2005 GMC SLT LLY/KRYPTONITE UPPERS
    6IN FABTECH/20x12MOTOMETAL969/35IN TOYO M/T
    ATP EFI-LIVE WITH CTS CONTROL
    4IN MBRP STAINLESS DUALS/3IN MBRP DOWN PIPE
    AIRAID INTAKE/AFE TURBO INLET
    PPE RACE FUEL VALVE
    PPE PORTED FUEL FITTING
    AIRDOG DF-200
    SNOW WATER/METH INJECTION
    CALVIN'S TRANS W/SUNCOAST CONVERTER
    TRAIL READY BUMPERS/WARN M15000 WINCH

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 07:30 PM
  • Join Date: 07-19-2010
  • Referrals: 0

  Friends

Showing Friends 1 to 1 of 1
  • Bravo
    • Bravo
    • DuramaxForum n00b
    • Bravo is offline

  Mentions

No results to display...

  Quotes

01-07-2020
08:22 PM - Blacked12 quoted nastynotchback1 in post Error code $053E Stranded/PPEI Autocal
$053E means that the VIN that is sto...
12-03-2019
06:55 PM - nastynotchback1 quoted J83 in post CTS1 problem
Naw it acts up sometimes...
11-22-2019
02:58 PM - J83 quoted nastynotchback1 in post CTS1 problem
Naw it acts up sometimes. if the ...
02:33 PM - nastynotchback1 quoted J83 in post CTS1 problem
Well I can't find my cab...
11-20-2019
11:10 AM - J83 quoted nastynotchback1 in post CTS1 problem
Well I can't find my cable to update...
11-18-2019
06:59 AM - 407driver quoted nastynotchback1 in post CTS1 problem
Thanks Let us know if this works.
11-06-2019
07:47 AM - dgetzlaff quoted nastynotchback1 in post Heated seats issue
If I turn on the driver's side it go...
10-20-2017
12:30 PM - nastynotchback1 quoted Wildmanben in post Trans go shift kit worth it?
As in you bought a whole new tr...
12:26 PM - nastynotchback1 quoted Dirtbikindad393 in post Stock 05 LLY with 155k... What next?? to preserve life?
It is a ball valve that replaces the...
10-19-2017
05:24 PM - Wildmanben quoted nastynotchback1 in post Trans go shift kit worth it?
I limped mine the 1st time on a tow ...
04:05 PM - Dirtbikindad393 quoted nastynotchback1 in post Stock 05 LLY with 155k... What next?? to preserve life?
please tell me about this e-z drain ...
02:53 PM - nastynotchback1 quoted DuramaxSam22 in post Stock 05 LLY with 155k... What next?? to preserve life?
Hey dp_cooper, I have an 05 L...
09-25-2017
11:21 AM - nastynotchback1 quoted Oldrustbucket in post
08-27-2017
05:53 AM - JimmyD quoted nastynotchback1 in post 2017 3500HD 6.6L using oil
My 2005 with 230plus miles does not ...
12:31 AM - D_R_C quoted nastynotchback1 in post 2017 3500HD 6.6L using oil
My 2005 with 230plus miles does not ...
08-21-2017
11:19 AM - nastynotchback1 quoted jc1843 in post Engine Light on and lost all power
Yep, I got tired of writing...
08-04-2017
06:51 AM - nastynotchback1 quoted DmaxJSC in post Allison 1000 going in and out of limp mode
Well after having my truck o...
08-03-2017
08:57 AM - nastynotchback1 quoted Shibby6600 in post Just changed FPR.
The OEM one on rock auto isn't ...
07-02-2017
09:46 PM - caleb.broege quoted nastynotchback1 in post 05 wont start after 3 hr trip
Let me get in on this.My LLy I have ...
06-14-2017
01:36 PM - nastynotchback1 quoted jwcgmc1985 in post

  Garage

    2005 Duramax SLT
    Trai
 
For the best viewing experience please update your browser to Google Chrome