Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 20 of 42 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
I have a 01 duramax extend cab has a lopey idle loss of power after 70mph and smokes really bad while driving but not at a idle. Has had codes checked had a code about fuel rail pressure performance I think it was p0094 or close to that I can get more information on codes tomorrow. Any help is greatly appreciated thanks
 

·
Registered
Joined
·
894 Posts
When was the last time your fuel filter was replaced? If you have a fairly new filter on, it could possibly be a weak cp3. I'd check desired vs actual fuel rail pressure with a scan tool is where I would start.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
Well I just bought the truck and the previous owner said was replaced just a few days before I bought it. I will have it checked out later today
 

·
Registered
Joined
·
894 Posts

·
Registered
Joined
·
894 Posts
Oh ok, its the common rail injection pump.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #7 ·
O ok so what would I say to a parts store or is there a aftermarket one I should look into
 

·
Diesel Addict
Joined
·
7,754 Posts
Sounds like you have 2 issues, the lope is more then likely caused by a FCA/FPR(Fuel Control Actuator) sticking. A good lubricity additive can make a big difference. The lack of power is more then likely caused by the CP3 injection pump failing, dirty fuel filter, or lack of fuel flow from the tank to the engine. Check the desired Fuel Rail Pressure to the actual and see what it says. James
 

·
Diesel Addict
Joined
·
7,754 Posts
You'll need a diagnostic tool such as a tech II, snap on, efilive or equilivant to that. James
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #14 · (Edited)
What type of fuel additives should I try or start using I am picking up a new fuel filter just to change it and a oil filter as well.
 

·
Registered
Joined
·
189 Posts
You didnt put a race cam in it did you? Ha just kidding. I use cetane boost every four or 5 tank fulls. I know gm make a special cleaning solution but they have a special procedure that goes with it.


Kmac
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #16 · (Edited)
Also forgot to say I have to start the truck with starting fluid. I will be working on it this weekend so I will be trying all of the suggestion that you all have given as well as new fuel filter and oil filter and air. Also when I check the fuel pressure what is it supposed to be at?
 

·
Premium Member
Joined
·
62 Posts
Also forgot to say I have to start the truck with starting fluid. I will be working on it this weekend so I will be trying all of the suggestion that you all have given as well as new fuel filter and oil filter and air. Also when I check the fuel pressure what is it supposed to be at?
Starting fluid! You shouldn't spray anything into your intake. You could cause a run away motor and more problems then low fuel pressure.
 
1 - 20 of 42 Posts
Top