Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 20 of 52 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
I recently purchased a 2001 2500HD duramax with 210,000 miles on it. I bought it knowing that it needed a turbo because it poured out smoke and oil out the tailpipe. I just swapped a good turbo on the engine and started it up and it does the same exact thing as before. I know the old turbo was bad because there was so much play in it that the props were hitting the edges and even had some small pieces missing on the edges of them. My next question is what else could be causing this much oil out the exaust? I started it up today and revved it up some and it ran away on me for about 10 sec or so till i managed to plug the intake up with my hand and there is oil thrown a good 30 feet behind the truck. Im thinking it could possibly be a hole in the piston? Im looking for anything that could cause this issue as im prettymuch clueless at this point, i was really hoping to put a turbo in it and be good to go. thanks in advance and heres a few pics of the old turbo.
 

Attachments

·
Registered
Joined
·
64 Posts
Discussion Starter #2
I got up the nerve to try an restart it after it ran away on me earlier today and to my suprise it fired up pretty quick and ran really good, sounded good with no abnormal noises and had great oil pressure considering its probably down at least 3 or 4 quarts from earlier. I could definately smell the oil burning out the exhaust and notice a light haze of smoke like normal, i didnt get the nerve up to try an rev it up because thats when the smoke will really roll and it has the chance of running away on me but at idle it seems to do pretty good. I did notice that im building up ALOT of pressure in my coolant system so i def think the head gaskets are bad but thats not a big deal for me as is the oil problem. Is there a o ring somewhere or a vaccum that could be sucking oil in where its not supposed to be? Im just looking for some answers as to how the oil is getting in the exhaust and i have ruled out the turbo as i just replaced it. Any ideas?
 

·
Registered
Joined
·
87 Posts
Don't use your hand to block the intake to get it to shut down, heard some nasty stories when i was in a diesel class about that. Keep a flat piece of wood around for that. Are you sure that it's not running the oil out of all the piping and intercooler? If that turbo was blowing oil on the intake side that bad the pipes and intercooler must be loaded with it.Check that 1st and clean it all out.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
Thanks for the reply. I know better than to stick my hand in the air intake but i was in a panic and my engine was revving to the moon so i did the first thing i could think of the keep from destroying my engine:). I thought about the possible left over oil in the intercooler and piping but i assumed it would have already burnt that up, especially with how bad it was smoking earlier today. You think it could smoke out the whole block and then some from just the intercooler and piping? Im looking into doing a compression test in the near future im kinda afraid to pull my glowplugs though so i really want to avoid it if possible. Im looking into the pcv system and a oil separator system to see if either of them could be the culprit. Anyone know if these two items could be causing this much oil out the exhaust? Thanks again.
 

·
Registered
Joined
·
87 Posts
I understand, just lookin out for ya. Pull the hoses off the intercooler and see what it looks like, lowest spot in the system.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #6
Its dark out but im gonna run out and pull the lowest hose of just to cure my curiosity. Ill post back in a few.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #7
I just pulled the driverside intercooler tube off and had a black suprise, a good quarter quart or more poured out. Heres a pic. So maybe i am burning oil that is left over from before, i never thought there would be this much in there.
 

Attachments

·
Registered
Joined
·
64 Posts
Discussion Starter #8
Looks like tommorow im going to pull of the intercooler and piping for a thorough diesel cleaning. Fingers crossed this will fix the oil problem and thanks LB7toy for the responses ill keep updated on progress.
 

·
Registered
Joined
·
891 Posts
Yea man, that's probably all it needs, I bet there are gallons of oil in the intercooler!
 

·
NewEST Spinny Thinggg
Joined
·
4,291 Posts
Thats a really good thing in a way I'd say onece you do that and run it a while it'll be fine...the turbos feed alot of oil so it could build up fast.

just be carful on your first test drive if it runs away on the road it's not gonna be fun
 

·
Registered
Joined
·
64 Posts
Discussion Starter #11
Ive got alittle update for those who are interested. I took out the intercooler and all assosiated piping today and cleaned them up with diesel fuel then hosed them out and let them dry in the sun for a few hrs. I got it all put back together and immediately noticed very little smoke at idle and not much revved either. So drove it around the block for about 20 min and it smokes some when i get on it hard but it kept getting less and less and less the more i drove it so i feel it will completely go away over time. This thing tremendous power, very smooth. My only concern at this point is the oil pressure. When i started it cold i had about 65 psi but after 20 min of driving and getting it fully up to temp my oil pressure driving is around 20 psi and close to 0 at idle, as soon as i get off idle the pressure will go to 20 but go to idle and it drops to 0 and my low oil pressure light comes on. I wonder if the oil pressure it a guage issue or related to the engine running away for a about 10 seconds yesterday. If it is a engine issue it would be the bearing wouldnt it? Could i just pull the engine and replace the bearing and have the crank turned or is that no recommended for the duramax? Ive never worked on a diesel before so i just dont know all the rules for them. All together it was a succesfull day and im not sure if i have a head gasket issue or not, i can still squeeze the upper hose a small amount when warm but its pretty hard. I checked my buddies LLY duramax after warm and its the same hardness as mine which is pretty darn hard but not so hard you can dent it in some. Sorry for the long post but its been a long day on the truck and ive got alot on my mind. thanks
 

·
Registered
Joined
·
945 Posts
If you can put a manual oil pressure gauge on it to see what your oil pressure is. The earlier trucks had problems with the gauge clusters. It may be just the oil pressure sending unit.
 

·
Registered
Joined
·
7,819 Posts
subscribing
 

·
Registered
Joined
·
168 Posts
Definitely check the oil pressure with a manual gauge, I'm sure it's just the gauge cluster. Unless the oil got so low it smoked the bearings, in which case it would show up very quickly! And it would already sound like a bag of ball peen hammers in a 30 gallon drum.
My cluster has been giving me fits for a while, but the GT tuner has all the temps, tach and speedo, so I just haven't replaced it. The factory oil pressure gauge shows way low too, some of that is just the wide range the gauge operates in looks odd. When I checked it with a manual gauge it was fine, it just looked like I had very low oil pressure at running temps on the factory gauge.
 

·
Registered
Joined
·
4,629 Posts
It's an 01, check the oil for fuel, bad injectors could cause fuel in the oil which will give you low oil pressure.

easy thing to check and all tooooooooo common with the LB7's
 

·
Registered
Joined
·
64 Posts
Discussion Starter #16
Im gonna check the oil for fuel tommorow first thing, im not exactly sure what im looking for in the oil, i guess ill just smell it and make sure its not reading high as well as dab some on a paper towl. Im also gonna try and get a mechanical guage on that oil pressure but where do i plumb it in? I looked at the oil filter housing and noticed a plug on it, could i tap in there? Ill get to checking it out tommorow.
 

·
Registered
Joined
·
945 Posts
The sending unit for the gauge is above the oil filter. Take it out and hook up a manual gauge there.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #18
I havent put a mech guage on it yet but i did check the old oil and it didnt look overfull or smell like fuel but i decided to change it to see if i noticed and variance in my oil pressure and its exactly the same as before so i would think that would rule out the injectors being bad. I think its just my guage but i wont know till i put the mech guage on it. I know that the oil pressure was jumping around alot today sometimes it would idle at 20 and sometimes 0 and then it would jump between the two, also when i turn on my ac the oil pressure seems to read alittle bit higher as well. Im pretty sure its just my guage judging by all the bouncing around the needle was doing. I drove the truck for about another 20 min or so today and the smoke is all but gone. It smoke black when i get down on it hard and thats all the smoke i see now. I heard a couple different odd noises today and i have videos of both but im not sure how to post them. The first noise was a high pitch hum type noise coming from my air filter and the 2nd one sounded like it was my overflow jug becuse the pressure in my upper hose is really high and before i even started it up today i felt it and it was still holding alot of pressure inside so im pretty sure ill be doing head gaskets in the near future. Ill try to get the videos up so you can hear the two different noises, ill prob put them on youtube and post the links.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #19 (Edited)
Here are the links to my videos, the 2nd one i show my oil pressure issue. Dont mind the FUBAR air intake, it was like that when i bought it and have havent got to it yet. The first noise went away when it got warmed up fully.



 

·
Registered
Joined
·
64 Posts
Discussion Starter #20 (Edited)
I got back from another little drive and its starting to possibly look worse for my engine. It drove great so i let it sit in the driveway and run for about 10 minutes or so and it started getting shaky and almost dieing after a short rev or even after touching the throttle at all and it dosent want to rev up very well like it did before. I also noticed what sounds like a lower end noise and i dont know if these two symptoms are coincidence or if the bearings are bad after all and they can make the engine run like its starting to run. I think the truck is about to get real expensive, im debating if it would better to buy a engine from a junk yard to throw in it or if would be better to do a head job and bearings on this engine? I think id rather just get one complete and toss it in there. Here are a few videos of what its running like now, in the 2nd video i didnt turn it off halfway threw it just died on its own.

 
1 - 20 of 52 Posts
Top