Chevy and GMC Duramax Diesel Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
I have a 2001 Chevy 3500 4x4 with no after market additions. Has about 52000 miles on it. Every once in a while if I have to make a hard stop while under a load (example-car turns in front of me) the transmission will not shift right after that and if you shut the truck off and restart it, the trany works fine. I have noticed that when this happens the battery light will come on, service engine light will come on and the battery gauge will be reading about 10-12 volts if not lower. The gear shift selector light will be blinking on and off and the truck will only move a little bit maybe at 5 miles per hour if that. Most of the time I have to stop in traffic and shut off the truck and restart it. After a couple of start ups after this has happened the servcie engine light will go out. Any ideas. Would like to have an understanding before I take it in to have the codes checked. Could this be a bad battrery, alt. of serpentine belt. I have noticed that when I start it up the battery gauge will hang about 10 volts for about 30 to 45 seconds before it goes up to 13-14 volts. It doesnt matter what the temp is outside, or what the trany temp is. Will do it cold or warm.
 

·
Registered
Joined
·
82 Posts
Sounds like a bad battery connection could be causing some other issue. Have you checked the battery terminals to make sure the bolts are tight and that there isn't any corrosion on them? It could also be a bad ground wire somewhere. Check the ground for both negative cables running off the batteries. I had a similar issue on my '97 1500 and it ended up being a combo of a slightly loose terminal and a bad ground wire. Someone with more experience with a Duramax can chime in but those would be the first two things that I would check.
 

·
Registered
Joined
·
1,587 Posts
Yeah o had this problem mine acted all kinds of weird and one of the terminals were broke!
 

·
Registered
Joined
·
53 Posts
Discussion Starter #4
I shall start there. Didnt notice any corosion but I will check all at try again.
 
1 - 5 of 5 Posts
Top