Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi, new to the thread. Been searching the thread for a few days on issues i have been having with my duramax, but they dont seem to be the same.

Truck is a 2003 chevy 2500hd LB7

I bought the truck because previous owner could not get it to start, so i decided i can take a swing at it. Pulled the valve covers off to remove the injectors and Injection pump to send them to get tested. All 8 injectors failed and so did the pump. So i got my injectors rebuilt, and ordered an injection pump. I installed the parts, cleaned out all the lines, and dropped the tank to clean it outas well. I went to start the truck and the security light was on. I did the relearn process and light went away. Still no success starting. I Noticed the primer pump was leaking, so i rebuilt it. Still not starting. I kept pumping the primer pump while cranking and it built pressure, but still not starting. It sounds like it wants to start, but it just doesnt. I hooked up the scanner and i have more than the desired fuel pressure, my injector balance rate is within the +/- 4. I checked all the grounds and cables, everything checks out, no tears, clean grounds. Last thing i checked was the oil pressure. I dont have a specific reading on the oil pressure, but i have one of the heavy machinery CAT oil pressure guages that marks red for no/low oil pressure, white and green for good oil pressure. When cranking, the oil pressure gets all the way to the green section. I have no codes popping up. I tried a little bit of starting fluid to see if it fires up, it does but it doesnt stay on. Only tried it once because i heard its bad for the engine.
 

·
Registered
Joined
·
706 Posts
Hi, new to the thread. Been searching the thread for a few days on issues i have been having with my duramax, but they dont seem to be the same.

Truck is a 2003 chevy 2500hd LB7

I bought the truck because previous owner could not get it to start, so i decided i can take a swing at it. Pulled the valve covers off to remove the injectors and Injection pump to send them to get tested. All 8 injectors failed and so did the pump. So i got my injectors rebuilt, and ordered an injection pump. I installed the parts, cleaned out all the lines, and dropped the tank to clean it outas well. I went to start the truck and the security light was on. I did the relearn process and light went away. Still no success starting. I Noticed the primer pump was leaking, so i rebuilt it. Still not starting. I kept pumping the primer pump while cranking and it built pressure, but still not starting. It sounds like it wants to start, but it just doesnt. I hooked up the scanner and i have more than the desired fuel pressure, my injector balance rate is within the +/- 4. I checked all the grounds and cables, everything checks out, no tears, clean grounds. Last thing i checked was the oil pressure. I dont have a specific reading on the oil pressure, but i have one of the heavy machinery CAT oil pressure guages that marks red for no/low oil pressure, white and green for good oil pressure. When cranking, the oil pressure gets all the way to the green section. I have no codes popping up. I tried a little bit of starting fluid to see if it fires up, it does but it doesnt stay on. Only tried it once because i heard its bad for the engine.
What's your fuel rail pressure cranking?
 
1 - 3 of 3 Posts
Top