Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 · (Edited)
On the way home from work a couple mornings ago, the Battery Not Charging light came on. My truck died and i coasted into a vacant lot. I thought my alternator took a dump... i waited a few minutes and tried starting it up...she fired right up and i havent had any problems since...maybe a loose connection or wire somewhere? Well im editing this...sounds like in an earlier posted thread it could lead to the edge, which yes i have....hopefully it doesnt happen again or i think ill call edge!! thanks:rolleyes:
 

·
Administrator
Joined
·
8,815 Posts
Yep, could be the edge, could be a bad battery if you still have the originals. If it is a battery, you will have to change them as a pair.
 

·
Smoke. It's what's cookin
Joined
·
2,934 Posts
yep on the edge there is a small square plug in under the hood. Make sure that is tight. Dad's did that and the dealer ended up putting heat shrink tube on it to keep water out and to keep it tight.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
Well after it happening again just yesterday, my dad and i pulled the batteries and alternator and had them tested....they were fine. After hooking everything back up, the truck started and i took it to the local dealer. After they got it in they said it was an Engine Control Module. $900. Thank god it had an 8yr 80k warranty on it so i got luck by 2300 miles. So if anyone has this prob, make sure you get ur truck in before it hits 80k!!
 
1 - 4 of 4 Posts
Top