Chevy and GMC Duramax Diesel Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have an 04 1/2 LLY that wont start without help from wd40 or starting fluid(im aware that starting fluid can destroy this engine). Once you get the truck started it will run all day long just not as good as it should. Ive already checked the usual=filter,housing,wiring. once the truck is running and i shut it off as long as I start it back up within a few seconds it will start right back up but if I let it sit for about 30 seconds it wont start again without using something. Any help would be greatly appreciated
 

·
Premium Member
Joined
·
17,807 Posts
Welcome to the BEST Duramax Forum on the Net-!

Does it start if you pump the primer bulb on top of the fuel filter housing-? Most common problem is the seals dry out in the filter housing, and it sucks air-- that allows the fuel to drain back down the fuel line. Pumping the primer should bring the fuel back up. And it should start.

Many vendors on this site have the seal kit for the filter housing-- $20 and up. The dealer only sells the housing --big $$$.

Moving to LLY for more exposure-- truck runs.
 

·
Registered
Joined
·
126 Posts
Mine was doing the same thing. I had replaced the filter and the filter head. I checked the wiring and the injector connectors. I had finally gave up and took it to a mechanic. He said that 3 of my injectors went out. How the heck does that happen. I'm not looking forward to spending a lil over a grand on injectors tomorrow :-/
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
No it wont start if you pump the primer. the primer stays hard to push so I know its not the housing or mthe primer. Its looking like injectors unless someone else has any more ideas?
 

·
Registered
Joined
·
278 Posts
fuel filter?
 

·
Premium Member
Joined
·
17,807 Posts
I doubt you have bad injectors-- LLY engines do not eat injectors like the early LB7. Mechanics replace them-- they make good money and are easy to do on a LLY-- or they don't know what else the problem can be, and hope that will fix it.

The FICM harness does short out, and it will act like injector problem, also the injector can have loose connector, and cause problems.

First, check for codes. Also read the rail pressure when cranking.
 

·
Registered
Joined
·
5,778 Posts
Mine was doing the same thing. I had replaced the filter and the filter head. I checked the wiring and the injector connectors. I had finally gave up and took it to a mechanic. He said that 3 of my injectors went out. How the heck does that happen. I'm not looking forward to spending a lil over a grand on injectors tomorrow :-/

I just hope your mechanic did a return rate test on all your injectors before proclaiming you had 3 bad ones.
 

·
Registered
Joined
·
126 Posts
I just got my truck back yesterday. It starts now, but it isn't perfect. He said he just replace the 3 that were really bad. He said 2 other were poor, but not as bad as the other 3
 

·
Registered
Joined
·
1 Posts
was yours the lb7 or LLY motor?? I have a truck that won't start with out starting fluid witch I used thinking the motor was toasted so im going threw the list before I get a shop to hook up to it
 
1 - 9 of 9 Posts
Top