Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
So about a month ago, my truck started to have transmission issues. The main symptom are ranger selector is missing, whenever I shift into rev or drive it shifts extremely hard, it’s stuck in limp mode, and the check engine light is on. Whenever I do have it in drive it takes a little bit to actually get the truck going. I know nothing mechanically is wrong with the transmission. I have replaced the NSBU and TCM. And nothing had gotten better. My next step is either the shift linkage or pressure valve ??
 

·
Registered
Joined
·
4,130 Posts
Most likely the wiring harness from the transmission to the TCM. Possible it's the TCM itself, but most likely NOT. There is another post today about this with a Youtube video. Good advice.
 

·
Registered
Joined
·
778 Posts
So about a month ago, my truck started to have transmission issues. The main symptom are ranger selector is missing, whenever I shift into rev or drive it shifts extremely hard, it’s stuck in limp mode, and the check engine light is on. Whenever I do have it in drive it takes a little bit to actually get the truck going. I know nothing mechanically is wrong with the transmission. I have replaced the NSBU and TCM. And nothing had gotten better. My next step is either the shift linkage or pressure valve ??
Did you resole this issue. It takes a while for the new TCM to learn all over again.
 
1 - 3 of 3 Posts
Top