Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I did a little searching before posting.. My wife started my truck while i was gone... went back into the house and it shut off. Went to start it back up and nothing.. It just cranks and that's it! my friend says it sounds like it's not getting fuel. I went to the prime button under the hood and pumped it a few times til it got hard. I then tried to start it and after a few tries and a few minutes later... the prime button is soft again.. could that have to do with anything? Any help would be greatly appreciated! Thanks!

Shane
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Thanks for your reply! I'm actually in Las Vegas NV. and as for warranty work.. I don't think I have any type of warranty on the truck.. It's got quite a few aftermarket parts on it. It's just weird how it just up and died on it's own. This is my first diesel vehicle and it's boggling my mind LOL..... Where do I check the Fuel pressure on this engine? And what is it supposed to be? I know diesels have a much higher pressure.. Thanks again!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
I just bought the truck from a private party about 3 months ago... The truck has a dual filter setup and I believe he told me that they were recently replaced.. is there a way to check the filters or should I just try replacing them? Also could that just cause the truck to shut off with no previous symptoms or problems?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #7 ·
Usually clogged filter will show up when truck is worked on hwy. Sluggish somewhat of a miss. To have no symtoms prior to the crank no fire indicates other problems. Fuel issue, crank sensor ect ect... Let us know what you or the shop finds.
Sluggish huh? You know, I did notice then when I would go up in the mountains ( I live in the Las Vegas Valley ) to go snow boarding.. When leaving to go home, the truck is EXTREMELY sluggish. I'm talking you give it gas and a couple seconds later it will start to build boost and the truck doesn't really moooove for a few moments and then all of a sudden when boost builds.. THEN it'll kinna go.. Is THAT normal? Doesn't really sound like it huh?
 
1 - 4 of 4 Posts
Top