Chevy and GMC Duramax Diesel Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have having issues with 4wd no one can figure out. I have replaced the front axle actuator,transfer case motor and new selector switch. I have no codes in it and I have service 4wd flashing. I had a guy to put a scanner on it and he can control and hear everything shifting but it will not allow him to relearn procedure. We have did it also from the switch put in 2hi then shift truck into neural then turn the selector switch passed 4low and hold for 40 sec and we hear nothing. He said tccm had the program already on it. I am lost to what is next. I have a new tccm to put on but waiting till the end because of the high price dealer wants. Any advice would be helpful. Thanks !
 

· Former GM Tech and parts
Joined
·
4,241 Posts
If you can hear the transfer case shifting but still not 4wd, and you have already replaced the front axle actuator, then you need to be checking wiring to see if the front end is actuating, and if not then need to see if the shift collar or fork in the front axle is compromised.
 

· Registered
Joined
·
759 Posts
Long shot since u hear yours working when connected to a scanner but I took my ‘07 to a shop to have the brake lines replaced and when I got it back the 4wd light was on in the dash. Guy came out with his scanner and couldn’t find anything wrong. He cleared the code and sent me on my way. About 2 miles down the road the light came back on.

Long story short I found the ground below the driver door disconnected. They unhooked it doing the brake lines and never reconnected it. I reconnected it and my 4wd was fine.


The ground I’m talking about is the first one he shows is this video. There’s two in the spot below the drivers door.



Sent from my iPhone using Tapatalk
 

· Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
If you can hear the transfer case shifting but still not 4wd, and you have already replaced the front axle actuator, then you need to be checking wiring to see if the front end is actuating, and if not then need to see if the shift collar or fork in the front axle is compromised.
I'll check when I get home today. Thanks.
 

· Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Long shot since u hear yours working when connected to a scanner but I took my ‘07 to a shop to have the brake lines replaced and when I got it back the 4wd light was on in the dash. Guy came out with his scanner and couldn’t find anything wrong. He cleared the code and sent me on my way. About 2 miles down the road the light came back on.

Long story short I found the ground below the driver door disconnected. They unhooked it doing the brake lines and never reconnected it. I reconnected it and my 4wd was fine.


The ground I’m talking about is the first one he shows is this video. There’s two in the spot below the drivers door.



Sent from my iPhone using Tapatalk
Ok I will check it to. Thanks.
 
1 - 5 of 5 Posts
Top