Chevy and GMC Duramax Diesel Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Didn't see a specific thread for this so I thought to kick one off, My 18 is used in construction so the use is mixed on / off road. As seen in here my HIDs sucked and I,ve got some gremlins in the electronics. I'll be fair and note it has not left me stranded except for a dead battery . Bought 2 new Interstates and life is good, Also installed a set of Bilstein 5100's and Morimoto D5S mains plus the fog set. One of those burned out >>>> seller did make it good but photos and a cut return wire were required. The factory shocks checked out around 38k.

A current issue is the front end, wanders and clunks like my 225k front end on the 13. Making plans to change everything to Moog and be done with it plus add the stabilizer. Also lost one of the Bose speakers and the window switch is going bad on the drivers side. Have a friend whom bought the Denali and hes having same issues / repairs.

Really debating the delete ( now out of emission warranty ) ( chime in ) . My guy wants 6k and 3 days for a cab off which is about right with my point being another 6 grand considering current issues and unknowns. Looking forward I don't see this on being the trusty steed the 13 was. The quality is not there in the build or materials used. If you have a older one I'd strongly suggest keeping it.

On the Morimotos, I'm $515 OTD plus self install so $600 + / - and yes its an improvement but I really can't give a solid endorsement. I can see a measured 300 feet now. Anything outside that in front is toast. I'd need to look up stopping distances but I'm thinking unless I'm going like 25 mph I wont be able to stop in time to spare whatever crossed my path. The fogs are cool but like the factor ones they only light a circle in front of the truck....say 20 feet. Oh ! when I pulled the left battery for the headlight install and completed the work this truck was pissed off. The dash lit up like a Xmas tree. Service traction control, the CE light and one other. I had to open the drivers door, cycle the window and use the scanner to kill the CEL. XM suffered the worst of it. My ID is gone, radio works but the ID is gone and she talks to me once in awhile. I'll start it and the computer will tell me about limited Onstar equipped services lol.

I'm still praying for hail.
 

·
Premium Member
Joined
·
384 Posts
Damn that sucks reading this. My 2019 High Country has many of the same mods and more ... with no major issues ... fixed all the small ones myself. The front end steering linkage on these trucks are junk. I bit the bullet and spent ~ $1,000 and replaced the pitman and idler arms with Kryptonite‘s sealed bearing design (no more ball stud junk) and a Cognito PISK support kit. Steering is tight like a sports car now ... and I have a FabTech 4 inch lift and 35’s which puts a lot more strain on the steering than the factory tires. I also self-installed the Morimotto HID kit for my low beams ... pain in the ass to install ... also had to pull the driver side battery to access the headlight compartment ... but no issues with the HID kit so far (~ 9 months). Not sure what to say about the radio losing the XM ID number. Unfortunately I do agree that my 2010 Avalanche was a superior build to this truck (last GM truck I owned). One the flip side, got several buddies with late-model Ford and Dodge trucks with lots of miscellaneous problems as well. Not sure I have any advise other than this site has lots of resources on how to fix the issues yourself. Best of luck.
 
1 - 2 of 2 Posts
Top