Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
85981 - 86000 of 86459 Posts

·
WOOD... man!
Joined
·
4,323 Posts
Randy, I have always heard that if you didn't start drinking first thing in the morning, you can't stay drunk all day! 🥃

Glad to hear that someone else uses Fireball (for medicinal purposes only). (y) Glad to hear that you are feeling a bit better.

Really love the look of your property. When we get done with our place, we are certainly hoping to have something that seems as peaceful and beautiful as yours Well done Brother.
Thank you. It is, and always will be, a constant work in progress.
Hopefully next year I'll fill in and level the pond. Then the digging will begin and new non-leaking pond will be in a better location.
 

·
WOOD... man!
Joined
·
4,323 Posts
Russ, no news on your buddy's transmission issue?
 

·
Registered
Joined
·
19,240 Posts
Discussion Starter · #85,984 ·
Russ, no news on your buddy's transmission issue?
Fluid level is good but a little dirty. Shift cable is attached on the side of trans and working as it should. Do its something internal. Maybe something inside that has to do with the shifter cable. He is gonna have it rebuilt buy his trans mission guy I guess. Told him to order up a suncoast rebuild kit for his trans. They are about $800 for the kit. In the end its up to him on whats he wants to do, I just gave him my 2 cents

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
6,259 Posts
Morning boys.
Thanks for all the prayers and good wishes.
No real changes as of yet. We are on the very easternmost edge of the alert. The campground across the road isn't on alert.

I haven't heard of any structures being lost yet. The area to the west of the alert area that I posted last night is on evacuation order.

The whole Province is on a state of emergency with the fires. Still about 300 currently burning.

Hayden, my son bought his 1940 GMC tow truck from Mike at Rust Bros before they started the show.

Typical TV show, most of it is made up for entertainment.

My son's buddy used to work with Mike when they were working road construction. Mike has been known as the Rasta Blaster for years. They are also friends with Russell from Dubs Customs.
JF's shop is on the other side of Osoyoos from me. His house is over that way too.

You will notice that I haven't used "eh" in the post...yet.

Everywhere people have their own colloquialisms that they interject into everyday speech.

Sent from my SM-A705W using Tapatalk
 

·
Registered
Joined
·
6,136 Posts
Scott you take care of yourself. Have you got everything of value in the RV ready to go? Like all them skeeery gunz you haz got.

Sent from my SM-A505U using Tapatalk
 
  • Like
Reactions: Blue06Sierra

·
Registered
Joined
·
738 Posts
@1TRIKHD
I have to pipe in here, I was towing a (roughly) 9000 lbs. bumper pull in 124 degree heat last month. I was 200 miles into a 245 mile pull a pretty good grade earlier in the morning. When i was doing the last 45 minutes of the road trip. My trans was at 252 degrees. I usually watch the vitals vigorously but didnt see it until it was too hot. It was shifting hard like being rearended. and slipping sometimes real erratic behavior.

I had it rebuilt 2 years ago with a billet converter and able to hold 700hp (per builder) also a HUGE trans cooler 18"X18" with 5/8" cooler lines. I also maintain my own truck and take what i think is really good care of her. I pulled over shut it down turned it back on and it was slipping bad.....P0700 and U1041 ( I think i recall)
Called a trans guy he said bring it in the TCM is bad. He ordered it and put it in also saying the PNS was bad also. (Raped me) 1700.00.

I get home after the trip ordered 2 gallons of Transynd and both filters from the DMAX Store. I drained what i thought was 2 gallons out replaced both filters filed it up with two gallons. Here is the weird part, when i checked the dip stick. It looks like it is full (170 degree idling in park) It is just below the mid point in the top cross (meaning the top section) hatch to the best of my ability to see. It seems to need to build line pressure to move out of park into drive or reverse. Once in gear it drives fine. Just when it sits for a bit it doesnt want to move until it builds line pressure. I am afraid of over filling it. It drove fine after getting home. It had to relearn but other than that it was fine. Now not so much.
It seems hard to get an accurate reading on the dip stick with the fluid level correct and the being clean . Im waiting for another gallon from DMAX store to see if just adding a little more.

Anyhow short story long....
 
  • Like
Reactions: rwood64083

·
Registered
Joined
·
19,240 Posts
Discussion Starter · #85,990 ·
@1TRIKHD
I have to pipe in here, I was towing a (roughly) 9000 lbs. bumper pull in 124 degree heat last month. I was 200 miles into a 245 mile pull a pretty good grade earlier in the morning. When i was doing the last 45 minutes of the road trip. My trans was at 252 degrees. I usually watch the vitals vigorously but didnt see it until it was too hot. It was shifting hard like being rearended. and slipping sometimes real erratic behavior.

I had it rebuilt 2 years ago with a billet converter and able to hold 700hp (per builder) also a HUGE trans cooler 18"X18" with 5/8" cooler lines. I also maintain my own truck and take what i think is really good care of her. I pulled over shut it down turned it back on and it was slipping bad.....P0700 and U1041 ( I think i recall)
Called a trans guy he said bring it in the TCM is bad. He ordered it and put it in also saying the PNS was bad also. (Raped me) 1700.00.

I get home after the trip ordered 2 gallons of Transynd and both filters from the DMAX Store. I drained what i thought was 2 gallons out replaced both filters filed it up with two gallons. Here is the weird part, when i checked the dip stick. It looks like it is full (170 degree idling in park) It is just below the mid point in the top cross (meaning the top section) hatch to the best of my ability to see. It seems to need to build line pressure to move out of park into drive or reverse. Once in gear it drives fine. Just when it sits for a bit it doesnt want to move until it builds line pressure. I am afraid of over filling it. It drove fine after getting home. It had to relearn but other than that it was fine. Now not so much.
It seems hard to get an accurate reading on the dip stick with the fluid level correct and the being clean . Im waiting for another gallon from DMAX store to see if just adding a little more.

Anyhow short story long....
Have you called your trans builder and told him how its acting? How long was the temp at 252 that seems a little extreme? Did 18x18 trans cooler replace the factory cooler and is it in the factory location? New fluid level seems fine to me, you really dont want it any higher cause it could possibly puke out the vent on top of the trans. How did the fluid look and smell when you drained it?

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
738 Posts
Have you called your trans builder and told him how its acting? How long was the temp at 252 that seems a little extreme? Did 18x18 trans cooler replace the factory cooler and is it in the factory location? New fluid level seems fine to me, you really dont want it any higher cause it could possibly puke out the vent on top of the trans. How did the fluid look and smell when you drained it?

Sent from my LM-G900 using Tapatalk
I dont speak to the trans guy anymore. We had a falling out after having the truck for almost 3 months. Reputable builder just lacks communication. I spoke to Mike L. from Inglewood trans. His shop is about 30 minutes form me. He said just add fluid until it is full. Thats what it sounds like to him. He also said 252 bad, 300 and higher is bad. The fluid wasnt even burnt and it was still red i changed it anyway. It was just changed a month before this trip.
I get the fluid tonight. I am going to add just a bit that by chance it is a little low. It seems when i check it it picks up fluid off of the tube if you know what i mean. If this isnt it. Its going to Mikes shop.
 

·
Registered
Joined
·
738 Posts
Have you called your trans builder and told him how its acting? How long was the temp at 252 that seems a little extreme? Did 18x18 trans cooler replace the factory cooler and is it in the factory location? New fluid level seems fine to me, you really dont want it any higher cause it could possibly puke out the vent on top of the trans. How did the fluid look and smell when you drained it?

Sent from my LM-G900 using Tapatalk
Sorry, the trans cooler is in the factory location and replaced the factory cooler.
 

·
Registered
Joined
·
19,240 Posts
Discussion Starter · #85,993 ·
I dont speak to the trans guy anymore. We had a falling out after having the truck for almost 3 months. Reputable builder just lacks communication. I spoke to Mike L. from Inglewood trans. His shop is about 30 minutes form me. He said just add fluid until it is full. Thats what it sounds like to him. He also said 252 bad, 300 and higher is bad. The fluid wasnt even burnt and it was still red i changed it anyway. It was just changed a month before this trip.
I get the fluid tonight. I am going to add just a bit that by chance it is a little low. It seems when i check it it picks up fluid off of the tube if you know what i mean. If this isnt it. Its going to Mikes shop.
Let us know if adding fluid fixes the issue. Thats good that your do close to Mikes shop in case you need them guys to investigate more for ya.

Sent from my LM-G900 using Tapatalk
 

·
Registered
Joined
·
738 Posts
Let us know if adding fluid fixes the issue. Thats good that your do close to Mikes shop in case you need them guys to investigate more for ya.

Sent from my LM-G900 using Tapatalk
Thanks, Ill update tomorrow as i find more....
 
  • Like
Reactions: 1TRIKHD

·
WOOD... man!
Joined
·
4,323 Posts
@1TRIKHD
I have to pipe in here, I was towing a (roughly) 9000 lbs. bumper pull in 124 degree heat last month. I was 200 miles into a 245 mile pull a pretty good grade earlier in the morning. When i was doing the last 45 minutes of the road trip. My trans was at 252 degrees. I usually watch the vitals vigorously but didnt see it until it was too hot. It was shifting hard like being rearended. and slipping sometimes real erratic behavior.

I had it rebuilt 2 years ago with a billet converter and able to hold 700hp (per builder) also a HUGE trans cooler 18"X18" with 5/8" cooler lines. I also maintain my own truck and take what i think is really good care of her. I pulled over shut it down turned it back on and it was slipping bad.....P0700 and U1041 ( I think i recall)
Called a trans guy he said bring it in the TCM is bad. He ordered it and put it in also saying the PNS was bad also. (Raped me) 1700.00.

I get home after the trip ordered 2 gallons of Transynd and both filters from the DMAX Store. I drained what i thought was 2 gallons out replaced both filters filed it up with two gallons. Here is the weird part, when i checked the dip stick. It looks like it is full (170 degree idling in park) It is just below the mid point in the top cross (meaning the top section) hatch to the best of my ability to see. It seems to need to build line pressure to move out of park into drive or reverse. Once in gear it drives fine. Just when it sits for a bit it doesnt want to move until it builds line pressure. I am afraid of over filling it. It drove fine after getting home. It had to relearn but other than that it was fine. Now not so much.
It seems hard to get an accurate reading on the dip stick with the fluid level correct and the being clean . Im waiting for another gallon from DMAX store to see if just adding a little more.

Anyhow short story long....
Only thing I would have done differently would have been leaving it idling after pulling over until the temps dropped back to normal.
Hope there's no serious damage.
 
  • Like
Reactions: ChevyTech77

·
WOOD... man!
Joined
·
4,323 Posts
Taking a break working in the shop. Loaded the 99 pull from Friday night.

 

·
WOOD... man!
Joined
·
4,323 Posts

·
Registered
Joined
·
6,259 Posts
Scott you take care of yourself. Have you got everything of value in the RV ready to go? Like all them skeeery gunz you haz got.

Sent from my SM-A505U using Tapatalk
We're getting there. Don't have any skeeery gunz, so no need to put them in there. Going through some stuff to put in the RV right now.

Sent from my SM-A705W using Tapatalk
 
85981 - 86000 of 86459 Posts
Top