Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
794 Posts
Discussion Starter · #1 ·
I ordered an AC/Delco MAP sensor from Rock Auto (part # 213796) and installed it on the passenger side intake manifold. Once I hooked it all up, I now keep getting a P0238 code. After doing some research, it seems I may have a Turbo boost sensor and a MAP sensor. Does this sound accurate? I can't seem to get a 100% certain conclusion.

Are the two sensors different part numbers? Did I put a MAP sensor in the Turbo Boost Sensor location?

I found an exact looking sensor on the driver side, underneath the two large wiring harnesses. Is that the MAP sensor?

See photos...
1079764
1079765
 

·
Registered
Joined
·
794 Posts
Discussion Starter · #3 ·
Thanks! I had been researching this all day and that is what I concluded but I just wanted one more confirmation.

I think my LB7 might be different than most of the Google search results I found, maybe because it's an '01.

Hated to start a new thread but needed to be sure. Thanks!!
 

·
Former GM Tech and parts
Joined
·
3,504 Posts
The MAP sensor is the sensor that reads boost- Manifold Absolute/Air Pressure sensor is what it is. It is located on the intake runner on the 01 engines, but is in the neck of the bridge on 02-04 engines. The sensor on the bracket in your picture is the barometric pressure sensor, it measures the outside air pressure.
The P0238 is actually a circuit high voltage code- but if you didn't have it until after you changed the sensor, I would bet that the sensor is the issue.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top