Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Tonight I was working on my dads 2003 ccsb duramax all stock new injectors at 145k currently has 156k. I removed the "Hot" side (drivers side) inter cooler tube off the turbo to test for leaks and I could see a oil resido and I can wipe it off but there seems to be a lot on turbo and in the IC boot. So I pressurize the system can't find any leaks. the problem the truck is have is it has no power the turbo starts to spool and all you hear is phsss and you go no where's. And I have the weast gate disconnected but have tried it an seems to function alright The truck is a work truck and is pretty beat up. Just trying to get some input of weather this is symptoms of a bad turbo or head gaskets going as my dad doesn't want to spend much on it.
Thanks in advance for any help.


2002 Chevy 2500HD lb7 no emissions ecsb
5inch exhaust to 6 in stack
K&N CAI
Pro Fab intake horn
PPE boost valve
Efi Live not installed due to not working belived to be because mass air flow sensor not working.
When efi live is on the truck won't build over 5psi of boost and when shifts drops to 1000rpm on all tunes
The tunes are from Duramax Tuner 1 stock 2 light tow 3 heavy tow 4 100hp street tune 5 200hp race tune.
Truck runs the same on all tunes
 

·
Registered
Joined
·
4,933 Posts
the 03 was the first year to have PCV hoses into the intake right? that could be the source of some of your oil, or like me it could be coming from the turbo. the head gasket would pressurize the cooling system, not put oil in the IC tubes. if it were me, i would do the PCV vent mod, clean the tubes and see if the oil comes back, might have nothing at all to do with your problem. are you SURE the waste gate is working? they have a nasty habit of premature blow off.

if you want to test the head gasket scenario, run the truck get it hot then park it, if the upper rad hose is hard the next day, or you open the cap on the tank and it dents your hood and puts your hand in a cast then you have a bad head gasket. also you may see soot in the tank. otherwise the heads are ok. do you have a way to measure boost pressure? numbers would be good to help figure out the problem.


also, what elevation are you at?
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
I plan on a boost gauge for it and if I put pressure on the wast tube the wast gate opens just not sure at what pressure but even with it disconnected it dosent do it but if it wasn't closing all the way that could be part off the problem and not sure of elevation but I'm up in Vermont if that helps any and is there some good threads on that vent?
Thanks


2002 Chevy 2500HD lb7 no emissions ecsb
5inch exhaust to 6 in stack
K&N CAI
Pro Fab intake horn
PPE boost valve
Efi Live not installed due to not working belived to be because mass air flow sensor not working.
When efi live is on the truck won't build over 5psi of boost and when shifts drops to 1000rpm on all tunes
The tunes are from Duramax Tuner 1 stock 2 light tow 3 heavy tow 4 100hp street tune 5 200hp race tune.
Truck runs the same on all tunes
 

·
Premium Member
Joined
·
10,431 Posts
Search PVC re-route.
 

·
Premium Member
Joined
·
458 Posts
the 03 was the first year to have PCV hoses into the intake right? that could be the source of some of your oil, or like me it could be coming from the turbo. the head gasket would pressurize the cooling system, not put oil in the IC tubes. if it were me, i would do the PCV vent mod, clean the tubes and see if the oil comes back, might have nothing at all to do with your problem. are you SURE the waste gate is working? they have a nasty habit of premature blow off.

if you want to test the head gasket scenario, run the truck get it hot then park it, if the upper rad hose is hard the next day, or you open the cap on the tank and it dents your hood and puts your hand in a cast then you have a bad head gasket. also you may see soot in the tank. otherwise the heads are ok. do you have a way to measure boost pressure? numbers would be good to help figure out the problem.


also, what elevation are you at?

Search PVC re-route.
LB7s are already routed to the atmosphere...
 

·
Premium Member
Joined
·
10,431 Posts
Not sure if the Cali. emissions did, just answering the fore mentioned question.
 

·
Premium Member
Joined
·
458 Posts
They are routed to the atmosphere as well.
 

·
Registered
Joined
·
613 Posts
If you grab the turbo wheel does it have allot of play on the shaft up/down? And does it spin free?
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #9 ·
As far as I could tell and our ace shop macanic could it is roughted to the atmosphere and I would cheak shaft play but I'm trying not to tear that far into it yet cuz I installed a profab intake horn on my truck and don't want to remove this one for the fun of it. There not very fun have to remove a bunch to get to them and


2002 Chevy 2500HD lb7 no emissions ecsb
5inch exhaust to 6 in stack
K&N CAI
Pro Fab intake horn
PPE boost valve
Efi Live not installed due to not working belived to be because mass air flow sensor not working.
When efi live is on the truck won't build over 5psi of boost and when shifts drops to 1000rpm on all tunes
The tunes are from Duramax Tuner 1 stock 2 light tow 3 heavy tow 4 100hp street tune 5 200hp race tune.
Truck runs the same on all tunes
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #10 ·
And I need to remove my profab to change my FPR and I dread it cuz those allen head bolts are great if you can get on them strait thinking of modifying mine to put regular bolts in when I remove it


2002 Chevy 2500HD lb7 no emissions ecsb
5inch exhaust to 6 in stack
K&N CAI
Pro Fab intake horn
PPE boost valve
Efi Live not installed due to not working belived to be because mass air flow sensor not working.
When efi live is on the truck won't build over 5psi of boost and when shifts drops to 1000rpm on all tunes
The tunes are from Duramax Tuner 1 stock 2 light tow 3 heavy tow 4 100hp street tune 5 200hp race tune.
Truck runs the same on all tunes
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #11 ·
Update intercooler tube on the "hot" side had rubbed a 1/2 hole in the aluminum so I pulled the tube off my truck cuz it's in the shop in need of a tranny and it's got much better power but it's still not like my 02 I have a boost gauge on the way for it to see what it makes to compare to mine


2002 Chevy 2500HD lb7 no emissions ecsb
5inch exhaust to 6 in stack
K&N CAI
Pro Fab intake horn
PPE boost valve
Efi Live not installed due to not working belived to be because mass air flow sensor not working.
When efi live is on the truck won't build over 5psi of boost and when shifts drops to 1000rpm on all tunes
The tunes are from Duramax Tuner 1 stock 2 light tow 3 heavy tow 4 100hp street tune 5 200hp race tune.
Truck runs the same on all tunes
 
1 - 11 of 11 Posts
Top