Chevy and GMC Duramax Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
i have a 03 duramax with a lb7 and my truck in the morning take forever to warm up 10 minutes idling temp gauge does not move tell 3 miles down road and takes 6 miles to get up to first slash on temp gauge is this normal outside temps are 48 in the morning and 55 during day does same during the day and when it gets to temp when going down highway or in town my gauge evrey 2 mins or so will go from 190 down to the first slash mark go back up slowy back down and at idle it will stay at first slash mark above 160 i put new thermostats in from o riley auto parts they look very flimsy is this my problem let me know thatnk you!!!
 

·
Registered
Joined
·
4,422 Posts
I'd put OEM replacement thermostats back in it. Could maybe be your problem, that or your gauge. It takes awhile for diesels to warm up though so I wouldnt worry. takes me 10mins idling and 2-5mins driving to reach temp.

Fill out your sig, do you have any mods? Tuning? Ect?

If I run a hot tune I will notice drops in engine temp and EGTs when I run in town compared to highway(less fuel = less heat)...so fill out your sig. Will help...
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
i also think i gonna put ac delco thermostats back these ones i put in look cheap and flimisy unlike the ones i took out i will be putting them in monday 120 bucks from dealear ouch and my truck is bone stock except my turbo back 4 inch exhaust
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
ok put oem stats back in and now it runs all the time at about 185-190 just a touch under the 210 mark and when i idle for proubly 5 mins or longer it drops down to the first solid line under neath the 210 so 170 175 is this normal soon as start driving slowly comes up
 

·
Premium Member
Joined
·
470 Posts
I just put new ones in from napa and they look like the factory ones and are working perfect and they were about half the dealer price.
 

·
Premium Member
Joined
·
470 Posts
Mine runs between 182 and 198 by my CTS monitor.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
i hooked up the snap on scanner runs between 181 and 193 so not that far off well see what she does tommorow with 15,000lbs behind her
 
1 - 8 of 8 Posts
Top