Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 5 of 5 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
Been fighting an overboost code and power issues with black smoke for a while now. Decided to borrow my buddy's Edge CTS2 to use as a monitor without the tunes. Once up and running I was able to see that my truck was idling at 7psi of boost and my turbo vanes were stuck at 9%. I also checked for codes and found three.
p2227 Barometric Pressure Circuit Performance
u0106 Lost Communications With Glow Plug Control Module
p0234 Engine Overboost
I've been searching through the forums and gathered the following information. With a bad Barometric or Maps sensor, my ECM can misread my air levels which would be responsible for the 7psi of boost at idle. I can only assume this is also responsible for throwing the overboost code being that I'm 7psi over? I'm to believe the barometric sensor and overboost codes are due to one another and the GPCM code is something seperate.
Any tips for diagnosing? Should go right ahead and replace the baro sensor and maps sensors? Also, my turbo vanes showing stuck at 9% but feel like they're functioning as they should, is there a way to manually making sure they are opening and closing? This seems like a faulty turbo vane position sensor to me but I'm somewhat new to all of this.
Any information/advice would be greatly appreciated. Thanks in advance.
 

·
Registered
Joined
·
307 Posts
I don't have answers for you, however, I am having similar issues with an LB7. Overboost codes and more smoke than expected. I have an CS2 on the way myself and will share my data once I have some. Otherwise just consider this a comment to learn some myself.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
@RaticalM4 Hey! Well glad I’m not the only one although I’m sorry to hear that lol. Mine seems to run great at lower rpms I don’t really notice much untill I’m accelerating hard. Good luck would like to see what your CS2 reads keep me posted!
 

·
Registered
Joined
·
307 Posts
Well my cs2 hasn’t explained the overboost code. At wide open it’s not making over 22psi of boost and 0 at idle. I have got a lead on my loss of power though. Desired fuel pressure was 23k and actual was around 6k. I’m struggling to understand how I can get too much boost while also not enough fuel but I’m going to the drawing board on the rail pressure issue first. Good luck on sorting it out.
 
1 - 5 of 5 Posts
Top