Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!

1 - 4 of 4 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi guys,
I started my truck , a 2005 2500HD Duramax LLY to warm it up after a few days. It started right up with no hesitation. I went to get in after a few minutes and it died. I cranked but it wouldn't start. and it's been 5 days now. Here's the list of things I checked and I know:
1. Batteries are fully charged and I have a charger running constantly to make sure.
2. Filter is new (changed twice) and filter head and pump bulb are in good order and rock hard after 2 pumps. No visible fuel leak anywhere and no air in the low system.
3. FRP Fuel rail Pressure shows above 15000 PSI cranking (assuming rail pressure is good).
4. RPM shows about 130 RPM while cranking (assuming crank sensor is good)
5. FICM Fuel Injector Control Module wirings are in good order, no cuts or breaks and both big connectors receive ignition 12v and both have grounds.
6. Injectors 2 & 7 are both ice picked and connected.
7. All fuses and relays are in working order.
8. I disconnected the FPR fuel pressure regulator and still no start.
9. There was never a RPM surge before.
10. there are no codes at all. If I keep cranking it until it cuts off the power after 30 seconds, I managed to get it to throw two codes: P0611 and P0090 but never both at the same time. And the P0090 was probably because i disconnected the FPR.
To me it sounds electrical. We have air, fuel, timing (I hope) and compression. It doesn't even sound like that it want to start, no fumes anywhere and the exhaust is bone dry. I broke down and sprayed diesel fuel with spray bottle down the intake and she seems to want to fire up, so that tells me that the injectors are not opening up. The fuel pressure is plenty so it has to be electrical.
Please help as this is a farm work truck and the animals are going hungry. I'm stuck down in South America for Covid-19and there are no AutoZones that I can throw parts at it. I have a OBDII scanner, no TECH 2 or fancy things but do have a fully stocked shop here.
 

·
Registered
Joined
·
2 Posts
Hi guys,
I started my truck , a 2005 2500HD Duramax LLY to warm it up after a few days. It started right up with no hesitation. I went to get in after a few minutes and it died. I cranked but it wouldn't start. and it's been 5 days now. Here's the list of things I checked and I know:
1. Batteries are fully charged and I have a charger running constantly to make sure.
2. Filter is new (changed twice) and filter head and pump bulb are in good order and rock hard after 2 pumps. No visible fuel leak anywhere and no air in the low system.
3. FRP Fuel rail Pressure shows above 15000 PSI cranking (assuming rail pressure is good).
4. RPM shows about 130 RPM while cranking (assuming crank sensor is good)
5. FICM Fuel Injector Control Module wirings are in good order, no cuts or breaks and both big connectors receive ignition 12v and both have grounds.
6. Injectors 2 & 7 are both ice picked and connected.
7. All fuses and relays are in working order.
8. I disconnected the FPR fuel pressure regulator and still no start.
9. There was never a RPM surge before.
10. there are no codes at all. If I keep cranking it until it cuts off the power after 30 seconds, I managed to get it to throw two codes: P0611 and P0090 but never both at the same time. And the P0090 was probably because i disconnected the FPR.
To me it sounds electrical. We have air, fuel, timing (I hope) and compression. It doesn't even sound like that it want to start, no fumes anywhere and the exhaust is bone dry. I broke down and sprayed diesel fuel with spray bottle down the intake and she seems to want to fire up, so that tells me that the injectors are not opening up. The fuel pressure is plenty so it has to be electrical.
Please help as this is a farm work truck and the animals are going hungry. I'm stuck down in South America for Covid-19and there are no AutoZones that I can throw parts at it. I have a OBDII scanner, no TECH 2 or fancy things but do have a fully stocked shop here.
This is almost exactly what I'm facing right now. Would loved to have seen a forum on this. What resolved your issue?
 
1 - 4 of 4 Posts
Top