Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
stuck in south fl with my kodiac that wont go over 2000rpm and top speed of 23. wont shift into 3rd. if let sit a few minutes may work for a little while. then kicks back down. 60,000 miles on it. need ideas on how to fix. its under warranty still, but am on a dead line in ct. towing three cars. please advise on next step. thank you
 

·
Premium Member
Joined
·
17,806 Posts
How long since the fuel filter has been changed-? Start here first!

Do you have any codes-? Some autoparts read them for free!

Air filter plugged-?

Blowing any smoke-?
 

·
Registered
Joined
·
1,834 Posts
sounds like limp mode. check engine light on? got any codes? if its not fuel filter...
 

·
Registered
Joined
·
7,558 Posts
mine does that with the PTO switch on.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Ugh

It was not the fuel filter. light came back on, wont go over 2k rpm. Code came up as a sensor, then said see manufacturer for exact application. advanced auto did it. so replaced speed sensor, still no go. what next.
 

·
Registered
Joined
·
2,379 Posts
what are the code numbers for example P0101 or P0000
 

·
Premium Member
Joined
·
17,806 Posts
Have you been driving in the snow-?

The 107 code is barometric pressure -- These freeze up on some of the 2500 trucks, so GM modified the nozzle. Also check all the hoses to the innercooler-- a hose may be loose or off-- the lower is usually the one.

The 540 code is Air Intake Heater relay- could be a bad relay or the 175 amp fuse may be blown.

I suggest that you make sure the intake filter is clean and also clean the MAF sensor in the intake- autoparts have a special cleaner for it-- BE CARFEFUL- it is fragile and expensive.

Then check the barometric sensor- it is mounted in the intake manifold.

What about the fuel filter?

Hope this helps-
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
I am so screwed, please help

under warrantty yet will not tow. just put in second fuel filter, along with control module. started ran fine. shut off will not start. cranks fine, no fire up. just paid hundred for a guy to raed again. came up with turbo sensor. what is going on? just drove from ct to key west, and now stuck in naples fl.have three cars on trailer. need to get moving. any help is appreciated.
 

·
Registered
Joined
·
2,379 Posts
the EGR problem P0403 will cause the P0299 which is turbo underboost code. the EGR will put your truck into limp mode. take care of the EGR problem first
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top