Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Vote for the Site Favourite ROTM winner for the year of 2021 HERE!
21 - 24 of 24 Posts

·
Registered
Joined
·
746 Posts
Well I should read the other messages before going on. Forget about the other checks if those other lights go off after a few seconds. D
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #22 ·
You do have corrosion damage to the remote module. The last pic shows it. Also when I click on the pic a third pic shows up of a damaged wire harness, where was that at. Dean
The damaged black wire is a ground 10ga ground d wire that mounts up behind the bumper on the driver's side
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #23 ·
So that theft derrent module surrounds the lock cylinder in the steering column. The code your getting is a lack of communication between that and the ecm when the key is being turned. It's not the keys because when I looked into the data on the scanner it was reading a valid key but still not sending the "start password" to the ecm..........


This is what the scanner was reading about the anti theft deterrent code
 

·
Registered
Joined
·
746 Posts
So that theft derrent module surrounds the lock cylinder in the steering column. The code your getting is a lack of communication between that and the ecm when the key is being turned. It's not the keys because when I looked into the data on the scanner it was reading a valid key but still not sending the "start password" to the ecm..........


This is what the scanner was reading about the anti theft deterrent code
Well the good news then is there is no data buss problem. Yours is definitely within the security system, if the system sees a good key code I would likely think it may be the security module itself especially if you can reset it and it works for a bit before the problem starts up again. Never changed one of those so no idea what all needs to be done with that task. Dean
 
21 - 24 of 24 Posts
Top