Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I’ve had my truck n the shop for 3 months. It’s getting good rail pressure. It cuts out & stalls for 2 or 3 seconds & goes back to normal. Sometimes it does it a lot & sometimes I can drive a few hundred miles before it does it. The shop has been tracing out wires. Fuse box, check all modules, even swap computers & different tunes. It has a kory Willis efi live 5 with fass system. It’s still doing it
 

·
Registered
Joined
·
10,692 Posts
If you arent working on it yourself the next step is to find a new shop. Where are you located, I might be able to help with a reputable shop
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Cutting out going down the road, sometimes it doesn’t & sometimes it does it’s crazy. It ant filters or modules. I’ve seen other people on this forum have same problems but nobody ever says how they fixed it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
2011 gmc 2500 lml Duramax with Kory Willis efi live 5, has 150 fass system, stage 2 cold air intake. Have swapped modules out. Even pulled computer & put another one n it with egp tunes still cuts out at various times. Even on lowest tune setting. Was hoping someone on this forum who has same issues could tell me how they resolved this.
 

·
Premium Member
Joined
·
291 Posts
how are your fuel lines? any chance sucking air?
 

·
Registered
Joined
·
86 Posts
2011 gmc 2500 lml Duramax with Kory Willis efi live 5, has 150 fass system, stage 2 cold air intake. Have swapped modules out. Even pulled computer & put another one n it with egp tunes still cuts out at various times. Even on lowest tune setting. Was hoping someone on this forum who has same issues could tell me how they resolved this.
Check all the engine compartment wiring harnesses for damage caused by rubbing or chaffing, fairly common on these trucks as they age:thumbsup
 

·
Registered
Joined
·
691 Posts
Check your wiring harness that runs across the air conditioning line over the top of the engine. That harness is prone to wear at that location.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
10 Posts
any update

I’ve had my truck n the shop for 3 months. It’s getting good rail pressure. It cuts out & stalls for 2 or 3 seconds & goes back to normal. Sometimes it does it a lot & sometimes I can drive a few hundred miles before it does it. The shop has been tracing out wires. Fuse box, check all modules, even swap computers & different tunes. It has a kory Willis efi live 5 with fass system. It’s still doing it
Having similar issues.. any update?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top