Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all,
this thursday im going to look at a 2011 gmc 2500 z71 with the lml duramax. its got 155,000 miles and is a clean mississippi truck for 13,900. the only problem is is that it wont run. the guy whos selling it sent pics of the code reader throwing 5 glow plug codes for 5 different glow plugs, and the trucks in limp mode because of it. any clue as to what could have caused that and what could fix it? my friend and i thought to just order a set of new glow plugs, but i find it really odd that that many went out all at once. Im a cummins guy at heart, and most of my diesel knowledge revolves around the 5.9's, so any help would greatly be appreciated! i dug around online and found that the glow plug control module can be a culprit, or weak batteries, but i really have no clue myself. Thanks!
 

·
Registered
Joined
·
2,383 Posts
The older trucks don't care if the glow plugs work or not. I can't imagine that causing any limp mode but I've been wrong before.

Sent from my SM-N920V using Tapatalk
 

·
Premium Member
Joined
·
8,491 Posts
Even if all eight glow plugs are bad, the truck will still run. That’s not the problem.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
645 Posts
How old are the batteries in it? original? Replace. Low voltage from batteries have been known to ruin glow plugs. Replace all of em if you get it. Also there are likely more codes.
 
1 - 4 of 4 Posts
Top