Chevy and GMC Duramax Diesel Forum banner
  • Hey Everyone! Enter your ride HERE to be a part of this months Ride of the Month Challenge!
1 - 6 of 6 Posts

Registered
Joined
9 Posts
Discussion Starter · #1 ·
I almost never post here because I usually find an answer to my question by searching. But, this one is driving me nuts. Sorry for the long description but I want to include everything I have tried.

I have a 2013 Silverado with 185K on the LML. It's bone stock. I left something plugged into the accessory plug and ran down the batteries in June. Truck still started but it threw some codes. I cleared the codes without much thought (didn't record them all). P2201 and P2610 kept coming back. I replaced the #1 NOX sensor, cleared codes, and P2201 hasn't returned. I still have P2610 for the engine off timer. I was using a CTS to clear the codes but decided to try my Bosch scan tool. It says "P2610 PERMANENT" even after I try to clear it. The CEL will only stay off for a couple of starts. I have tried the procedure of disconnecting the ECM connectors 3 or 4 times now. I've disconnected both batteries 3 times. How in the heck do I get my CEL to stay off? DO I have to resort to a dealer visit? This one is driving me crazy.
 

Registered
Joined
9 Posts
Discussion Starter · #2 ·
Anybody got anything?
 

Registered
Joined
10,684 Posts
That code used to pop up years and years ago when guys were using the ppe standard tuners or switch to efi. Would drive guys nuts back in 08. You would have to disconnect the ecm for 90 seconds while the batteries were still plugged in and then clear the code and it would go away. It's for something like the ignition being on so too long with the engine not running.
 

Registered
Joined
9 Posts
Discussion Starter · #5 ·
have you tested the life of both batteries?

making sure one does not have issues
After your suggestion I had both batteries load tested separately and was told they are fine.
 

Registered
Joined
9 Posts
Discussion Starter · #6 ·
Well here is an update. Weather has been crappy so I've been driving the truck more and just ignored the code. Yesterday the CEL cleared and no codes. I have had 6 or 7 restarts and no light or codes.
 
1 - 6 of 6 Posts
Top