Chevy and GMC Duramax Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have only owned my truck for a few months, so Im new to the diesel world. The truck is bone stock at this point.

I have noticed on a few occasions that after sitting at a stop light and when I take off for the green light, I had white smoke coming pouring out of the tail pipe. The smoke was so bad the guy behind me didn't move until I was about 30 yards in front of him. I spoke with several people and they told me it was the indirect injector. I have since replaced the injector and drove the truck with no issues until this morning(about a month). I did notice the truck is in regen right now, and I took off from a light and I had white smoke again. This time the white smoke is not near as bad as before the injector replacement, but definitely did happen.

The only other issue I have had with the truck is the def heater went bad, but was covered under a special policy with Gm...so it was also replaced.

Any ideas?
 

·
Registered
Joined
·
1,548 Posts
Go to an auto parts store like O'Reillys and ask them to scan your truck for codes. Record all the code numbers in same order as the were shown on the code reader.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I should have stated that in the original post....the truck has been scanned at my local GM dealer and it currently has no codes stored present or history.
 

·
Registered
Joined
·
2 Posts
Sorry about that /\ my trucks a 16 and does the same. No codes related. From the research I found it seems like a cracked def filter? I’m still unsure but ever 1000-3000 miles around regen time it’s let’s smoke out heavy.
 

·
Registered
Joined
·
645 Posts
My 2013 would do the same during a regen in stop and go traffic. 2 dealers said it is normal. My 08s did not leave a huge cloud of white smoke when they do regens. I've seen the same thing happen with newer Power Strokes.
 

·
Registered
Joined
·
1,669 Posts
Mine does it too, during regens, since day one. Dealer said it was normal but some say it is a problem with the "ninth injector".
 
1 - 7 of 7 Posts
Top