Chevy and GMC Duramax Diesel Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
My 2017 L5P 2500HD Denali has some rear camera problems. I've searched a few forums and I haven't seen anyone else with this problem so, I thought I would put it out there and see if anyone else does have this issue.

When it rains or I wash the truck my rear camera just turns its self on. It happens when it's raining and I'm driving down the road. It'll just come on and stay on for a second or two, sometimes longer. After washing it, sometimes it stays on for a while, I assume until the water dries and is no longer causing a short. I had taken the truck to the dealer yesterday for a bunch of issues, this being one, and they said they opened a case up with GM but the response doesn't make sense to me. They said it's because I have LED tail lights on the truck. Now I'm fairly certain this started before I put the LED tail lights on. I put them on because I managed to break one of the original lights. It's just cracked so I could put them back on but I highly doubt they are causing this camera issue that only happens when it rains / gets wet.

Has anyone else had an issue with their rear camera coming on by its self in the rain?
 

·
Premium Member
Joined
·
285 Posts
Sounds like BS to me... Yeah its a moisture issue... Amazing the crap a dealer will spew to not have to warranty an item..

Put you OEM lights back in and then video the problem when its happens again... and show em what dip shits they are
 

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Sounds like BS to me... Yeah its a moisture issue... Amazing the crap a dealer will spew to not have to warranty an item..

Put you OEM lights back in and then video the problem when its happens again... and show em what dip shits they are
Likely the only way to get them to address the issue... more time I really don't have but at around $300 for a replacement, I should probably get this settled while I'm still under factory warranty.
 

·
Registered
Joined
·
3 Posts
Hi,did you ever find out what your problem was with the rear camera?
I have a 2018 Denali with the exact same problem and I too have 2016 1500 denali led taillights installed,wonder if the are causing the problem as well...
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
18dmaxdenali, I put my original tail lights back on and don't know if it's not rained enough or what but I've had zero issues with the rear camera. I've even washed the the truck at the car wash that with the LED lights would cause the camera to act up but it hasn't with the original lights. I'll leave the original lights on the rest of the winter and we'll see if the camera acts up or not. Hard to believe but maybe it was the LED's.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Just a follow up. Since I've put my original tail lights back on I've had no issues with my back up camera. I follow a few Youtubers and this one had a problem with his build. While discovering the root cause he discusses other issues he has heard from various folks. Now I can understand why the LED tail lights could have / likely caused my issue. https://youtu.be/0geZPNaT_Nk
 

·
Registered
Joined
·
1,286 Posts
My 2017 L5P 2500HD Denali has some rear camera problems. I've searched a few forums and I haven't seen anyone else with this problem so, I thought I would put it out there and see if anyone else does have this issue.

When it rains or I wash the truck my rear camera just turns its self on. It happens when it's raining and I'm driving down the road. It'll just come on and stay on for a second or two, sometimes longer. After washing it, sometimes it stays on for a while, I assume until the water dries and is no longer causing a short. I had taken the truck to the dealer yesterday for a bunch of issues, this being one, and they said they opened a case up with GM but the response doesn't make sense to me. They said it's because I have LED tail lights on the truck. Now I'm fairly certain this started before I put the LED tail lights on. I put them on because I managed to break one of the original lights. It's just cracked so I could put them back on but I highly doubt they are causing this camera issue that only happens when it rains / gets wet.

Has anyone else had an issue with their rear camera coming on by its self in the rain?
18dmaxdenali, I put my original tail lights back on and don't know if it's not rained enough or what but I've had zero issues with the rear camera. I've even washed the the truck at the car wash that with the LED lights would cause the camera to act up but it hasn't with the original lights. I'll leave the original lights on the rest of the winter and we'll see if the camera acts up or not. Hard to believe but maybe it was the LED's.
Just a follow up. Since I've put my original tail lights back on I've had no issues with my back up camera. I follow a few Youtubers and this one had a problem with his build. While discovering the root cause he discusses other issues he has heard from various folks. Now I can understand why the LED tail lights could have / likely caused my issue. https://youtu.be/0geZPNaT_Nk
Chinese LEDs can cause all sorts of weird issues with the BCM/ECM; see the update to my thread here that describes what happened with my LED headlights. Hopefully yours stay fixed.
 

·
Premium Member
Joined
·
589 Posts
my truck back up camera would go blue every now and then, today brought back in they says camera is only getting 11.5 volts due to LED tail lights and reverse bulbs, seems strange since LED's draw less! shame I sold my old tail lights!
 

·
Registered
Joined
·
464 Posts
Sounds like BS to me... Yeah its a moisture issue... Amazing the crap a dealer will spew to not have to warranty an item..

Put you OEM lights back in and then video the problem when its happens again... and show em what dip shits they are
Insert foot here lol:oops:
 

·
Premium Member
Joined
·
589 Posts
did some research dealer told me the LED's are causing camera to see 11.3 volts so it will show blue screen, what I'm going to try is rung a lead direct to battery and sell when it goes on if it no longer faults out
 
1 - 10 of 10 Posts
Top