Chevy and GMC Duramax Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Bought this 2019 Denali new back in October 2019. Has been great up until yesterday. I went out for a break at work, and get in and fire it up. Sitting for about 5 minuets at idle the truck RPMs drop and then truck dies. Turn key off and back on, runs for another minuet or so and dies. Says service 4WD on the DIC. I go back into work, few hours later drive home and no issues.
Now today, I go on lunch break at work. Take off in stop and go style traffic. Truck has a slight surge at one point, and then next time I stop it dies. Turn key off and back on. Truck fires up. I take off and hit the throttle. Truck falls flat on its face. Let off, hit it again, it goes fine. Since then, no issues.
Doesn’t look like any codes As no light are on and service 4WD is not showing anymore. Truck has 9700 miles. I know I’ll be taking it to the stealership for the issue, and hopefully warranty covers it. Just curious if anyone knows what the problem could be? Truck is 100% stock
 

·
Registered
Joined
·
572 Posts
Change fuel filter and go from there...

Sent from my SM-G955U using Tapatalk
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
I didn’t think to do that, as the dash says “47% life left”
I’ll give it a shot though
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
Found out the issue today. Took it to the dealer, fuse block is bad. They’re on national back order. So now we wait for them to get the part and fix the truck
 
1 - 4 of 4 Posts
Top